aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2004-11-27 13:28:19 +0800
committeredwin <edwin@FreeBSD.org>2004-11-27 13:28:19 +0800
commit560b8812889540e454b6fb9fee8b625b5cb59d94 (patch)
treefd1955a2ddc11e84dc426661dc3c7c9bde36a004 /devel
parente8da455c8b52f3e784b7022328d9d536741c59a9 (diff)
downloadfreebsd-ports-gnome-560b8812889540e454b6fb9fee8b625b5cb59d94.tar.gz
freebsd-ports-gnome-560b8812889540e454b6fb9fee8b625b5cb59d94.tar.zst
freebsd-ports-gnome-560b8812889540e454b6fb9fee8b625b5cb59d94.zip
New port: devel/pear-Var_Dump Provides methods for dumping structured
information about a variable The Var_Dump class is a wrapper for the var_dump function. The var_dump function displays structured information about expressions that includes its type and value. Arrays are explored recursively with values indented to show structure. The Var_Dump class captures the output of the var_dump function, by using output control functions, and then uses external renderer classes for displaying the result in various graphical ways: * Simple text, * HTML/XHTML text, * HTML/XHTML table, * XML, * ... PR: ports/74329 Submitted by: Antônio Carlos Venâncio Júnior <antonio@php.net>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/pear-Var_Dump/Makefile34
-rw-r--r--devel/pear-Var_Dump/distinfo2
-rw-r--r--devel/pear-Var_Dump/pkg-descr16
4 files changed, 53 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index e5a99b8ab4db..f858dee513fb 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1092,6 +1092,7 @@
SUBDIR += pear-Pager
SUBDIR += pear-VFS
SUBDIR += pear-Validate
+ SUBDIR += pear-Var_Dump
SUBDIR += pear-XML_Parser
SUBDIR += pear-XML_RPC
SUBDIR += pear-XML_RSS
diff --git a/devel/pear-Var_Dump/Makefile b/devel/pear-Var_Dump/Makefile
new file mode 100644
index 000000000000..54c47f7c75be
--- /dev/null
+++ b/devel/pear-Var_Dump/Makefile
@@ -0,0 +1,34 @@
+# Ports collection makefile for: pear-Var_Dump
+# Date created: 24 November 2004
+# Whom: Antonio Carlos Venancio Junior (<antonio@inf.ufsc.br>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= Var_Dump
+PORTVERSION= 1.0.1
+CATEGORIES= devel www pear
+
+MAINTAINER= antonio@php.net
+COMMENT= Provides methods for dumping structured information about a variable
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+FILES= Var_Dump.php Var_Dump/Renderer.php Var_Dump/Renderer/Common.php \
+ Var_Dump/Renderer/Text.php Var_Dump/Renderer/Table.php \
+ Var_Dump/Renderer/HTML4_Table.php Var_Dump/Renderer/HTML4_Text.php \
+ Var_Dump/Renderer/XHTML_Table.php Var_Dump/Renderer/XHTML_Text.php \
+ Var_Dump/Renderer/XML.php
+DOCS= example-1.php example-2.php example-3.php example-4.php example-5.php \
+ example-6.php
+DATA= renderer-xml.dtd memory-usage.txt
+TESTS= test.php
+
+_DOCSDIR= .
+_TESTSDIR= .
+_DATADIR= .
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include <bsd.port.post.mk>
diff --git a/devel/pear-Var_Dump/distinfo b/devel/pear-Var_Dump/distinfo
new file mode 100644
index 000000000000..b068b3b87e70
--- /dev/null
+++ b/devel/pear-Var_Dump/distinfo
@@ -0,0 +1,2 @@
+MD5 (PEAR/Var_Dump-1.0.1.tgz) = ee4a176bec0bbf3c2111377e3e17499f
+SIZE (PEAR/Var_Dump-1.0.1.tgz) = 14843
diff --git a/devel/pear-Var_Dump/pkg-descr b/devel/pear-Var_Dump/pkg-descr
new file mode 100644
index 000000000000..567f438c0831
--- /dev/null
+++ b/devel/pear-Var_Dump/pkg-descr
@@ -0,0 +1,16 @@
+The Var_Dump class is a wrapper for the var_dump function.
+
+The var_dump function displays structured information about expressions that
+includes its type and value. Arrays are explored recursively with values
+indented to show structure.
+
+The Var_Dump class captures the output of the var_dump function, by using output
+control functions, and then uses external renderer classes for displaying the
+result in various graphical ways:
+* Simple text,
+* HTML/XHTML text,
+* HTML/XHTML table,
+* XML,
+* ...
+
+WWW: http://pear.php.net/package/Var_Dump/