aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorokazaki <okazaki@FreeBSD.org>2008-05-01 21:14:23 +0800
committerokazaki <okazaki@FreeBSD.org>2008-05-01 21:14:23 +0800
commit58ce691dc0ec4e5aee5a66f8798d67c54c5f88b3 (patch)
treef541570ce59b34eda5f7de7eae8b61c351ad2cb2 /devel
parent10529dfb86bc61c26eb6ababdb2a2ee673cee290 (diff)
downloadfreebsd-ports-gnome-58ce691dc0ec4e5aee5a66f8798d67c54c5f88b3.tar.gz
freebsd-ports-gnome-58ce691dc0ec4e5aee5a66f8798d67c54c5f88b3.tar.zst
freebsd-ports-gnome-58ce691dc0ec4e5aee5a66f8798d67c54c5f88b3.zip
Fix for 7.x ABI breakage.
PR: 120118 Submitted by: Teemu Korhonen
Diffstat (limited to 'devel')
-rw-r--r--devel/linux-js/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/devel/linux-js/Makefile b/devel/linux-js/Makefile
index a2bdbe97a335..8d150dc2580c 100644
--- a/devel/linux-js/Makefile
+++ b/devel/linux-js/Makefile
@@ -33,10 +33,6 @@ MAKE_ENV= WITHOUT_DEBUG=yes
IGNORE= requires FreeBSD 5.3 or superior
.endif
-.if ${OSVERSION} >= 700000
-IGNORE= module cannot be loaded on FreeBSD 7.x
-.endif
-
.if !exists(/usr/src/sys/Makefile)
IGNORE= requires kernel source files
.endif
@@ -55,6 +51,10 @@ MAKE_ENV+= WITHOUT_UHID=yes
post-patch:
@${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|' ${WRKSRC}/linux_js.4
+.if ${OSVERSION} >= 700000
+ @${REINPLACE_CMD} -e 's|FILEDESC_UNLOCK|FILEDESC_SUNLOCK|' ${WRKSRC}/linux_js.c
+ @${REINPLACE_CMD} -e 's|FILEDESC_LOCK|FILEDESC_SLOCK|' ${WRKSRC}/linux_js.c
+.endif
post-install:
${MKDIR} ${PREFIX}/include/linux