aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-07-26 06:50:43 +0800
committermiwi <miwi@FreeBSD.org>2008-07-26 06:50:43 +0800
commit5950453f1c9a13e41c806e4184bec88161ac2706 (patch)
treea9821967bbb95b9c6e6cfb51d135bec314aab21a /devel
parent59fec01ed62597938968a56211acda1fdf520791 (diff)
downloadfreebsd-ports-gnome-5950453f1c9a13e41c806e4184bec88161ac2706.tar.gz
freebsd-ports-gnome-5950453f1c9a13e41c806e4184bec88161ac2706.tar.zst
freebsd-ports-gnome-5950453f1c9a13e41c806e4184bec88161ac2706.zip
GitPython is a python library used to interact with
Git repositories. GitPython provides object model access to your git repository. Once you have created a repository object, you can traverse it to find parent commit(s), trees, blobs, etc. GitPython is a port of the grit library in Ruby created by Tom Preston-Werner and Chris Wanstrath. WWW: http://gitorious.org/projects/git-python/ PR: ports/125826 Submitted by: Wen Heping <wenheping at gmail.com>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-gitpython/Makefile22
-rw-r--r--devel/py-gitpython/distinfo3
-rw-r--r--devel/py-gitpython/files/patch-setup.py10
-rw-r--r--devel/py-gitpython/pkg-descr10
5 files changed, 46 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 6ce55c96de35..4825de5aa2d7 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2086,6 +2086,7 @@
SUBDIR += py-generate
SUBDIR += py-geojson
SUBDIR += py-geotypes
+ SUBDIR += py-gitpython
SUBDIR += py-gobject
SUBDIR += py-grouch
SUBDIR += py-icalendar
diff --git a/devel/py-gitpython/Makefile b/devel/py-gitpython/Makefile
new file mode 100644
index 000000000000..c4de7909dac6
--- /dev/null
+++ b/devel/py-gitpython/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: py-GitPython
+# Date created: 2006-07-18
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= GitPython
+PORTVERSION= 0.1.4.1
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= Python Git Library
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=easy_install
+
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
+
+.include <bsd.port.mk>
diff --git a/devel/py-gitpython/distinfo b/devel/py-gitpython/distinfo
new file mode 100644
index 000000000000..9a9672fec1ed
--- /dev/null
+++ b/devel/py-gitpython/distinfo
@@ -0,0 +1,3 @@
+MD5 (GitPython-0.1.4.1.tar.gz) = 8f09f5569db3822a7d0a80413180ec3f
+SHA256 (GitPython-0.1.4.1.tar.gz) = 698fb3f171ce589be284cccbfaf1e67ab43abe9d9617757b1fb5f16236fb3b4b
+SIZE (GitPython-0.1.4.1.tar.gz) = 16631
diff --git a/devel/py-gitpython/files/patch-setup.py b/devel/py-gitpython/files/patch-setup.py
new file mode 100644
index 000000000000..7d908b6ec367
--- /dev/null
+++ b/devel/py-gitpython/files/patch-setup.py
@@ -0,0 +1,10 @@
+--- setup.py.orig 2008-07-21 23:42:54.000000000 +0800
++++ setup.py 2008-07-21 23:43:00.000000000 +0800
+@@ -1,5 +1,5 @@
+-from ez_setup import use_setuptools
+-use_setuptools()
++#from ez_setup import use_setuptools
++#use_setuptools()
+ from setuptools import setup, find_packages
+ from distutils.command.build_py import build_py as _build_py
+ from setuptools.command.sdist import sdist as _sdist
diff --git a/devel/py-gitpython/pkg-descr b/devel/py-gitpython/pkg-descr
new file mode 100644
index 000000000000..9b72c4d3031c
--- /dev/null
+++ b/devel/py-gitpython/pkg-descr
@@ -0,0 +1,10 @@
+GitPython is a python library used to interact with
+Git repositories. GitPython provides object model
+access to your git repository. Once you have created
+a repository object, you can traverse it to find
+parent commit(s), trees, blobs, etc.
+
+GitPython is a port of the grit library in Ruby
+created by Tom Preston-Werner and Chris Wanstrath.
+
+WWW: http://gitorious.org/projects/git-python/