aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2011-02-07 16:04:08 +0800
committerbapt <bapt@FreeBSD.org>2011-02-07 16:04:08 +0800
commit5aa8fac3d0d48849116006cc6c792a71e48f69c6 (patch)
treefe56f803bf6aa654ac1ac55e496bec4c0de86847 /devel
parent1edf362c4dfe5af17bb76f0bbde11ecb616a0618 (diff)
downloadfreebsd-ports-gnome-5aa8fac3d0d48849116006cc6c792a71e48f69c6.tar.gz
freebsd-ports-gnome-5aa8fac3d0d48849116006cc6c792a71e48f69c6.tar.zst
freebsd-ports-gnome-5aa8fac3d0d48849116006cc6c792a71e48f69c6.zip
Simple git-compatible config file parser for Perl.
WWW: http://search.cpan.org/dist/Config-GitLike/ Feature safe: yes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Config-GitLike/Makefile33
-rw-r--r--devel/p5-Config-GitLike/distinfo2
-rw-r--r--devel/p5-Config-GitLike/pkg-descr3
-rw-r--r--devel/p5-Config-GitLike/pkg-plist8
5 files changed, 47 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 9b03ea9e5396..e69d94ba02b3 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1347,6 +1347,7 @@
SUBDIR += p5-Config-AutoConf
SUBDIR += p5-Config-Fast
SUBDIR += p5-Config-General
+ SUBDIR += p5-Config-GitLike
SUBDIR += p5-Config-INI
SUBDIR += p5-Config-INI-MVP
SUBDIR += p5-Config-INI-Simple
diff --git a/devel/p5-Config-GitLike/Makefile b/devel/p5-Config-GitLike/Makefile
new file mode 100644
index 000000000000..bcdd5a519538
--- /dev/null
+++ b/devel/p5-Config-GitLike/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: p5-Config-GitLike
+# Date created: 2011-02-07
+# Whom: Baptiste Daroussin <bapt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Config-GitLike
+PORTVERSION= 1.05
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN/../../authors/id/S/SP/SPANG/
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= bapt@FreeBSD.org
+COMMENT= Simple git-compatible config file parser for Perl
+
+BUILD_DEPENDS= devel/p5-Any-Moose>=0:${PORTSDIR}/devel/p5-Any-Moose
+
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+# for tests
+BUILD_DEPENDS+= devel/p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception
+
+MAN3+= Config::GitLike::Git.3 \
+ Config::GitLike::Cascaded.3 \
+ Config::GitLike.3
+
+PERL_CONFIGURE= yes
+
+LICENSE_COMB= dual
+LICENSE= ART20 GPLv1
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Config-GitLike/distinfo b/devel/p5-Config-GitLike/distinfo
new file mode 100644
index 000000000000..aa4f0e1732e7
--- /dev/null
+++ b/devel/p5-Config-GitLike/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Config-GitLike-1.05.tar.gz) = 75161e884f32ca25a48c9704e22c9118c7159a98994802dc00f43129ddf182e4
+SIZE (Config-GitLike-1.05.tar.gz) = 44126
diff --git a/devel/p5-Config-GitLike/pkg-descr b/devel/p5-Config-GitLike/pkg-descr
new file mode 100644
index 000000000000..a20ae16c6250
--- /dev/null
+++ b/devel/p5-Config-GitLike/pkg-descr
@@ -0,0 +1,3 @@
+Simple git-compatible config file parser for Perl.
+
+WWW: http://search.cpan.org/dist/Config-GitLike/
diff --git a/devel/p5-Config-GitLike/pkg-plist b/devel/p5-Config-GitLike/pkg-plist
new file mode 100644
index 000000000000..5dadc8125e1d
--- /dev/null
+++ b/devel/p5-Config-GitLike/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/mach/auto/Config/GitLike/.packlist
+%%SITE_PERL%%/Config/GitLike/Cascaded.pm
+%%SITE_PERL%%/Config/GitLike/Git.pm
+%%SITE_PERL%%/Config/GitLike.pm
+@dirrm %%SITE_PERL%%/mach/auto/Config/GitLike
+@dirrm %%SITE_PERL%%/mach/auto/Config
+@dirrm %%SITE_PERL%%/Config/GitLike
+@dirrm %%SITE_PERL%%/Config