aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2003-11-10 13:52:33 +0800
committerijliao <ijliao@FreeBSD.org>2003-11-10 13:52:33 +0800
commit638a09dbb0bb89c9f32c635f2b8610d7e17840fa (patch)
treed6184e2a0ac97d2363d4c54fe729d9d35b53d517 /devel
parentacfda361fb6427a84e0e2a3943b6caf7fa5fe2a2 (diff)
downloadfreebsd-ports-gnome-638a09dbb0bb89c9f32c635f2b8610d7e17840fa.tar.gz
freebsd-ports-gnome-638a09dbb0bb89c9f32c635f2b8610d7e17840fa.tar.zst
freebsd-ports-gnome-638a09dbb0bb89c9f32c635f2b8610d7e17840fa.zip
unbreak
upgrade to 1.30.2 PR: 58168 Submitted by: Keishi Katoux <k-shi_freebsd@k2factory.org> Approved by: maintainer timeout
Diffstat (limited to 'devel')
-rw-r--r--devel/boost/Makefile44
-rw-r--r--devel/boost/distinfo2
-rw-r--r--devel/boost/files/gcc-custom-tools.jam3
-rw-r--r--devel/boost/files/gcc-tools.jam.diff16
-rw-r--r--devel/boost/files/patch-gcc.hpp59
-rw-r--r--devel/boost/pkg-plist163
6 files changed, 132 insertions, 155 deletions
diff --git a/devel/boost/Makefile b/devel/boost/Makefile
index 4bec1ad1f890..ecdd44aecbf5 100644
--- a/devel/boost/Makefile
+++ b/devel/boost/Makefile
@@ -7,40 +7,46 @@
#
PORTNAME= boost
-PORTVERSION= 1.30.0
-PORTREVISION= 1
+PORTVERSION= 1.30.2
+PORTREVISION= 0
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR=${PORTNAME}
-DISTNAME= ${PORTNAME}_${PORTVERSION:S/./_/g}
+DISTNAME= ${PORTNAME}-${PORTVERSION}
MAINTAINER= pmarquis@pobox.com
COMMENT= Free peer-reviewed portable C++ source libraries
-BROKEN= "Does not build, will be removed after Feb 2"
-
MAKE_ENV+= BOOST_ROOT=${WRKSRC} BUILD="debug release"
-MAKE_ENV+= BOOST_BUILD_PATH="${WRKDIR}/gcc-custom" TOOLS="gcc-custom"
-COMPILED_LIBS= regex signals thread
-.if defined(WITHOUT_PYTHON)
-PLIST_SUB+= BOOST_PYTHON="@comment "
-.else
-PLIST_SUB+= BOOST_PYTHON=""
+
+.if defined(WITH_PYTHON)
USE_PYTHON= yes
-MAKE_ENV+= PYTHON="${PYTHON_CMD}" PYTHON_VERSION="${_PYTHON_VERSION}"
-MAKE_ENV+= PYTHON_INCLUDES="${PYTHON_INCLUDEDIR}"
-MAKE_ENV+= PYTHON_STDLIB_PATH="${PYTHON_LIBDIR}"
+# 1.30.2 doesn't support python2.3
+PYTHON_VERSION= python2.2
COMPILED_LIBS+= python
+PLIST_SUB+= BOOST_PYTHON=""
+.else
+PLIST_SUB+= BOOST_PYTHON="@comment "
.endif
+
+.include <bsd.port.pre.mk>
+
+MAKE_ENV+= PYTHON_ROOT="${PREFIX}"
+MAKE_ENV+= PYTHON_VERSION="${_PYTHON_VERSION}"
+MAKE_ENV+= PYTHON_INCLUDES="${PYTHON_INCLUDEDIR}"
+MAKE_ENV+= PYTHON_LIB_PATH="${PYTHON_LIBDIR}"
INSTALLS_SHLIB= yes
DOCFILES= *.css *.gif *.htm *.html *.jpeg *.jpg *.png
+
BJAM= ${WRKSRC}/tools/build/jam_src/bin.freebsd/bjam
+
+COMPILED_LIBS+= date_time filesystem regex signals test thread
do-configure:
- ${MKDIR} ${WRKDIR}/gcc-custom
- ${SED} -E -e 's/%%GXX%%/${CXX}/g' -e 's/%%GCC%%/${CC}/g' < \
- ${FILESDIR}/gcc-custom-tools.jam > \
- ${WRKDIR}/gcc-custom/gcc-custom-tools.jam
+# for -pthread options
+.if ${OSVERSION} >= 500016
+ cd ${WRKSRC} && patch < ${FILESDIR}/gcc-tools.jam.diff
+.endif
do-build:
cd ${WRKSRC}/tools/build/jam_src && ./build.sh gcc
@@ -60,4 +66,4 @@ do-install:
cd ${WRKSRC} && ${FIND} libs -type d -name example\* | ${TAR} cTf - - | ${TAR} xUCf ${EXAMPLESDIR} -
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/boost/distinfo b/devel/boost/distinfo
index 56ccf8f7e9f0..f69b6e432944 100644
--- a/devel/boost/distinfo
+++ b/devel/boost/distinfo
@@ -1 +1 @@
-MD5 (boost_1_30_0.tar.gz) = fe85dec53e671ea7d830936dd7423458
+MD5 (boost-1.30.2.tar.gz) = 90aa1cc62f82f50a5dfa6def6a1be32f
diff --git a/devel/boost/files/gcc-custom-tools.jam b/devel/boost/files/gcc-custom-tools.jam
deleted file mode 100644
index 029301a6b8c9..000000000000
--- a/devel/boost/files/gcc-custom-tools.jam
+++ /dev/null
@@ -1,3 +0,0 @@
-extends-toolset gcc ;
-GXX = %%GXX%% ;
-GCC = %%GCC%% ;
diff --git a/devel/boost/files/gcc-tools.jam.diff b/devel/boost/files/gcc-tools.jam.diff
new file mode 100644
index 000000000000..d2052cf52b85
--- /dev/null
+++ b/devel/boost/files/gcc-tools.jam.diff
@@ -0,0 +1,16 @@
+*** tools/build/gcc-tools.jam.orig Tue Oct 14 21:38:52 2003
+--- tools/build/gcc-tools.jam Tue Oct 14 21:50:16 2003
+***************
+*** 122,127 ****
+--- 122,132 ----
+ GCC ?= cc ;
+ GXX ?= c++ ;
+ }
++ case FreeBSD :
++ {
++ # for current which doesn't support -pthread
++ flags gcc LINKFLAGS <threading>multi : -lc_r ;
++ }
+ case *BSD :
+ {
+ flags gcc CFLAGS <threading>multi : -pthread ;
diff --git a/devel/boost/files/patch-gcc.hpp b/devel/boost/files/patch-gcc.hpp
deleted file mode 100644
index d039c8bd4415..000000000000
--- a/devel/boost/files/patch-gcc.hpp
+++ /dev/null
@@ -1,59 +0,0 @@
-*** boost/config/compiler/gcc.hpp 2003/01/30 18:13:55 1.15
---- boost/config/compiler/gcc.hpp 2003/05/19 12:11:22 1.17
-***************
-*** 28,39 ****
- # define BOOST_NO_OPERATORS_IN_NAMESPACE
- # endif
-
- //
- // Threading support: Turn this on unconditionally here (except for
-! // MinGW, where we can know for sure). It will get turned off again
- // later if no threading API is detected.
- //
-! #if !defined(__MINGW32__) || defined(_MT)
- # define BOOST_HAS_THREADS
- #endif
-
---- 28,43 ----
- # define BOOST_NO_OPERATORS_IN_NAMESPACE
- # endif
-
-+ #ifndef __EXCEPTIONS
-+ # define BOOST_NO_EXCEPTIONS
-+ #endif
-+
- //
- // Threading support: Turn this on unconditionally here (except for
-! // those platforms where we can know for sure). It will get turned off again
- // later if no threading API is detected.
- //
-! #if !defined(__MINGW32__) && !defined(__CYGWIN__) && !defined(linux) && !defined(__linux) && !defined(__linux__)
- # define BOOST_HAS_THREADS
- #endif
-
-***************
-*** 58,68 ****
- # error "Compiler not configured - please reconfigure"
- #endif
- //
-! // last known and checked version is 3.2:
-! #if (__GNUC__ > 3) || ((__GNUC__ == 3) && (__GNUC_MINOR__ > 2))
- # if defined(BOOST_ASSERT_CONFIG)
- # error "Unknown compiler version - please run the configure tests and report the results"
- # else
- # warning "Unknown compiler version - please run the configure tests and report the results"
- # endif
- #endif
---- 62,73 ----
- # error "Compiler not configured - please reconfigure"
- #endif
- //
-! // last known and checked version is 3.3:
-! #if (__GNUC__ > 3) || ((__GNUC__ == 3) && (__GNUC_MINOR__ > 3))
- # if defined(BOOST_ASSERT_CONFIG)
- # error "Unknown compiler version - please run the configure tests and report the results"
- # else
- # warning "Unknown compiler version - please run the configure tests and report the results"
- # endif
- #endif
-+
diff --git a/devel/boost/pkg-plist b/devel/boost/pkg-plist
index 1c2caf5e3c44..8f2c0595d650 100644
--- a/devel/boost/pkg-plist
+++ b/devel/boost/pkg-plist
@@ -1808,6 +1808,11 @@ include/boost/utility_fwd.hpp
include/boost/version.hpp
include/boost/visit_each.hpp
include/boost/weak_ptr.hpp
+lib/libboost_date_time.a
+lib/libboost_date_time.so
+lib/libboost_filesystem.a
+lib/libboost_prg_exec_monitor.a
+lib/libboost_prg_exec_monitor.so
%%BOOST_PYTHON%%lib/libboost_python.a
%%BOOST_PYTHON%%lib/libboost_python.so
%%BOOST_PYTHON%%lib/libboost_python_debug.a
@@ -1818,8 +1823,12 @@ lib/libboost_regex_debug.a
lib/libboost_regex_debug.so
lib/libboost_signals.a
lib/libboost_signals.so
+lib/libboost_test_exec_monitor.a
+lib/libboost_test_exec_monitor.so
lib/libboost_thread.so
lib/libboost_threadd.so
+lib/libboost_unit_test_framework.a
+lib/libboost_unit_test_framework.so
%%PORTDOCS%%share/doc/boost/boost.css
%%PORTDOCS%%share/doc/boost/c++boost.gif
%%PORTDOCS%%share/doc/boost/doc/html/any.html
@@ -1922,6 +1931,7 @@ lib/libboost_threadd.so
%%PORTDOCS%%share/doc/boost/libs/date_time/doc/BasicTerms.html
%%PORTDOCS%%share/doc/boost/libs/date_time/doc/BuildInfo.html
%%PORTDOCS%%share/doc/boost/libs/date_time/doc/Calculations.html
+%%PORTDOCS%%share/doc/boost/libs/date_time/doc/Changes.html
%%PORTDOCS%%share/doc/boost/libs/date_time/doc/DesignGoals.html
%%PORTDOCS%%share/doc/boost/libs/date_time/doc/References.html
%%PORTDOCS%%share/doc/boost/libs/date_time/doc/Tradeoffs.html
@@ -3386,10 +3396,12 @@ lib/libboost_threadd.so
%%PORTDOCS%%share/doc/boost/tools/build/como-tools.html
%%PORTDOCS%%share/doc/boost/tools/build/cwpro8-tools.html
%%PORTDOCS%%share/doc/boost/tools/build/darwin-tools.html
+%%PORTDOCS%%share/doc/boost/tools/build/edg-tools.html
%%PORTDOCS%%share/doc/boost/tools/build/gcc-nocygwin-tools.html
%%PORTDOCS%%share/doc/boost/tools/build/gcc-stlport-tools.html
%%PORTDOCS%%share/doc/boost/tools/build/gcc-tools.html
%%PORTDOCS%%share/doc/boost/tools/build/index.html
+%%PORTDOCS%%share/doc/boost/tools/build/index_v2.html
%%PORTDOCS%%share/doc/boost/tools/build/intel-linux-tools.html
%%PORTDOCS%%share/doc/boost/tools/build/intel-win32-tools.html
%%PORTDOCS%%share/doc/boost/tools/build/jam_src/Jam.html
@@ -3403,14 +3415,17 @@ lib/libboost_threadd.so
%%PORTDOCS%%share/doc/boost/tools/build/mipspro-tools.html
%%PORTDOCS%%share/doc/boost/tools/build/msvc-stlport-tools.html
%%PORTDOCS%%share/doc/boost/tools/build/msvc-tools.html
+%%PORTDOCS%%share/doc/boost/tools/build/sunpro-tools.html
%%PORTDOCS%%share/doc/boost/tools/build/test/test_system.html
%%PORTDOCS%%share/doc/boost/tools/build/tru64cxx-tools.html
%%PORTDOCS%%share/doc/boost/tools/build/vacpp-tools.html
%%PORTDOCS%%share/doc/boost/tools/build/variables.html
%%PORTDOCS%%share/doc/boost/tools/build/vc7-tools.html
+%%PORTDOCS%%share/doc/boost/tools/build/vc7.1-tools.html
%%PORTDOCS%%share/doc/boost/tools/index.html
%%PORTDOCS%%share/doc/boost/tools/inspect/index.html
%%PORTDOCS%%share/doc/boost/tools/regression/index.htm
+%%PORTDOCS%%share/doc/boost/tools/regression/xsl_reports/xsl/master.css
%%PORTDOCS%%share/examples/boost/libs/date_time/example/Jamfile
%%PORTDOCS%%share/examples/boost/libs/date_time/example/gregorian/Jamfile.v2
%%PORTDOCS%%share/examples/boost/libs/date_time/example/gregorian/dates_as_strings.cpp
@@ -3566,9 +3581,9 @@ lib/libboost_threadd.so
%%PORTDOCS%%share/examples/boost/libs/graph/example/makefile-target-names.dat
%%PORTDOCS%%share/examples/boost/libs/graph/example/max_flow.cpp
%%PORTDOCS%%share/examples/boost/libs/graph/example/max_flow.dat
+%%PORTDOCS%%share/examples/boost/libs/graph/example/max_flow.expected
%%PORTDOCS%%share/examples/boost/libs/graph/example/max_flow2.dat
%%PORTDOCS%%share/examples/boost/libs/graph/example/max_flow3.dat
-%%PORTDOCS%%share/examples/boost/libs/graph/example/max_flow.expected
%%PORTDOCS%%share/examples/boost/libs/graph/example/miles_span.cpp
%%PORTDOCS%%share/examples/boost/libs/graph/example/miles_span.expected
%%PORTDOCS%%share/examples/boost/libs/graph/example/min_max_paths.cpp
@@ -3775,7 +3790,6 @@ lib/libboost_threadd.so
%%PORTDOCS%%share/examples/boost/libs/spirit/example/application/cpp_lexer/cpp_lexer_token.hpp
%%PORTDOCS%%share/examples/boost/libs/spirit/example/application/cpp_lexer/lexer_base.hpp
%%PORTDOCS%%share/examples/boost/libs/spirit/example/application/cpp_lexer/lexer_token_base.hpp
-%%PORTDOCS%%share/examples/boost/libs/spirit/example/application/cpp_lexer/makefile
%%PORTDOCS%%share/examples/boost/libs/spirit/example/application/cpp_to_html/cpp_to_html.cpp
%%PORTDOCS%%share/examples/boost/libs/spirit/example/application/cpp_to_html/cpp_to_html_vc6_7.cpp
%%PORTDOCS%%share/examples/boost/libs/spirit/example/application/cpp_to_html/readme.txt
@@ -3813,6 +3827,7 @@ lib/libboost_threadd.so
%%PORTDOCS%%share/examples/boost/libs/spirit/example/application/quickdoc/index.html
%%PORTDOCS%%share/examples/boost/libs/spirit/example/application/quickdoc/quickdoc.cpp
%%PORTDOCS%%share/examples/boost/libs/spirit/example/application/quickdoc/quickdoc.hpp
+%%PORTDOCS%%share/examples/boost/libs/spirit/example/application/quickdoc/quickdoc.txt
%%PORTDOCS%%share/examples/boost/libs/spirit/example/application/rfcdate/mystyle.xls
%%PORTDOCS%%share/examples/boost/libs/spirit/example/application/rfcdate/peti.css
%%PORTDOCS%%share/examples/boost/libs/spirit/example/application/rfcdate/peti.dsl
@@ -3952,6 +3967,79 @@ lib/libboost_threadd.so
%%PORTDOCS%%share/examples/boost/libs/type_traits/examples/fill_example.cpp
%%PORTDOCS%%share/examples/boost/libs/type_traits/examples/iter_swap_example.cpp
%%PORTDOCS%%share/examples/boost/libs/type_traits/examples/trivial_destructor_example.cpp
+%%PORTDOCS%%@dirrm share/examples/boost/libs/type_traits/examples
+%%PORTDOCS%%@dirrm share/examples/boost/libs/type_traits
+%%PORTDOCS%%@dirrm share/examples/boost/libs/thread/example
+%%PORTDOCS%%@dirrm share/examples/boost/libs/thread
+%%PORTDOCS%%@dirrm share/examples/boost/libs/test/example
+%%PORTDOCS%%@dirrm share/examples/boost/libs/test
+%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/phoenix/example/fundamental
+%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/phoenix/example
+%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/phoenix
+%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/fundamental/position_iterator
+%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/fundamental/calc
+%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/fundamental
+%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/application/xml/goodtest
+%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/application/xml
+%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/application/slex/testfiles
+%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/application/slex
+%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/application/rfcdate
+%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/application/quickdoc/doc/theme
+%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/application/quickdoc/doc
+%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/application/quickdoc
+%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/application/pascal/test_files
+%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/application/pascal
+%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/application/cpp_to_html
+%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/application/cpp_lexer
+%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/application/c/test_files
+%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/application/c
+%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/application
+%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example
+%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit
+%%PORTDOCS%%@dirrm share/examples/boost/libs/smart_ptr/example
+%%PORTDOCS%%@dirrm share/examples/boost/libs/smart_ptr
+%%PORTDOCS%%@dirrm share/examples/boost/libs/signals/example
+%%PORTDOCS%%@dirrm share/examples/boost/libs/signals
+%%PORTDOCS%%@dirrm share/examples/boost/libs/regex/example/timer
+%%PORTDOCS%%@dirrm share/examples/boost/libs/regex/example/snippets
+%%PORTDOCS%%@dirrm share/examples/boost/libs/regex/example/jgrep
+%%PORTDOCS%%@dirrm share/examples/boost/libs/regex/example/iso8859_1_regex_traits
+%%PORTDOCS%%@dirrm share/examples/boost/libs/regex/example
+%%PORTDOCS%%@dirrm share/examples/boost/libs/regex
+%%PORTDOCS%%@dirrm share/examples/boost/libs/python/pyste/example
+%%PORTDOCS%%@dirrm share/examples/boost/libs/python/pyste
+%%PORTDOCS%%@dirrm share/examples/boost/libs/python/example/tutorial
+%%PORTDOCS%%@dirrm share/examples/boost/libs/python/example
+%%PORTDOCS%%@dirrm share/examples/boost/libs/python
+%%PORTDOCS%%@dirrm share/examples/boost/libs/preprocessor/doc/examples
+%%PORTDOCS%%@dirrm share/examples/boost/libs/preprocessor/doc
+%%PORTDOCS%%@dirrm share/examples/boost/libs/preprocessor
+%%PORTDOCS%%@dirrm share/examples/boost/libs/numeric/interval/examples
+%%PORTDOCS%%@dirrm share/examples/boost/libs/numeric/interval
+%%PORTDOCS%%@dirrm share/examples/boost/libs/numeric
+%%PORTDOCS%%@dirrm share/examples/boost/libs/multi_array/example
+%%PORTDOCS%%@dirrm share/examples/boost/libs/multi_array
+%%PORTDOCS%%@dirrm share/examples/boost/libs/mpl/example/fsm/aux_
+%%PORTDOCS%%@dirrm share/examples/boost/libs/mpl/example/fsm
+%%PORTDOCS%%@dirrm share/examples/boost/libs/mpl/example
+%%PORTDOCS%%@dirrm share/examples/boost/libs/mpl
+%%PORTDOCS%%@dirrm share/examples/boost/libs/graph/example/figs
+%%PORTDOCS%%@dirrm share/examples/boost/libs/graph/example
+%%PORTDOCS%%@dirrm share/examples/boost/libs/graph
+%%PORTDOCS%%@dirrm share/examples/boost/libs/function/example
+%%PORTDOCS%%@dirrm share/examples/boost/libs/function
+%%PORTDOCS%%@dirrm share/examples/boost/libs/format/example
+%%PORTDOCS%%@dirrm share/examples/boost/libs/format
+%%PORTDOCS%%@dirrm share/examples/boost/libs/filesystem/example
+%%PORTDOCS%%@dirrm share/examples/boost/libs/filesystem
+%%PORTDOCS%%@dirrm share/examples/boost/libs/date_time/example/posix_time
+%%PORTDOCS%%@dirrm share/examples/boost/libs/date_time/example/gregorian
+%%PORTDOCS%%@dirrm share/examples/boost/libs/date_time/example
+%%PORTDOCS%%@dirrm share/examples/boost/libs/date_time
+%%PORTDOCS%%@dirrm share/examples/boost/libs
+%%PORTDOCS%%@dirrm share/examples/boost
+%%PORTDOCS%%@dirrm share/doc/boost/tools/regression/xsl_reports/xsl
+%%PORTDOCS%%@dirrm share/doc/boost/tools/regression/xsl_reports
%%PORTDOCS%%@dirrm share/doc/boost/tools/regression
%%PORTDOCS%%@dirrm share/doc/boost/tools/inspect
%%PORTDOCS%%@dirrm share/doc/boost/tools/build/test
@@ -4091,77 +4179,6 @@ lib/libboost_threadd.so
%%PORTDOCS%%@dirrm share/doc/boost/doc/html
%%PORTDOCS%%@dirrm share/doc/boost/doc
%%PORTDOCS%%@dirrm share/doc/boost
-%%PORTDOCS%%@dirrm share/examples/boost/libs/type_traits/examples
-%%PORTDOCS%%@dirrm share/examples/boost/libs/type_traits
-%%PORTDOCS%%@dirrm share/examples/boost/libs/thread/example
-%%PORTDOCS%%@dirrm share/examples/boost/libs/thread
-%%PORTDOCS%%@dirrm share/examples/boost/libs/test/example
-%%PORTDOCS%%@dirrm share/examples/boost/libs/test
-%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/phoenix/example/fundamental
-%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/phoenix/example
-%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/phoenix
-%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/fundamental/position_iterator
-%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/fundamental/calc
-%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/fundamental
-%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/application/xml/goodtest
-%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/application/xml
-%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/application/slex/testfiles
-%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/application/slex
-%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/application/rfcdate
-%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/application/quickdoc/doc/theme
-%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/application/quickdoc/doc
-%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/application/quickdoc
-%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/application/pascal/test_files
-%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/application/pascal
-%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/application/cpp_to_html
-%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/application/cpp_lexer
-%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/application/c/test_files
-%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/application/c
-%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example/application
-%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit/example
-%%PORTDOCS%%@dirrm share/examples/boost/libs/spirit
-%%PORTDOCS%%@dirrm share/examples/boost/libs/smart_ptr/example
-%%PORTDOCS%%@dirrm share/examples/boost/libs/smart_ptr
-%%PORTDOCS%%@dirrm share/examples/boost/libs/signals/example
-%%PORTDOCS%%@dirrm share/examples/boost/libs/signals
-%%PORTDOCS%%@dirrm share/examples/boost/libs/regex/example/timer
-%%PORTDOCS%%@dirrm share/examples/boost/libs/regex/example/snippets
-%%PORTDOCS%%@dirrm share/examples/boost/libs/regex/example/jgrep
-%%PORTDOCS%%@dirrm share/examples/boost/libs/regex/example/iso8859_1_regex_traits
-%%PORTDOCS%%@dirrm share/examples/boost/libs/regex/example
-%%PORTDOCS%%@dirrm share/examples/boost/libs/regex
-%%PORTDOCS%%@dirrm share/examples/boost/libs/python/pyste/example
-%%PORTDOCS%%@dirrm share/examples/boost/libs/python/pyste
-%%PORTDOCS%%@dirrm share/examples/boost/libs/python/example/tutorial
-%%PORTDOCS%%@dirrm share/examples/boost/libs/python/example
-%%PORTDOCS%%@dirrm share/examples/boost/libs/python
-%%PORTDOCS%%@dirrm share/examples/boost/libs/preprocessor/doc/examples
-%%PORTDOCS%%@dirrm share/examples/boost/libs/preprocessor/doc
-%%PORTDOCS%%@dirrm share/examples/boost/libs/preprocessor
-%%PORTDOCS%%@dirrm share/examples/boost/libs/numeric/interval/examples
-%%PORTDOCS%%@dirrm share/examples/boost/libs/numeric/interval
-%%PORTDOCS%%@dirrm share/examples/boost/libs/numeric
-%%PORTDOCS%%@dirrm share/examples/boost/libs/multi_array/example
-%%PORTDOCS%%@dirrm share/examples/boost/libs/multi_array
-%%PORTDOCS%%@dirrm share/examples/boost/libs/mpl/example/fsm/aux_
-%%PORTDOCS%%@dirrm share/examples/boost/libs/mpl/example/fsm
-%%PORTDOCS%%@dirrm share/examples/boost/libs/mpl/example
-%%PORTDOCS%%@dirrm share/examples/boost/libs/mpl
-%%PORTDOCS%%@dirrm share/examples/boost/libs/graph/example/figs
-%%PORTDOCS%%@dirrm share/examples/boost/libs/graph/example
-%%PORTDOCS%%@dirrm share/examples/boost/libs/graph
-%%PORTDOCS%%@dirrm share/examples/boost/libs/function/example
-%%PORTDOCS%%@dirrm share/examples/boost/libs/function
-%%PORTDOCS%%@dirrm share/examples/boost/libs/format/example
-%%PORTDOCS%%@dirrm share/examples/boost/libs/format
-%%PORTDOCS%%@dirrm share/examples/boost/libs/filesystem/example
-%%PORTDOCS%%@dirrm share/examples/boost/libs/filesystem
-%%PORTDOCS%%@dirrm share/examples/boost/libs/date_time/example/posix_time
-%%PORTDOCS%%@dirrm share/examples/boost/libs/date_time/example/gregorian
-%%PORTDOCS%%@dirrm share/examples/boost/libs/date_time/example
-%%PORTDOCS%%@dirrm share/examples/boost/libs/date_time
-%%PORTDOCS%%@dirrm share/examples/boost/libs
-%%PORTDOCS%%@dirrm share/examples/boost
@dirrm include/boost/utility
@dirrm include/boost/type_traits/detail
@dirrm include/boost/type_traits
s='insertions'>+1 * - remove broken/expired ports@ portspgollucci2010-01-181-1/+0 * SKK engine for IBus.wen2010-01-051-0/+1 * The KDE FreeBSD team is proud to announce the release of KOffice2 suite for F...fluffy2009-12-221-0/+1 * New port: japanese/font-mona-ipa, a combined TrueType font ofhrs2009-11-301-0/+1 * Add japanese Slaveport of MovableTypearved2009-10-061-0/+1 * - Add new port japanese/tdiary-devel at 2.3.3tota2009-09-121-0/+1 * 2009-07-07 audio/gai-album: abandoned project, does not buildmiwi2009-07-071-1/+0 * - Update to 11.0.140395tabthorpe2009-06-141-0/+1 * Remove japanese/slirc. The port has been BROKEN of over 4 monthserwin2009-06-131-1/+0 * Convert Japanese characters.kuriyama2009-06-071-0/+1 * Add japanese/font-ipa-uigothic, a Japanese font "IPAUIGothic"hrs2009-06-031-0/+1 * OCR engine for Japanese languageamdmi32009-06-011-0/+1 * japanese/font-std, chinese/font-std, and dependency fixups duehrs2009-05-311-0/+1 * Ports for Japanese fonts have been reorganized in the following way:hrs2009-05-311-7/+8 * jd - a 2ch browserbeat2009-05-231-0/+1 * HTML::MobileJp is html tag generator for Japanese mobile phone.miwi2009-05-011-0/+1 * Add new port japanese/ibus-anthy,daichi2009-04-301-0/+1 * Japanese Mobile Phone Carrier doesn't feed any informationmiwi2009-04-271-0/+1 * Add acroread9, Adobe Reader 9.1.0. For changes since Adobe Readerhrs2009-03-291-0/+1 * 2009-02-21 japanese/ruby-tk: uses old Tk, not required with newver versionsstas2009-03-091-1/+0 * Add p5-Encode-JP-Mobile 0.25, perl extension for encoding for mobilekuriyama2009-01-231-0/+1 * icanna is a connector program between yc.el and Canna serveramdmi32009-01-131-0/+1 * Add ja-awffull port, which is supported for Japanese search words (EUC-JP/Shi...nork2008-12-311-0/+1 * - remove japenese/msdosfs: only for 5.x [1]pgollucci2008-12-281-1/+0 * 2008-09-19 japanese/escpf: Has been broken for more than 6 monthsmiwi2008-12-081-1/+0 * Remove japanese/magicpoint and merge Japanese character supporthrs2008-11-081-1/+0 * - Simplify japanese/jvim3-* variants into a single japanese/jvim3.hrs2008-10-281-8/+0 * Remove japanese/jvim and japanese/jvim-* variants because theyhrs2008-10-271-8/+0 * - Simplify japanese/onew-* variants into a single japanese/onew.hrs2008-10-271-7/+1 * - Simplify japanese/kinput2-* variants into a single japanese/kinput2.hrs2008-10-271-15/+1 * - Separate the server part and the library part from japanese/Canna, andhrs2008-10-271-1/+2 * - Separate the server part and the library part from japanese/sj3, andhrs2008-10-271-1/+2 * Remove japanese/xjman and japanese/xjman-3. These are no longerhrs2008-10-051-2/+0 * Remove ports of Adobe Reader 7 and the localized versions because ofhrs2008-09-061-1/+0 * * print/ghostscript-* and related ports have been renamed in thehrs2008-09-061-1/+0 * - Update to 1.8.0 and support emacs22pav2008-08-251-0/+1 * Remove japanese/lyx and japanese/lyx-doc because these are nohrs2008-08-191-2/+0 * The KDE FreeBSD team is proud to announce the release of KDE 4.1.0miwi2008-08-101-0/+1 * Remove japanese/kterm16c because japanese/kterm now supports thehrs2008-07-241-1/+0 * Remove japanese/samba and suggest samba3 instead, after iterwin2008-07-221-1/+0 * - Resurrect japanese/lynxpav2008-06-191-0/+1 * - Delete expired port japanese/vje30: depends on forbidden port misc/compat3xpav2008-06-191-1/+0 * - Delete expired japanese/lynx port: Leaves behind config file on deinstallpav2008-06-191-1/+0 * Remove japanese/motoya-ttfonts. The EULA is too restrictive forhrs2008-05-311-1/+0 * [MAINTAINER] japanese/latex-japanese: change portname to platex-japaneseedwin2008-05-261-1/+1 * Remove japanese/kochi-cidfonts. This CID-keyed font is suspectedhrs2008-05-251-1/+0 * Add Ume Font, another free Japanese TrueType font based onhrs2008-05-251-0/+1 * Remove japanese/truetypefonts. This TrueType font is suspectedhrs2008-05-251-1/+0 * Add port japanese/p5-Lingua-JA-Kana:sat2008-05-161-0/+1 * Remove japanese/epson-ttfonts. The EULA is too restrictive forhrs2008-05-131-1/+0 * The original babel package for LaTeX does not have an option Japanese.miwi2008-03-151-0/+1 * This plugin provides many convenient functionsmiwi2008-02-171-0/+1 * This is a python bindings for MeCab.clsung2008-01-241-0/+1 * Add Adobe Reader 8.1.1 and localized versions (total 15hrs2008-01-051-0/+1 * The free Adobe Flex 2 SDK includes the technologies developers need tokuriyama2007-12-151-0/+1 * This module implements a DateTime::Format modulemiwi2007-12-121-0/+1 * Remove expired Emacs ports and the surrounding expired ports:vd2007-10-141-15/+0 * Remove expired leaf port:vd2007-10-111-1/+0 * 2007-08-22 java/jdk11-doc: Obsolete version of jdkmiwi2007-09-191-1/+0 * New port: japanese/p5-Mail-SpamAssassinedwin2007-09-071-0/+1 * New port: japanese/ochushaedwin2007-09-071-0/+1 * As promised, remove net-im/gaim, and all dependent ports. Gaim has beenmarcus2007-09-071-1/+0 * [new port] japanese/asterisk-sounds-jp Japanese sound files for Asteriskedwin2007-09-071-0/+1 * 2007-08-19 mail/mew3-emacs20: emacs20 and related ports are obsolete; please ...miwi2007-08-191-9/+0 * 2007-08-19 www/emacs-w3m-emacs20: emacs20 and related ports are obsolete; ple...miwi2007-08-191-1/+0 * - Add japanese/lookup-emacs21 as a slave to japanese/lookupsem2007-08-091-0/+1 * Add migemo-emacs22, Japanese incremental search tool for emacs.nobutaka2007-08-041-0/+1 * Add ja-postgresql81-man 8.1.5 and ja-postgresql82-man 8.2.4,nork2007-07-161-0/+2 * Exuberant Ctags with Japanese language support.miwi2007-06-101-0/+1 * Japan traditionally used an "era" system since 645. In modern daysmiwi2007-06-041-0/+1 * Remove japanese/addttfont and japanese/p5-mkres. These ports have beenhrs2007-06-031-2/+0 * Lingua::JA::Summarize::Extract is a summary generator formiwi2007-04-161-0/+1 * 2007-03-27 emulators/kmamerun: Project was abandoned 4 years ago and expects ...miwi2007-04-111-2/+0 * New port -- uim-tomoe-gtk is an UIM helper program for Tomoe.ume2007-04-091-0/+1 * Remove dvipdfm temporarily to unbreak the INDEX build.hrs2007-04-081-1/+0 * Migrate japanese/ptex{,-base,-tetex} to japanese/ptex; the old versionhrs2007-04-081-2/+0 * - Remove expired, long time broken portspav2007-03-291-3/+0 * Remove expired ports:gabor2007-03-101-2/+0 * Mr. Lou Ohshiba is a Japanese comedian.gabor2007-02-181-0/+1