aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormm <mm@FreeBSD.org>2010-09-22 00:08:11 +0800
committermm <mm@FreeBSD.org>2010-09-22 00:08:11 +0800
commit66250384aac316bb7c7e78e17a9f60ee4eef0d73 (patch)
treeac1208411d08a7a297bc4f544163f0a43e756b59 /devel
parent48de0cba3d21dae83e5b1fed09e41e79380ef9ec (diff)
downloadfreebsd-ports-gnome-66250384aac316bb7c7e78e17a9f60ee4eef0d73.tar.gz
freebsd-ports-gnome-66250384aac316bb7c7e78e17a9f60ee4eef0d73.tar.zst
freebsd-ports-gnome-66250384aac316bb7c7e78e17a9f60ee4eef0d73.zip
Explicitly depend on p5-Digest-MD5 only if PERL_LEVEL < 500703
Explicitly depend on p5-Digest-SHA only if PERL_LEVEL < 501000
Diffstat (limited to 'devel')
-rw-r--r--devel/bugzilla/Makefile6
-rw-r--r--devel/bugzilla3/Makefile6
-rw-r--r--devel/cons/Makefile12
-rw-r--r--devel/make++/Makefile11
-rw-r--r--devel/p5-Class-Tom/Makefile15
-rw-r--r--devel/p5-Data-Throttler-Memcached/Makefile16
-rw-r--r--devel/p5-Digest-TransformPath/Makefile13
-rw-r--r--devel/p5-File-HStore/Makefile12
-rw-r--r--devel/p5-IO-Toolkit/Makefile15
-rw-r--r--devel/p5-PerlIO-via-MD5/Makefile13
10 files changed, 86 insertions, 33 deletions
diff --git a/devel/bugzilla/Makefile b/devel/bugzilla/Makefile
index 54388757d742..1bef8592e9b9 100644
--- a/devel/bugzilla/Makefile
+++ b/devel/bugzilla/Makefile
@@ -7,6 +7,7 @@
PORTNAME= bugzilla
PORTVERSION= 3.6.2
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_MOZILLA}
MASTER_SITE_SUBDIR= webtools webtools/archived
@@ -39,7 +40,6 @@ RUN_DEPENDS+= \
p5-Template-Toolkit>=2.22:${PORTSDIR}/www/p5-Template-Toolkit \
p5-DateTime>=0.28:${PORTSDIR}/devel/p5-DateTime \
p5-DateTime-TimeZone>=0.71:${PORTSDIR}/devel/p5-DateTime-TimeZone \
- p5-Digest-SHA>=0:${PORTSDIR}/security/p5-Digest-SHA \
p5-URI>=0:${PORTSDIR}/net/p5-URI \
p5-Email-Send>=2.00:${PORTSDIR}/mail/p5-Email-Send \
p5-Email-MIME>=1.861:${PORTSDIR}/mail/p5-Email-MIME
@@ -71,6 +71,10 @@ NO_BUILD=
.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 501000
+RUN_DEPENDS+= p5-Digest-SHA>=5.47:${PORTSDIR}/security/p5-Digest-SHA
+.endif
+
.ifdef WITH_MYSQL
RUN_DEPENDS+= p5-DBD-mysql>=2.9003:${PORTSDIR}/databases/p5-DBD-mysql
USE_MYSQL= yes
diff --git a/devel/bugzilla3/Makefile b/devel/bugzilla3/Makefile
index 54388757d742..1bef8592e9b9 100644
--- a/devel/bugzilla3/Makefile
+++ b/devel/bugzilla3/Makefile
@@ -7,6 +7,7 @@
PORTNAME= bugzilla
PORTVERSION= 3.6.2
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_MOZILLA}
MASTER_SITE_SUBDIR= webtools webtools/archived
@@ -39,7 +40,6 @@ RUN_DEPENDS+= \
p5-Template-Toolkit>=2.22:${PORTSDIR}/www/p5-Template-Toolkit \
p5-DateTime>=0.28:${PORTSDIR}/devel/p5-DateTime \
p5-DateTime-TimeZone>=0.71:${PORTSDIR}/devel/p5-DateTime-TimeZone \
- p5-Digest-SHA>=0:${PORTSDIR}/security/p5-Digest-SHA \
p5-URI>=0:${PORTSDIR}/net/p5-URI \
p5-Email-Send>=2.00:${PORTSDIR}/mail/p5-Email-Send \
p5-Email-MIME>=1.861:${PORTSDIR}/mail/p5-Email-MIME
@@ -71,6 +71,10 @@ NO_BUILD=
.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 501000
+RUN_DEPENDS+= p5-Digest-SHA>=5.47:${PORTSDIR}/security/p5-Digest-SHA
+.endif
+
.ifdef WITH_MYSQL
RUN_DEPENDS+= p5-DBD-mysql>=2.9003:${PORTSDIR}/databases/p5-DBD-mysql
USE_MYSQL= yes
diff --git a/devel/cons/Makefile b/devel/cons/Makefile
index 8cc488ffb019..9c7a400ddc1c 100644
--- a/devel/cons/Makefile
+++ b/devel/cons/Makefile
@@ -7,7 +7,7 @@
PORTNAME= cons
PORTVERSION= 2.2.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel
MASTER_SITES= http://www.dsmit.com/cons/stable/ \
http://www.gnu.org/software/cons/stable/ \
@@ -18,8 +18,6 @@ EXTRACT_SUFX= .tgz
MAINTAINER= rv@gnu.org
COMMENT= A Perl-based Make Replacement
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
-
USE_PERL5= yes
NO_BUILD= yes
PLIST_SUB= CONS_VER=${PORTVERSION}
@@ -30,6 +28,12 @@ DOCS= CHANGES COPYING COPYRIGHT INSTALL MANIFEST README RELEASE \
cons.html TODO
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-${PORTVERSION}
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500703
+RUN_DEPENDS+= p5-Digest-MD5>=2.16:${PORTSDIR}/security/p5-Digest-MD5
+.endif
+
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/cons ${PREFIX}/bin/cons
${INSTALL_MAN} ${WRKSRC}/cons.1.gz ${PREFIX}/man/man1/cons.1.gz
@@ -40,4 +44,4 @@ do-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/make++/Makefile b/devel/make++/Makefile
index 6b2f3b3bdbb6..299bf7d34eed 100644
--- a/devel/make++/Makefile
+++ b/devel/make++/Makefile
@@ -8,6 +8,7 @@
PORTNAME= make++
PORTVERSION= 1.19
+PORTREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= SF/makepp/makepp/${PORTVERSION}
DISTNAME= ${PORTNAME:S/+/p/g}-${PORTVERSION}
@@ -15,11 +16,15 @@ DISTNAME= ${PORTNAME:S/+/p/g}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= A drop-in replacement for GNU make
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
-
USE_PERL5= yes
DATADIR= ${PREFIX}/share/makepp
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500703
+RUN_DEPENDS+= p5-Digest-MD5>=2.16:${PORTSDIR}/security/p5-Digest-MD5
+.endif
+
do-build:
@${PERL} -pi -e "s|\@htmldir\@|${PREFIX}/share/makepp/html|g ; \
s|\@datadir\@|${PREFIX}/share/makepp|g" ${WRKSRC}/makepp
@@ -35,4 +40,4 @@ do-install:
@(cd ${WRKSRC} ; \
${FIND} . -name "*.mk" -exec ${INSTALL_SCRIPT} {} ${DATADIR} \;)
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Class-Tom/Makefile b/devel/p5-Class-Tom/Makefile
index 108c73b71cda..6eb4ffc39406 100644
--- a/devel/p5-Class-Tom/Makefile
+++ b/devel/p5-Class-Tom/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Class-Tom
PORTVERSION= 3.02
+PORTREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= Class
@@ -15,12 +16,18 @@ PKGNAMEPREFIX= p5-
MAINTAINER= tobez@FreeBSD.org
COMMENT= A perl module to transport objects from one system to another
-BUILD_DEPENDS= ${SITE_PERL}/Devel/Symdump.pm:${PORTSDIR}/devel/p5-Devel-Symdump \
- ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
-RUN_DEPENDS= ${BUILD_DEPENDS}
+BUILD_DEPENDS= ${SITE_PERL}/Devel/Symdump.pm:${PORTSDIR}/devel/p5-Devel-Symdump
+RUN_DEPENDS= ${SITE_PERL}/Devel/Symdump.pm:${PORTSDIR}/devel/p5-Devel-Symdump
PERL_CONFIGURE= yes
MAN3= Class::Tom.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500703
+RUN_DEPENDS+= p5-Digest-MD5>=2.16:${PORTSDIR}/security/p5-Digest-MD5
+BUILD_DEPENDS+= p5-Digest-MD5>=2.16:${PORTSDIR}/security/p5-Digest-MD5
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Data-Throttler-Memcached/Makefile b/devel/p5-Data-Throttler-Memcached/Makefile
index 8f1bf9756100..38be04475f3f 100644
--- a/devel/p5-Data-Throttler-Memcached/Makefile
+++ b/devel/p5-Data-Throttler-Memcached/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Data-Throttler-Memcached
PORTVERSION= 0.00003
+PORTREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -15,15 +16,20 @@ MAINTAINER= markun@onohara.to
COMMENT= Memcached-Based Data::Throttler
BUILD_DEPENDS= p5-Cache-Memcached-Managed>=0:${PORTSDIR}/databases/p5-Cache-Memcached-Managed \
- p5-Data-Throttler>=0:${PORTSDIR}/devel/p5-Data-Throttler \
- p5-Digest-MD5>=0:${PORTSDIR}/security/p5-Digest-MD5
+ p5-Data-Throttler>=0:${PORTSDIR}/devel/p5-Data-Throttler
RUN_DEPENDS= p5-Cache-Memcached-Managed>=0:${PORTSDIR}/databases/p5-Cache-Memcached-Managed \
- p5-Data-Throttler>=0:${PORTSDIR}/devel/p5-Data-Throttler \
- p5-Digest-MD5>=0:${PORTSDIR}/security/p5-Digest-MD5
+ p5-Data-Throttler>=0:${PORTSDIR}/devel/p5-Data-Throttler
PERL_CONFIGURE= yes
MAN3= Data::Throttler::Memcached.3 \
Data::Throttler::BucketChain::Memcached.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500703
+RUN_DEPENDS+= p5-Digest-MD5>=2.16:${PORTSDIR}/security/p5-Digest-MD5
+BUILD_DEPENDS+= p5-Digest-MD5>=2.16:${PORTSDIR}/security/p5-Digest-MD5
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Digest-TransformPath/Makefile b/devel/p5-Digest-TransformPath/Makefile
index 17e97fc33b45..57116a27e038 100644
--- a/devel/p5-Digest-TransformPath/Makefile
+++ b/devel/p5-Digest-TransformPath/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Digest-TransformPath
PORTVERSION= 1.00
+PORTREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,9 +15,6 @@ PKGNAMEPREFIX= p5-
MAINTAINER= coryking@mozimedia.com
COMMENT= Implements the TransformPath concept
-BUILD_DEPENDS= p5-Digest-MD5>=2.36:${PORTSDIR}/security/p5-Digest-MD5
-RUN_DEPENDS= p5-Digest-MD5>=2.36:${PORTSDIR}/security/p5-Digest-MD5
-
PERL_CONFIGURE= yes
MAN3= Digest::TransformPath.3
@@ -24,4 +22,11 @@ MAN3= Digest::TransformPath.3
test: build
(@cd ${WRKSRC} && make test)
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500809
+RUN_DEPENDS+= p5-Digest-MD5>=2.36:${PORTSDIR}/security/p5-Digest-MD5
+BUILD_DEPENDS+= p5-Digest-MD5>=2.36:${PORTSDIR}/security/p5-Digest-MD5
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-File-HStore/Makefile b/devel/p5-File-HStore/Makefile
index acdc030a666f..96ee3c8517d5 100644
--- a/devel/p5-File-HStore/Makefile
+++ b/devel/p5-File-HStore/Makefile
@@ -7,6 +7,7 @@
PORTNAME= File-HStore
PORTVERSION= 0.10
+PORTREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,10 +15,15 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Store files on a filesystem using a very simple hash-based storage
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/SHA.pm:${PORTSDIR}/security/p5-Digest-SHA
-
PERL_CONFIGURE= yes
MAN3= File::HStore.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501000
+RUN_DEPENDS+= p5-Digest-SHA>=5.47:${PORTSDIR}/security/p5-Digest-SHA
+BUILD_DEPENDS+= p5-Digest-SHA>=5.47:${PORTSDIR}/security/p5-Digest-SHA
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-IO-Toolkit/Makefile b/devel/p5-IO-Toolkit/Makefile
index f580a062e079..834fffc98ac8 100644
--- a/devel/p5-IO-Toolkit/Makefile
+++ b/devel/p5-IO-Toolkit/Makefile
@@ -7,6 +7,7 @@
PORTNAME= IO-Toolkit
PORTVERSION= 1.008
+PORTREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,12 +15,18 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ychsiao@ychsiao.org
COMMENT= IO::Toolkit - Perl extension to create logfiles
-BUILD_DEPENDS= p5-Crypt-RC6>=0:${PORTSDIR}/security/p5-Crypt-RC6 \
- p5-Digest-MD5>=0:${PORTSDIR}/security/p5-Digest-MD5
-RUN_DEPENDS= ${BUILD_DEPENDS}
+BUILD_DEPENDS= p5-Crypt-RC6>=0:${PORTSDIR}/security/p5-Crypt-RC6
+RUN_DEPENDS= p5-Crypt-RC6>=0:${PORTSDIR}/security/p5-Crypt-RC6
PERL_CONFIGURE= 5.8.0+
MAN3= IO::Toolkit.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500703
+RUN_DEPENDS+= p5-Digest-MD5>=2.16:${PORTSDIR}/security/p5-Digest-MD5
+BUILD_DEPENDS+= p5-Digest-MD5>=2.16:${PORTSDIR}/security/p5-Digest-MD5
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-PerlIO-via-MD5/Makefile b/devel/p5-PerlIO-via-MD5/Makefile
index e0e894d9bdeb..777977e7f5a3 100644
--- a/devel/p5-PerlIO-via-MD5/Makefile
+++ b/devel/p5-PerlIO-via-MD5/Makefile
@@ -7,6 +7,7 @@
PORTNAME= PerlIO-via-MD5
PORTVERSION= 0.06
+PORTREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,12 +15,16 @@ PKGNAMEPREFIX= p5-
MAINTAINER= lth@FreeBSD.org
COMMENT= PerlIO layer for creating an MD5 digest of a file
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
-RUN_DEPENDS= ${BUILD_DEPENDS}
-
PERL_CONFIGURE= 5.8.0+
USE_PERL5_REASON= requires PerlIO, which was introduced in Perl 5.8.0. Install lang/perl5.8 and try again
MAN3= PerlIO::via::MD5.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500703
+RUN_DEPENDS+= p5-Digest-MD5>=2.16:${PORTSDIR}/security/p5-Digest-MD5
+BUILD_DEPENDS+= p5-Digest-MD5>=2.16:${PORTSDIR}/security/p5-Digest-MD5
+.endif
+
+.include <bsd.port.post.mk>