aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorashish <ashish@FreeBSD.org>2017-03-29 14:50:28 +0800
committerashish <ashish@FreeBSD.org>2017-03-29 14:50:28 +0800
commit6bec7428ec6f09940f5aaacbfc2a923bf020d810 (patch)
tree3ea7a6a98fea93d62edd7b44e4c101e0dddf9589 /devel
parent1d26a8a1096d70252cc2241aa77b7f4673b09e51 (diff)
downloadfreebsd-ports-gnome-6bec7428ec6f09940f5aaacbfc2a923bf020d810.tar.gz
freebsd-ports-gnome-6bec7428ec6f09940f5aaacbfc2a923bf020d810.tar.zst
freebsd-ports-gnome-6bec7428ec6f09940f5aaacbfc2a923bf020d810.zip
- Update devel/libpthread-stubs to 0.4
- Chase libpthread-stubs update, and also switch to BUILD_DEPENDS from LIB_DEPENDS, as port is now only .pc file PR: 218015 Submitted by: rezny
Diffstat (limited to 'devel')
-rw-r--r--devel/libpthread-stubs/Makefile6
-rw-r--r--devel/libpthread-stubs/distinfo5
-rw-r--r--devel/libpthread-stubs/files/patch-Makefile.in25
-rw-r--r--devel/libpthread-stubs/files/patch-stubs.c28
-rw-r--r--devel/libpthread-stubs/pkg-plist5
5 files changed, 6 insertions, 63 deletions
diff --git a/devel/libpthread-stubs/Makefile b/devel/libpthread-stubs/Makefile
index b351f46489b3..927d19a4b3d1 100644
--- a/devel/libpthread-stubs/Makefile
+++ b/devel/libpthread-stubs/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= libpthread-stubs
-PORTVERSION= 0.3
-PORTREVISION= 6
+PORTVERSION= 0.4
CATEGORIES= devel
MASTER_SITES= http://xcb.freedesktop.org/dist/
@@ -12,7 +11,8 @@ COMMENT= This library provides weak aliases for pthread functions
USES= libtool pathfix tar:bzip2
USE_LDCONFIG= yes
-
GNU_CONFIGURE= yes
+PLIST_FILES= libdata/pkgconfig/pthread-stubs.pc
+
.include <bsd.port.mk>
diff --git a/devel/libpthread-stubs/distinfo b/devel/libpthread-stubs/distinfo
index 25e9f1bfd3a9..d7153dd96114 100644
--- a/devel/libpthread-stubs/distinfo
+++ b/devel/libpthread-stubs/distinfo
@@ -1,2 +1,3 @@
-SHA256 (libpthread-stubs-0.3.tar.bz2) = 35b6d54e3cc6f3ba28061da81af64b9a92b7b757319098172488a660e3d87299
-SIZE (libpthread-stubs-0.3.tar.bz2) = 203468
+TIMESTAMP = 1490198411
+SHA256 (libpthread-stubs-0.4.tar.bz2) = e4d05911a3165d3b18321cc067fdd2f023f06436e391c6a28dff618a78d2e733
+SIZE (libpthread-stubs-0.4.tar.bz2) = 57565
diff --git a/devel/libpthread-stubs/files/patch-Makefile.in b/devel/libpthread-stubs/files/patch-Makefile.in
deleted file mode 100644
index 6d3234911187..000000000000
--- a/devel/libpthread-stubs/files/patch-Makefile.in
+++ /dev/null
@@ -1,25 +0,0 @@
---- Makefile.in.orig
-+++ Makefile.in
-@@ -75,9 +75,9 @@
- LTLIBRARIES = $(lib_LTLIBRARIES)
- libpthread_stubs_la_LIBADD =
- am__libpthread_stubs_la_SOURCES_DIST = stubs.c
--@BUILD_LIB_TRUE@am_libpthread_stubs_la_OBJECTS = stubs.lo
-+am_libpthread_stubs_la_OBJECTS = stubs.lo
- libpthread_stubs_la_OBJECTS = $(am_libpthread_stubs_la_OBJECTS)
--@BUILD_LIB_TRUE@am_libpthread_stubs_la_rpath = -rpath $(libdir)
-+am_libpthread_stubs_la_rpath = -rpath $(libdir)
- DEFAULT_INCLUDES = -I.@am__isrc@
- depcomp = $(SHELL) $(top_srcdir)/depcomp
- am__depfiles_maybe = depfiles
-@@ -221,8 +221,8 @@
- top_srcdir = @top_srcdir@
- pkgconfigdir = $(prefix)/libdata/pkgconfig
- pkgconfig_DATA = pthread-stubs.pc
--@BUILD_LIB_TRUE@lib_LTLIBRARIES = libpthread-stubs.la
--@BUILD_LIB_TRUE@libpthread_stubs_la_SOURCES = stubs.c
-+lib_LTLIBRARIES = libpthread-stubs.la
-+libpthread_stubs_la_SOURCES = stubs.c
- all: config.h
- $(MAKE) $(AM_MAKEFLAGS) all-am
-
diff --git a/devel/libpthread-stubs/files/patch-stubs.c b/devel/libpthread-stubs/files/patch-stubs.c
deleted file mode 100644
index 4290eb2e6987..000000000000
--- a/devel/libpthread-stubs/files/patch-stubs.c
+++ /dev/null
@@ -1,28 +0,0 @@
-XXX This is a big hack as we cannot define pthread_condattr_{init,destroy}
-here, or we will conflict with the weak symbols in libthr. The way our linker
-works, the weak symbols will be resolved here, and pthread_condattr functions
-will not work even in threaded applications.
-
-I am working to get these symbols added to libc, but in the meantime, this
-is needed to avoid crashes in threaded applications which make use of
-pthread_condattr*.
---- stubs.c.orig 2009-11-27 17:15:30.000000000 -0500
-+++ stubs.c 2009-11-27 17:16:29.000000000 -0500
-@@ -91,7 +91,7 @@ int pthread_cond_destroy() __attribute__
- # endif
- #endif
-
--#ifndef HAVE_PTHREAD_CONDATTR_INIT
-+#if 0
- #define NEED_ZERO_STUB
- # ifdef SUPPORT_ATTRIBUTE_ALIAS
- int pthread_condattr_init() __attribute__ ((weak, alias ("__pthread_zero_stub")));
-@@ -100,7 +100,7 @@ int pthread_condattr_init() __attribute_
- # endif
- #endif
-
--#ifndef HAVE_PTHREAD_CONDATTR_DESTROY
-+#if 0
- #define NEED_ZERO_STUB
- # ifdef SUPPORT_ATTRIBUTE_ALIAS
- int pthread_condattr_destroy() __attribute__ ((weak, alias ("__pthread_zero_stub")));
diff --git a/devel/libpthread-stubs/pkg-plist b/devel/libpthread-stubs/pkg-plist
deleted file mode 100644
index d027c649d4ba..000000000000
--- a/devel/libpthread-stubs/pkg-plist
+++ /dev/null
@@ -1,5 +0,0 @@
-lib/libpthread-stubs.a
-lib/libpthread-stubs.so
-lib/libpthread-stubs.so.0
-lib/libpthread-stubs.so.0.0.0
-libdata/pkgconfig/pthread-stubs.pc