aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2009-04-22 09:33:33 +0800
committerlioux <lioux@FreeBSD.org>2009-04-22 09:33:33 +0800
commit6ee3eb7b6f6ddd3aa2a24629125eb3cb44507e01 (patch)
tree1e04eeaad3a453a57f8bb0726eacc6e823933b5d /devel
parenta2e4a124c003bd0b1b216f207d448dcdd59d0b3d (diff)
downloadfreebsd-ports-gnome-6ee3eb7b6f6ddd3aa2a24629125eb3cb44507e01.tar.gz
freebsd-ports-gnome-6ee3eb7b6f6ddd3aa2a24629125eb3cb44507e01.tar.zst
freebsd-ports-gnome-6ee3eb7b6f6ddd3aa2a24629125eb3cb44507e01.zip
Update to 1.6.6
Diffstat (limited to 'devel')
-rw-r--r--devel/upnp/Makefile12
-rw-r--r--devel/upnp/distinfo6
-rw-r--r--devel/upnp/files/patch-libupnp.pc.in10
-rw-r--r--devel/upnp/files/patch-upnp__src__api__upnpapi.c15
-rw-r--r--devel/upnp/pkg-plist265
5 files changed, 33 insertions, 275 deletions
diff --git a/devel/upnp/Makefile b/devel/upnp/Makefile
index 8bede36a984a..dd35027c2c1f 100644
--- a/devel/upnp/Makefile
+++ b/devel/upnp/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= upnp
-PORTVERSION= 1.6.5
+PORTVERSION= 1.6.6
PORTEPOCH= 1
CATEGORIES= devel
MASTER_SITES= SF/pupnp
@@ -23,17 +23,15 @@ USE_GNOME= gnomehack
USE_DOS2UNIX= yes
USE_LDCONFIG= yes
-MAKE_ENV= PTHREAD_LIBS=${PTHREAD_LIBS}
-CONFIGURE_ENV+= LIBS="-llwres -lcompat"
+CONFIGURE_ENV+= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
+ PTHREAD_LIBS="${PTHREAD_LIBS}"
.if defined(NOPORTDOCS)
CONFIGURE_ARGS= --without-documentation
.else
CONFIGURE_ARGS= --with-documentation=${DOCSDIR}
-.endif
-post-patch:
- ${FIND} ${WRKSRC} -type f | \
- ${XARGS} ${REINPLACE_CMD} -e 's,malloc.h,stdlib.h,'
+PORTDOCS= *
+.endif
.include <bsd.port.mk>
diff --git a/devel/upnp/distinfo b/devel/upnp/distinfo
index de1fa33c5f89..52873c215908 100644
--- a/devel/upnp/distinfo
+++ b/devel/upnp/distinfo
@@ -1,3 +1,3 @@
-MD5 (libupnp-1.6.5.tar.bz2) = 2b0370e7c405a5bc80880085e6d7d827
-SHA256 (libupnp-1.6.5.tar.bz2) = 95b11e2db04c2e714c2f4fb05d9d31351d3388dababd4e1dd5300f4b0d5e8767
-SIZE (libupnp-1.6.5.tar.bz2) = 1136968
+MD5 (libupnp-1.6.6.tar.bz2) = 8918dcf7428cd119d0c8275765ff2833
+SHA256 (libupnp-1.6.6.tar.bz2) = 58d7cabec2b21c80e28a4e5090bba94a849a8f02450e26c1b985318a36b0bbb3
+SIZE (libupnp-1.6.6.tar.bz2) = 1146854
diff --git a/devel/upnp/files/patch-libupnp.pc.in b/devel/upnp/files/patch-libupnp.pc.in
new file mode 100644
index 000000000000..3b268bc12862
--- /dev/null
+++ b/devel/upnp/files/patch-libupnp.pc.in
@@ -0,0 +1,10 @@
+--- ./libupnp.pc.in.orig 2009-04-20 09:12:51.000000000 -0300
++++ ./libupnp.pc.in 2009-04-20 09:13:30.000000000 -0300
+@@ -6,6 +6,6 @@
+ Name: libupnp
+ Description: Linux SDK for UPnP Devices
+ Version: @VERSION@
+-Libs: @PTHREAD_LIBS@ -L${libdir} -lupnp -lthreadutil -lixml
++Libs: @PTHREAD_LIBS@ -L${libdir} -lupnp -lthreadutil -lixml @LIBS@
+ Cflags: @PTHREAD_CFLAGS@ -I${includedir}/upnp
+
diff --git a/devel/upnp/files/patch-upnp__src__api__upnpapi.c b/devel/upnp/files/patch-upnp__src__api__upnpapi.c
new file mode 100644
index 000000000000..d177e23c5af8
--- /dev/null
+++ b/devel/upnp/files/patch-upnp__src__api__upnpapi.c
@@ -0,0 +1,15 @@
+--- ./upnp/src/api/upnpapi.c.orig 2009-04-20 09:15:43.000000000 -0300
++++ ./upnp/src/api/upnpapi.c 2009-04-20 09:15:55.000000000 -0300
+@@ -44,11 +44,11 @@
+
+ #ifndef WIN32
+ #include <arpa/inet.h>
++ #include <sys/socket.h>
+ #include <net/if.h>
+ #include <netinet/in.h>
+ #include <sys/ioctl.h>
+ #include <sys/param.h>
+- #include <sys/socket.h>
+ #include <sys/types.h>
+ #include <sys/utsname.h>
+
diff --git a/devel/upnp/pkg-plist b/devel/upnp/pkg-plist
index fcbe28940376..ddf0b7e351cf 100644
--- a/devel/upnp/pkg-plist
+++ b/devel/upnp/pkg-plist
@@ -21,269 +21,4 @@ lib/libupnp.la
lib/libupnp.so
lib/libupnp.so.3
libdata/pkgconfig/libupnp.pc
-%%PORTDOCS%%%%DOCSDIR%%/IXML_Programming_Guide.pdf
-%%PORTDOCS%%%%DOCSDIR%%/UPnP_Programming_Guide.pdf
-%%PORTDOCS%%%%DOCSDIR%%/examples/sample_util.c
-%%PORTDOCS%%%%DOCSDIR%%/examples/sample_util.h
-%%PORTDOCS%%%%DOCSDIR%%/examples/upnp_tv_ctrlpt.c
-%%PORTDOCS%%%%DOCSDIR%%/examples/upnp_tv_ctrlpt.h
-%%PORTDOCS%%%%DOCSDIR%%/examples/upnp_tv_ctrlpt_main.c
-%%PORTDOCS%%%%DOCSDIR%%/examples/upnp_tv_device.c
-%%PORTDOCS%%%%DOCSDIR%%/examples/upnp_tv_device.h
-%%PORTDOCS%%%%DOCSDIR%%/examples/upnp_tv_device_main.c
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/DOMInterfaces.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/General.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/IXMLAPI.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/InterfaceitAttr.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/InterfaceitCDATASection.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/InterfaceitDocument.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/InterfaceitElement.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/InterfaceitNamedNodeMap.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/InterfaceitNode.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/InterfaceitNodeList.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/Introduction.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/License.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/icon1.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/icon2.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/index.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlAttr_free.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlCDATASection_free.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlCDATASection_init.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlCloneDOMString.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlDocument_createAttribute.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlDocument_createAttributeEx.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlDocument_createAttributeNS.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlDocument_createAttributeNSEx.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlDocument_createCDATASection.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlDocument_createCDATASectionEx.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlDocument_createDocument.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlDocument_createDocumentEx.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlDocument_createElement.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlDocument_createElementEx.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlDocument_createElementNS.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlDocument_createElementNSEx.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlDocument_createTextNode.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlDocument_createTextNodeEx.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlDocument_free.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlDocument_getElementById.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlDocument_getElementsByTagName.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlDocument_getElementsByTagNameNS.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlDocument_importNode.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlDocument_init.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlDocumenttoString.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlElement_free.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlElement_getAttribute.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlElement_getAttributeNS.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlElement_getAttributeNode.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlElement_getAttributeNodeNS.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlElement_getElementsByTagName.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlElement_getElementsByTagNameNS.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlElement_getTagName.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlElement_hasAttribute.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlElement_hasAttributeNS.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlElement_init.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlElement_removeAttribute.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlElement_removeAttributeNS.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlElement_removeAttributeNode.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlElement_setAttribute.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlElement_setAttributeNS.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlElement_setAttributeNode.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlElement_setAttributeNodeNS.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlFreeDOMString.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlLoadDocument.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlLoadDocumentEx.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNamedNodeMap_free.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNamedNodeMap_getLength.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNamedNodeMap_getNamedItem.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNamedNodeMap_getNamedItemNS.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNamedNodeMap_item.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNamedNodeMap_removeNamedItem.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNamedNodeMap_removeNamedItemNS.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNamedNodeMap_setNamedItem.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNamedNodeMap_setNamedItemNS.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNodeList_free.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNodeList_item.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNodeList_length.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNode_appendChild.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNode_cloneNode.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNode_free.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNode_getAttributes.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNode_getChildNodes.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNode_getFirstChild.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNode_getLastChild.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNode_getLocalName.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNode_getNamespaceURI.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNode_getNextSibling.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNode_getNodeName.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNode_getNodeType.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNode_getNodeValue.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNode_getOwnerDocument.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNode_getParentNode.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNode_getPrefix.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNode_getPreviousSibling.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNode_hasAttributes.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNode_hasChildNodes.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNode_insertBefore.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNode_removeChild.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNode_replaceChild.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNode_setNodeValue.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlNodetoString.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlParseBuffer.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlParseBufferEx.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlPrintDocument.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlPrintNode.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/ixmlRelaxParser.html
-%%PORTDOCS%%%%DOCSDIR%%/html/ixml/toc.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/AboutCallbacks.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/ConstantsStructuresandTypes.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/Control.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/ControlPointHTTPAPI.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/Discovery.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/Errorcodes.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/Eventing.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/General.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/InitializationandRegistration.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/Introduction.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/License.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/OptionalToolAPIs.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/TheAPI.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNPREG_BUF_DESC.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNPREG_FILENAME_DESC.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNPREG_URL_DESC.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_CONTROL_ACTION_COMPLETE.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_CONTROL_ACTION_REQUEST.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_CONTROL_GET_VAR_COMPLETE.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_CONTROL_GET_VAR_REQUEST.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_DISCOVERY_ADVERTISEMENT_ALIVE.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_DISCOVERY_ADVERTISEMENT_BYEBYE.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_DISCOVERY_SEARCH_RESULT.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_DISCOVERY_SEARCH_TIMEOUT.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_EVENT_AUTORENEWAL_FAILED.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_EVENT_RECEIVED.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_EVENT_RENEWAL_COMPLETE.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_EVENT_SUBSCRIBE_COMPLETE.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_EVENT_SUBSCRIPTION_EXPIRED.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_EVENT_SUBSCRIPTION_REQUEST.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_EVENT_UNSUBSCRIBE_COMPLETE.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_ALREADY_REGISTERED-120.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_BAD_HTTPMSG-119.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_BAD_RESPONSE-113.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_CANCELED-210.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_EXT_NOT_XML-504.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_FILE_NOT_FOUND-502.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_FILE_READ_ERROR-503.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_FINISH-116.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_INIT-105.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_INIT_FAILED-117.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_INTERNAL_ERROR-911.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_INVALID_ACTION-115.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_INVALID_ARGUMENT-501.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_INVALID_DESC-107.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_INVALID_HANDLE-100.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_INVALID_PARAM-101.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_INVALID_SERVICE-111.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_INVALID_URL-108.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_LISTEN-206.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_NETWORK_ERROR-200.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_NOTIFY_UNACCEPTED-303.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_NOT_FOUND-507.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_OUTOF_HANDLE-102.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_OUTOF_MEMORY-104.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_OUTOF_SOCKET-205.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_SOCKET_BIND-203.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_SOCKET_CONNECT-204.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_SOCKET_ERROR-208.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_SOCKET_READ-202.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_SOCKET_WRITE-201.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_SUBSCRIBE_UNACCEPTED-301.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_UNSUBSCRIBE_UNACCEPTED-302.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_SUCCESS0.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_E_TIMEDOUT-207.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_S_ALL.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_S_DEVICE.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_S_ROOT.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPNP_S_SERVICE.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UPnP_EventType.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpAcceptSubscription.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpAcceptSubscriptionExt.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpAddToAction.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpAddToActionResponse.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpAddToPropertySet.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpAddVirtualDir.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpCancelHttpGet.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpClient_Handle.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpCloseHttpGet.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpCloseHttpPost.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpCreatePropertySet.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpDevice_Handle.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpDownloadUrlItem.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpDownloadXmlDoc.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpEnableWebserver.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpFinish.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpGetErrorMessage.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpGetServerIpAddress.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpGetServerPort.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpGetServiceVarStatus.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpGetServiceVarStatusAsync.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpHttpGetProgress.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpInit.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpIsWebserverEnabled.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpMakeAction.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpMakeActionResponse.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpNotify.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpNotifyExt.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpOpenHttpGet.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpOpenHttpGetEx.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpOpenHttpGetProxy.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpOpenHttpPost.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpReadHttpGet.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpRegisterClient.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpRegisterRootDevice.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpRegisterRootDevice2.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpRemoveAllVirtualDirs.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpRemoveVirtualDir.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpRenewSubscription.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpRenewSubscriptionAsync.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpResolveURL.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpSearchAsync.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpSendAction.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpSendActionAsync.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpSendActionEx.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpSendActionExAsync.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpSendAdvertisement.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpSetContentLength.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpSetMaxContentLength.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpSetMaxSubscriptionTimeOut.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpSetMaxSubscriptions.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpSetVirtualDirCallbacks.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpSetWebServerRootDir.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpSubscribe.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpSubscribeAsync.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpUnRegisterClient.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpUnRegisterRootDevice.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpUnSubscribe.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpUnSubscribeAsync.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpVirtualDirCallbacks.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/UpnpWriteHttpPost.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/Upnp_Action_Request.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/Upnp_DescType.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/Upnp_Discovery.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/Upnp_Event.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/Upnp_Event_Subscribe.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/Upnp_FunPtr.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/Upnp_SID44.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/Upnp_SType.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/Upnp_State_Var_Complete.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/Upnp_State_Var_Request.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/Upnp_Subscription_Request.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/WebServerAPI.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/icon1.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/icon2.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/index.html
-%%PORTDOCS%%%%DOCSDIR%%/html/upnp/toc.html
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/html/upnp
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/html/ixml
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/html
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/examples
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm include/upnp