aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2000-08-22 15:22:57 +0800
committerknu <knu@FreeBSD.org>2000-08-22 15:22:57 +0800
commit7011855a4d85fb668bf00e6a356a6b1dc576eb35 (patch)
treebd28c1a9c358c5afb0ebdc4725f2488fa30a361a /devel
parent1bb2dbb81158dbb3e95d3ef50fbc9362deaff89e (diff)
downloadfreebsd-ports-gnome-7011855a4d85fb668bf00e6a356a6b1dc576eb35.tar.gz
freebsd-ports-gnome-7011855a4d85fb668bf00e6a356a6b1dc576eb35.tar.zst
freebsd-ports-gnome-7011855a4d85fb668bf00e6a356a6b1dc576eb35.zip
Oops, scanner.rb was not an example, but a part of the library.. ;)
Diffstat (limited to 'devel')
-rw-r--r--devel/ruby-strscan/Makefile18
-rw-r--r--devel/ruby-strscan/pkg-plist3
2 files changed, 11 insertions, 10 deletions
diff --git a/devel/ruby-strscan/Makefile b/devel/ruby-strscan/Makefile
index 4a5088466f58..968f54d27e56 100644
--- a/devel/ruby-strscan/Makefile
+++ b/devel/ruby-strscan/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= knu@FreeBSD.org
BUILD_DEPENDS= ruby:${PORTSDIR}/lang/ruby
RUN_DEPENDS= ruby:${PORTSDIR}/lang/ruby \
- ${LOCALBASE}/lib/ruby/site_ruby/${RUBY_VER}/amstd/info.rb:${PORTSDIR}/devel/ruby-amstd
+ ${RUBY_SITELIBDIR}/amstd/info.rb:${PORTSDIR}/devel/ruby-amstd
PLIST_SUB= RUBY_VER="${RUBY_VER}" RUBY_ARCH="${RUBY_ARCH}"
@@ -24,12 +24,18 @@ RUBY?= ${LOCALBASE}/bin/ruby
RUBY_VER?= 1.4
RUBY_ARCH?= ${ARCH}-freebsd${OSREL}
+RUBY_SITELIBDIR?= ${LOCALBASE}/lib/ruby/site_ruby/${RUBY_VER}
+RUBY_SITEARCHLIBDIR?= ${LOCALBASE}/lib/ruby/site_ruby/${RUBY_VER}/${RUBY_ARCH}
+
DOCS_EN= README.en \
doc.en/changes.html doc.en/index.html \
doc.en/reference.html doc.en/usage.html
DOCS_JA= doc.ja/changes.html doc.ja/index.html \
doc.ja/reference.html doc.ja/usage.html
-EXAMPLES= lib/strscan/scanner.rb
+
+post-patch:
+ ${PERL} -i -ne '/\bstrscan\b/ and print' ${WRKSRC}/lib/PATHCONV
+ for d in amstd; do ${RM} -rf ${WRKSRC}/lib/$$d; done
do-configure:
@cd ${WRKSRC}; \
@@ -40,13 +46,9 @@ do-build:
${SETENV} ${MAKE_ENV} ${RUBY} setup.rb setup
do-install:
- ${INSTALL_DATA} ${WRKSRC}/ext/strscanso/strscan.so \
- ${PREFIX}/lib/ruby/site_ruby/${RUBY_VER}/${RUBY_ARCH}/
+ @cd ${WRKSRC}; \
+ ${SETENV} ${MAKE_ENV} ${RUBY} setup.rb install
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/examples/ruby/strscan
-.for f in ${EXAMPLES}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/examples/ruby/strscan/
-.endfor
${MKDIR} ${PREFIX}/share/doc/ruby/strscan/ja
.for f in ${DOCS_EN}
${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/doc/ruby/strscan/
diff --git a/devel/ruby-strscan/pkg-plist b/devel/ruby-strscan/pkg-plist
index ff0bb8f5acdd..483e0514cd24 100644
--- a/devel/ruby-strscan/pkg-plist
+++ b/devel/ruby-strscan/pkg-plist
@@ -1,6 +1,5 @@
lib/ruby/site_ruby/%%RUBY_VER%%/%%RUBY_ARCH%%/strscan.so
-share/examples/ruby/strscan/scanner.rb
-@dirrm share/examples/ruby/strscan
+lib/ruby/site_ruby/%%RUBY_VER%%/scanner.rb
share/doc/ruby/strscan/README.en
share/doc/ruby/strscan/changes.html
share/doc/ruby/strscan/index.html