aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2011-04-05 23:44:23 +0800
committerbapt <bapt@FreeBSD.org>2011-04-05 23:44:23 +0800
commit7099b349d66bfc00431f4dfa5c2871d82914a3c0 (patch)
treeebf413d10b61482bd8fd391a09e2b57b5fec8578 /devel
parent083716053bf315a8ac84ab9f77f5389302470f85 (diff)
downloadfreebsd-ports-gnome-7099b349d66bfc00431f4dfa5c2871d82914a3c0.tar.gz
freebsd-ports-gnome-7099b349d66bfc00431f4dfa5c2871d82914a3c0.tar.zst
freebsd-ports-gnome-7099b349d66bfc00431f4dfa5c2871d82914a3c0.zip
Path::Dispatcher - flexible and extensible dispatch for perl
WWW: http://search.cpan.org/dist/Path-Dispatcher
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Path-Dispatcher/Makefile49
-rw-r--r--devel/p5-Path-Dispatcher/distinfo2
-rw-r--r--devel/p5-Path-Dispatcher/pkg-descr3
-rw-r--r--devel/p5-Path-Dispatcher/pkg-plist28
5 files changed, 83 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 7696cb8af425..a1027744e16a 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2105,6 +2105,7 @@
SUBDIR += p5-ParseTemplate
SUBDIR += p5-PatchReader
SUBDIR += p5-Path-Class
+ SUBDIR += p5-Path-Dispatcher
SUBDIR += p5-PathTools
SUBDIR += p5-Penguin
SUBDIR += p5-Penguin-Easy
diff --git a/devel/p5-Path-Dispatcher/Makefile b/devel/p5-Path-Dispatcher/Makefile
new file mode 100644
index 000000000000..6b8c8ad2842e
--- /dev/null
+++ b/devel/p5-Path-Dispatcher/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: Path-Dispatcher
+# Date created: 2011-04-05
+# Whom: Baptiste Daroussin <bapt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Path-Dispatcher
+PORTVERSION= 1.02
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:SARTAK
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= bapt@FreeBSD.org
+COMMENT= Perl flexible and extensible dispatch
+
+LICENSE_COMB= dual
+LICENSE= ART20 GPLv1
+
+PERL_CONFIGURE= yes
+
+BUILD_DEPENDS= p5-Any-Moose>=0.12:${PORTSDIR}/devel/p5-Any-Moose \
+ p5-Try-Tiny>=0.02:${PORTSDIR}/lang/p5-Try-Tiny
+
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+MAN3= Path::Dispatcher::Path.3 \
+ Path::Dispatcher::Rule::Tokens.3 \
+ Path::Dispatcher::Rule::Sequence.3 \
+ Path::Dispatcher::Rule::Dispatch.3 \
+ Path::Dispatcher::Role::Rules.3 \
+ Path::Dispatcher::Rule::Eq.3 \
+ Path::Dispatcher.3 \
+ Path::Dispatcher::Match.3 \
+ Path::Dispatcher::Rule::CodeRef.3 \
+ Path::Dispatcher::Rule::Metadata.3 \
+ Path::Dispatcher::Rule::Enum.3 \
+ Path::Dispatcher::Rule::Empty.3 \
+ Path::Dispatcher::Cookbook.3 \
+ Path::Dispatcher::Rule::Under.3 \
+ Path::Dispatcher::Rule.3 \
+ Path::Dispatcher::Rule::Intersection.3 \
+ Path::Dispatcher::Rule::Alternation.3 \
+ Path::Dispatcher::Rule::Always.3 \
+ Path::Dispatcher::Rule::Regex.3 \
+ Path::Dispatcher::Dispatch.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Path-Dispatcher/distinfo b/devel/p5-Path-Dispatcher/distinfo
new file mode 100644
index 000000000000..f87d1546a156
--- /dev/null
+++ b/devel/p5-Path-Dispatcher/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Path-Dispatcher-1.02.tar.gz) = 457266aaf69ce1f75cec7ed9c89bfbea2d73ec07c4e7d3e5d8a151da7befb3a7
+SIZE (Path-Dispatcher-1.02.tar.gz) = 35729
diff --git a/devel/p5-Path-Dispatcher/pkg-descr b/devel/p5-Path-Dispatcher/pkg-descr
new file mode 100644
index 000000000000..6e97487fdaa7
--- /dev/null
+++ b/devel/p5-Path-Dispatcher/pkg-descr
@@ -0,0 +1,3 @@
+Path::Dispatcher - flexible and extensible dispatch for perl
+
+WWW: http://http://search.cpan.org/dist/Path-Dispatcher
diff --git a/devel/p5-Path-Dispatcher/pkg-plist b/devel/p5-Path-Dispatcher/pkg-plist
new file mode 100644
index 000000000000..12c2d09a70c8
--- /dev/null
+++ b/devel/p5-Path-Dispatcher/pkg-plist
@@ -0,0 +1,28 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Path/Dispatcher/.packlist
+%%SITE_PERL%%/Path/Dispatcher/Dispatch.pm
+%%SITE_PERL%%/Path/Dispatcher/Rule.pm
+%%SITE_PERL%%/Path/Dispatcher/Path.pm
+%%SITE_PERL%%/Path/Dispatcher/Role/Rules.pm
+%%SITE_PERL%%/Path/Dispatcher/Rule/Eq.pm
+%%SITE_PERL%%/Path/Dispatcher/Rule/Intersection.pm
+%%SITE_PERL%%/Path/Dispatcher/Rule/Dispatch.pm
+%%SITE_PERL%%/Path/Dispatcher/Rule/Empty.pm
+%%SITE_PERL%%/Path/Dispatcher/Rule/Tokens.pm
+%%SITE_PERL%%/Path/Dispatcher/Rule/Alternation.pm
+%%SITE_PERL%%/Path/Dispatcher/Rule/Under.pm
+%%SITE_PERL%%/Path/Dispatcher/Rule/Sequence.pm
+%%SITE_PERL%%/Path/Dispatcher/Rule/Metadata.pm
+%%SITE_PERL%%/Path/Dispatcher/Rule/Chain.pm
+%%SITE_PERL%%/Path/Dispatcher/Rule/Regex.pm
+%%SITE_PERL%%/Path/Dispatcher/Rule/Enum.pm
+%%SITE_PERL%%/Path/Dispatcher/Rule/CodeRef.pm
+%%SITE_PERL%%/Path/Dispatcher/Rule/Always.pm
+%%SITE_PERL%%/Path/Dispatcher/Cookbook.pod
+%%SITE_PERL%%/Path/Dispatcher/Match.pm
+%%SITE_PERL%%/Path/Dispatcher.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Path/Dispatcher
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Path
+@dirrm %%SITE_PERL%%/Path/Dispatcher/Rule
+@dirrm %%SITE_PERL%%/Path/Dispatcher/Role
+@dirrm %%SITE_PERL%%/Path/Dispatcher
+@dirrm %%SITE_PERL%%/Path