aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2011-10-04 03:35:23 +0800
committerpawel <pawel@FreeBSD.org>2011-10-04 03:35:23 +0800
commit70f63368e1c97ad205d31352088aa5d6ea014d3b (patch)
tree32103638c3ea845d067e85350fb383d47beae6f1 /devel
parent2248383bc8fd1e6cac89410024bd6276a9f9cca6 (diff)
downloadfreebsd-ports-gnome-70f63368e1c97ad205d31352088aa5d6ea014d3b.tar.gz
freebsd-ports-gnome-70f63368e1c97ad205d31352088aa5d6ea014d3b.tar.zst
freebsd-ports-gnome-70f63368e1c97ad205d31352088aa5d6ea014d3b.zip
LibParserUtils provides various pieces of functionality that are useful when
writing parsers. These are: + A number of character set convertors + Mapping of character set names to/from MIB enum values + UTF-8 and UTF-16 (host endian) support functions + Various simple data structures (resizeable buffer, stack, vector) + A UTF-8 input stream WWW: http://www.netsurf-browser.org/projects/libparserutils/ PR: ports/159935 Submitted by: David Romano <unobe@cpan.org> Approved by: miwi, wen (mentors implicit)
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/libparserutils/Makefile56
-rw-r--r--devel/libparserutils/distinfo2
-rw-r--r--devel/libparserutils/files/patch-Makefile9
-rw-r--r--devel/libparserutils/pkg-descr10
-rw-r--r--devel/libparserutils/pkg-plist21
6 files changed, 99 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index b51a85ac579d..ffc628479e12 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -875,6 +875,7 @@
SUBDIR += libowfat
SUBDIR += libpafe
SUBDIR += libpafe-ruby
+ SUBDIR += libparserutils
SUBDIR += libpasori
SUBDIR += libpci
SUBDIR += libpciaccess
diff --git a/devel/libparserutils/Makefile b/devel/libparserutils/Makefile
new file mode 100644
index 000000000000..630e5426c9c5
--- /dev/null
+++ b/devel/libparserutils/Makefile
@@ -0,0 +1,56 @@
+# ports collection makefile for: libparserutils
+# Date created: 20 August 2011
+# Whom: David Romano <unobe@cpan.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libparserutils
+PORTVERSION= 0.1.0
+CATEGORIES= devel
+MASTER_SITES= http://www.rurs.us/fbsd/ports/
+
+MAINTAINER= unobe@cpan.org
+COMMENT= A library useful when writing parsers (formerly a part of NetSurf)
+
+USE_GMAKE= yes
+
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+OPTIONS= ICONV "Adds iconv support" On \
+ STATIC "Build statically linked library" On \
+ TEST "Enable tests" On \
+ DOXYGEN "Build Doxygen Documentation" On
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_ICONV)
+CFLAGS+= -DWITH_ICONV_FILTER
+LDFLAGS+= -liconv
+.endif
+
+.if !defined(WITH_STATIC)
+USE_PERL5_BUILD=yes
+USE_LDCONFIG= yes
+COMPONENT_TYPE= lib-shared
+MAKE_ENV+= COMPONENT_TYPE=${COMPONENT_TYPE}
+PLIST_SUB+= NO_STATIC="" STATIC="@comment "
+.else
+PLIST_SUB+= NO_STATIC="@comment " STATIC=""
+.endif
+
+.if defined(WITH_TEST)
+USE_PERL5_BUILD=yes
+ALL_TARGET+= test
+.endif
+
+.if defined(WITH_DOXYGEN)
+DOXYGEN_PORTDIR=${PORTSDIR}/devel/doxygen
+BUILD_DEPENDS+= doxygen:${DOXYGEN_PORTDIR}:build
+PATH:=${PATH}:`cd ${DOXYGEN_PORTDIR}; make -V WRKSRC`/bin
+ALL_TARGET+= docs
+MAKE_ENV+= PATH=${PATH}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/libparserutils/distinfo b/devel/libparserutils/distinfo
new file mode 100644
index 000000000000..6ce5255767fb
--- /dev/null
+++ b/devel/libparserutils/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libparserutils-0.1.0.tar.gz) = 15c92598e4ecd2fcd27d421eeadf896f7ba6eb284de7b2c6f2418529b0f8325b
+SIZE (libparserutils-0.1.0.tar.gz) = 85017
diff --git a/devel/libparserutils/files/patch-Makefile b/devel/libparserutils/files/patch-Makefile
new file mode 100644
index 000000000000..786a2531a9fa
--- /dev/null
+++ b/devel/libparserutils/files/patch-Makefile
@@ -0,0 +1,9 @@
+--- Makefile.orig 2011-08-13 20:17:22.000000000 -0700
++++ Makefile 2011-08-13 20:17:30.000000000 -0700
+@@ -46,5 +46,5 @@
+ I := /include/parserutils/utils
+ INSTALL_ITEMS := $(INSTALL_ITEMS) $(I):$(Is)/buffer.h;$(Is)/stack.h;$(Is)/vector.h
+
+-INSTALL_ITEMS := $(INSTALL_ITEMS) /lib/pkgconfig:lib$(COMPONENT).pc.in
++INSTALL_ITEMS := $(INSTALL_ITEMS) /libdata/pkgconfig:lib$(COMPONENT).pc.in
+ INSTALL_ITEMS := $(INSTALL_ITEMS) /lib:$(OUTPUT)
diff --git a/devel/libparserutils/pkg-descr b/devel/libparserutils/pkg-descr
new file mode 100644
index 000000000000..5b61fe3fb951
--- /dev/null
+++ b/devel/libparserutils/pkg-descr
@@ -0,0 +1,10 @@
+LibParserUtils provides various pieces of functionality that are useful when
+writing parsers. These are:
+
+ + A number of character set convertors
+ + Mapping of character set names to/from MIB enum values
+ + UTF-8 and UTF-16 (host endian) support functions
+ + Various simple data structures (resizeable buffer, stack, vector)
+ + A UTF-8 input stream
+
+WWW: http://www.netsurf-browser.org/projects/libparserutils/
diff --git a/devel/libparserutils/pkg-plist b/devel/libparserutils/pkg-plist
new file mode 100644
index 000000000000..5fbc2c859a89
--- /dev/null
+++ b/devel/libparserutils/pkg-plist
@@ -0,0 +1,21 @@
+include/parserutils/errors.h
+include/parserutils/functypes.h
+include/parserutils/parserutils.h
+include/parserutils/types.h
+include/parserutils/charset/codec.h
+include/parserutils/charset/mibenum.h
+include/parserutils/charset/utf16.h
+include/parserutils/charset/utf8.h
+include/parserutils/input/inputstream.h
+include/parserutils/utils/buffer.h
+include/parserutils/utils/stack.h
+include/parserutils/utils/vector.h
+libdata/pkgconfig/libparserutils.pc
+%%STATIC%%lib/libparserutils.a
+%%NO_STATIC%%lib/libparserutils.so
+%%NO_STATIC%%lib/libparserutils.so.0
+%%NO_STATIC%%lib/libparserutils.so.0.1.0
+@dirrm include/parserutils/utils
+@dirrm include/parserutils/input
+@dirrm include/parserutils/charset
+@dirrm include/parserutils