aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2003-10-07 13:06:03 +0800
committervanilla <vanilla@FreeBSD.org>2003-10-07 13:06:03 +0800
commit77f6457d7aa18ec2df7038411bd8d4b0ae11f23b (patch)
treee0b099deb8b4a16c8baaebe9aa24f43f6483caa2 /devel
parentbdec4f41f7a0ce66cf6654ba6a9d6c7861146e51 (diff)
downloadfreebsd-ports-gnome-77f6457d7aa18ec2df7038411bd8d4b0ae11f23b.tar.gz
freebsd-ports-gnome-77f6457d7aa18ec2df7038411bd8d4b0ae11f23b.tar.zst
freebsd-ports-gnome-77f6457d7aa18ec2df7038411bd8d4b0ae11f23b.zip
Add p5-Shape 0.04,
perl5 module to read and write shapefiles via shapelib. PR: 51098 Submitted by: Leif Pedersen <pedersen@meridian-enviro.com>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Shape/Makefile22
-rw-r--r--devel/p5-Shape/distinfo1
-rw-r--r--devel/p5-Shape/files/patch-Shape.xs11
-rw-r--r--devel/p5-Shape/pkg-descr5
-rw-r--r--devel/p5-Shape/pkg-plist7
6 files changed, 47 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 9a3e492d5adc..50b3e0a1117a 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -755,6 +755,7 @@
SUBDIR += p5-Set-NestedGroups
SUBDIR += p5-Set-Object
SUBDIR += p5-Set-Scalar
+ SUBDIR += p5-Shape
SUBDIR += p5-Sort-ArrayOfArrays
SUBDIR += p5-Sort-Versions
SUBDIR += p5-Storable
diff --git a/devel/p5-Shape/Makefile b/devel/p5-Shape/Makefile
new file mode 100644
index 000000000000..1331a3d43559
--- /dev/null
+++ b/devel/p5-Shape/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-Shape
+# Date created: April 17th 2003
+# Whom: Leif Pedersen <pedersen@meridian-enviro.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Shape
+PORTVERSION= 0.04
+CATEGORIES= devel perl5
+MASTER_SITES= http://www.water.hut.fi/pub/Grid/
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= pedersen@meridian-enviro.com
+COMMENT= Perl5 module to read and write shapefiles via shapelib
+
+LIB_DEPENDS= shp:${PORTSDIR}/devel/shapelib
+
+PERL_CONFIGURE= yes
+MAN3= Shape.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Shape/distinfo b/devel/p5-Shape/distinfo
new file mode 100644
index 000000000000..e83dafc68500
--- /dev/null
+++ b/devel/p5-Shape/distinfo
@@ -0,0 +1 @@
+MD5 (Shape-0.04.tar.gz) = c55b699cbac1c4850e0966860a9db444
diff --git a/devel/p5-Shape/files/patch-Shape.xs b/devel/p5-Shape/files/patch-Shape.xs
new file mode 100644
index 000000000000..bb3c71acd5a1
--- /dev/null
+++ b/devel/p5-Shape/files/patch-Shape.xs
@@ -0,0 +1,11 @@
+--- Shape.xs.orig Tue Oct 7 05:38:12 2003
++++ Shape.xs Tue Oct 7 05:38:19 2003
+@@ -2,7 +2,7 @@
+ #include "perl.h"
+ #include "XSUB.h"
+
+-#include <libshp/shapefil.h>
++#include <shapefil.h>
+
+
+ MODULE = Shape PACKAGE = Shape
diff --git a/devel/p5-Shape/pkg-descr b/devel/p5-Shape/pkg-descr
new file mode 100644
index 000000000000..faca1026c6b2
--- /dev/null
+++ b/devel/p5-Shape/pkg-descr
@@ -0,0 +1,5 @@
+This is a library for reading, creating, and writing ArcView(c)
+shapefiles using Perl. The Perl code uses Frank Warmerdam's Shapefile
+C Library.
+
+WWW: http://www.water.hut.fi/pub/Grid/Shape.html
diff --git a/devel/p5-Shape/pkg-plist b/devel/p5-Shape/pkg-plist
new file mode 100644
index 000000000000..9f1f2dde67af
--- /dev/null
+++ b/devel/p5-Shape/pkg-plist
@@ -0,0 +1,7 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Shape.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Shape/Shape.so
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Shape/Shape.bs
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Shape/autosplit.ix
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Shape/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Shape
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Shape 2>/dev/null || true