aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authortobez <tobez@FreeBSD.org>2009-09-23 22:42:08 +0800
committertobez <tobez@FreeBSD.org>2009-09-23 22:42:08 +0800
commit78bff00137af988f3b68d7ffd49861486a972323 (patch)
tree7d26a2bdd9e018a53d26b4cb6c967576e08e34b1 /devel
parent3cb001603f887c5ca061b52bc1f7045cba45e6a8 (diff)
downloadfreebsd-ports-gnome-78bff00137af988f3b68d7ffd49861486a972323.tar.gz
freebsd-ports-gnome-78bff00137af988f3b68d7ffd49861486a972323.tar.zst
freebsd-ports-gnome-78bff00137af988f3b68d7ffd49861486a972323.zip
Add devel/p5-Proc-Wait3, a Perl extension for wait3 system call.
Feature safe: yes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Proc-Wait3/Makefile22
-rw-r--r--devel/p5-Proc-Wait3/distinfo3
-rw-r--r--devel/p5-Proc-Wait3/pkg-descr8
-rw-r--r--devel/p5-Proc-Wait3/pkg-plist7
5 files changed, 41 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index cd188bb42a81..ec92daf49d1b 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1796,6 +1796,7 @@
SUBDIR += p5-Proc-Queue
SUBDIR += p5-Proc-Reliable
SUBDIR += p5-Proc-Simple
+ SUBDIR += p5-Proc-Wait3
SUBDIR += p5-Project-Gantt
SUBDIR += p5-RRDTool-OO
SUBDIR += p5-Rcs
diff --git a/devel/p5-Proc-Wait3/Makefile b/devel/p5-Proc-Wait3/Makefile
new file mode 100644
index 000000000000..61005bc3be13
--- /dev/null
+++ b/devel/p5-Proc-Wait3/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: devel/p5-Proc-Wait3
+# Date created: 23 September 2009
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Proc-Wait3
+PORTVERSION= 0.03
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= Proc
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= Perl extension for wait3 system call
+
+PERL_CONFIGURE= yes
+
+MAN3= Proc::Wait3.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Proc-Wait3/distinfo b/devel/p5-Proc-Wait3/distinfo
new file mode 100644
index 000000000000..dcfb07128fd9
--- /dev/null
+++ b/devel/p5-Proc-Wait3/distinfo
@@ -0,0 +1,3 @@
+MD5 (Proc-Wait3-0.03.tar.gz) = af5b362f3d1db4af8c34495b63f33c90
+SHA256 (Proc-Wait3-0.03.tar.gz) = 77bac5f02740f95918bb08f47142aa1e08babacd855cf0713216a6e92aa3eb36
+SIZE (Proc-Wait3-0.03.tar.gz) = 2962
diff --git a/devel/p5-Proc-Wait3/pkg-descr b/devel/p5-Proc-Wait3/pkg-descr
new file mode 100644
index 000000000000..d9109165db4a
--- /dev/null
+++ b/devel/p5-Proc-Wait3/pkg-descr
@@ -0,0 +1,8 @@
+Proc::Wait3 module implements wait3 system call in Perl.
+If any child processes have exited, this call will "reap" the zombies
+similar to the perl "wait" function. By default, it will return
+immediately and if there are no dead children, everything will be
+undefined. If you pass in a true argument, it will block until a child
+exits (or it gets a signal).
+
+WWW: http://search.cpan.org/dist/Proc-Wait3/
diff --git a/devel/p5-Proc-Wait3/pkg-plist b/devel/p5-Proc-Wait3/pkg-plist
new file mode 100644
index 000000000000..b3d306079b2f
--- /dev/null
+++ b/devel/p5-Proc-Wait3/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/Proc/Wait3.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Proc/Wait3/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Proc/Wait3/Wait3.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Proc/Wait3/Wait3.so
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Proc/Wait3
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Proc
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Proc