aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2006-07-07 01:49:52 +0800
committergarga <garga@FreeBSD.org>2006-07-07 01:49:52 +0800
commit79037c505debebe40f5e8d3f11da9172acbaf3cc (patch)
tree985f0a26e3237ddd9e3c93c548b92f6947ce7ef3 /devel
parent13e8c3ae4e3698c07a1dcf3e42394cbdc1be61f0 (diff)
downloadfreebsd-ports-gnome-79037c505debebe40f5e8d3f11da9172acbaf3cc.tar.gz
freebsd-ports-gnome-79037c505debebe40f5e8d3f11da9172acbaf3cc.tar.zst
freebsd-ports-gnome-79037c505debebe40f5e8d3f11da9172acbaf3cc.zip
OUnit is a unit testing framework for Objective Caml, inspired by
the JUnit tool for Java, and the HUnit tool for Haskell. WWW: http://home.wanadoo.nl/maas/ocaml PR: ports/93957 Submitted by: Meikel Brandmeyer <ocaml-ounit-port at kotka.de>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/ocaml-ounit/Makefile41
-rw-r--r--devel/ocaml-ounit/distinfo3
-rw-r--r--devel/ocaml-ounit/pkg-descr4
-rw-r--r--devel/ocaml-ounit/pkg-plist8
5 files changed, 57 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 519e4217adeb..e02f6cd58bc5 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -687,6 +687,7 @@
SUBDIR += ocaml-extlib
SUBDIR += ocaml-findlib
SUBDIR += ocaml-magic
+ SUBDIR += ocaml-ounit
SUBDIR += ocaml-pcre
SUBDIR += ocaml-sdl
SUBDIR += ocaml-sem
diff --git a/devel/ocaml-ounit/Makefile b/devel/ocaml-ounit/Makefile
new file mode 100644
index 000000000000..35240b6d5af7
--- /dev/null
+++ b/devel/ocaml-ounit/Makefile
@@ -0,0 +1,41 @@
+# Ports collection makefile for: ocaml-ounit
+# Date created: 28th February 2006
+# Whom: Meikel Brandmeyer <ocaml-ounit-port@kotka.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ounit
+PORTVERSION= 1.0.2
+CATEGORIES= devel
+MASTER_SITES= http://www.xs4all.nl/~mmzeeman/ocaml/
+PKGNAMEPREFIX= ocaml-
+
+MAINTAINER= ocaml-ounit-port@kotka.de
+COMMENT= OCaml unit test framework
+
+BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml \
+ ocamlfind:${PORTSDIR}/devel/ocaml-findlib
+
+USE_GMAKE= yes
+
+DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
+PORTDOCS= README style.css *.html
+
+ALL_TARGET= all allopt testall doc
+
+MAKE_ENV= OCAMLFIND_DESTDIR=${PREFIX}/lib/ocaml/site-lib
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${ECHO_MSG} "==> Installing port documentation for ${PKGORIGIN}..."
+ @${MKDIR} ${DOCSDIR}
+ @( cd ${WRKSRC}; ${INSTALL_DATA} README ${DOCSDIR} )
+ @( cd ${WRKSRC}/doc; \
+ ${INSTALL_DATA} style.css ${DOCSDIR}; \
+ for f in `${FIND} . -type f -name \\*.html -print`; do \
+ ${INSTALL_DATA} $${f} ${DOCSDIR}; \
+ done )
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/ocaml-ounit/distinfo b/devel/ocaml-ounit/distinfo
new file mode 100644
index 000000000000..037fa4bb2e2b
--- /dev/null
+++ b/devel/ocaml-ounit/distinfo
@@ -0,0 +1,3 @@
+MD5 (ounit-1.0.2.tar.gz) = 27320856992f0d1b9b0abc186df2e552
+SHA256 (ounit-1.0.2.tar.gz) = 3ab40dfe4202aa83fa0309d1265b30e1acd633fec1ad728e5b463dde07737e13
+SIZE (ounit-1.0.2.tar.gz) = 9806
diff --git a/devel/ocaml-ounit/pkg-descr b/devel/ocaml-ounit/pkg-descr
new file mode 100644
index 000000000000..e13b433093af
--- /dev/null
+++ b/devel/ocaml-ounit/pkg-descr
@@ -0,0 +1,4 @@
+OUnit is a unit testing framework for Objective Caml, inspired by
+the JUnit tool for Java, and the HUnit tool for Haskell.
+
+WWW: http://home.wanadoo.nl/maas/ocaml
diff --git a/devel/ocaml-ounit/pkg-plist b/devel/ocaml-ounit/pkg-plist
new file mode 100644
index 000000000000..a009cba84047
--- /dev/null
+++ b/devel/ocaml-ounit/pkg-plist
@@ -0,0 +1,8 @@
+lib/ocaml/site-lib/oUnit/oUnit.a
+lib/ocaml/site-lib/oUnit/oUnit.cmxa
+lib/ocaml/site-lib/oUnit/oUnit.cma
+lib/ocaml/site-lib/oUnit/oUnit.cmi
+lib/ocaml/site-lib/oUnit/oUnit.mli
+lib/ocaml/site-lib/oUnit/META
+@dirrm lib/ocaml/site-lib/oUnit
+@unexec ocamlfind remove oUnit 2> /dev/null || true