aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorvs <vs@FreeBSD.org>2007-11-09 16:10:48 +0800
committervs <vs@FreeBSD.org>2007-11-09 16:10:48 +0800
commit7a346459b802b9272efcb27617d9d2180c1d938a (patch)
tree5f86d92fbc1d539e70fbb7785ba4e9ebf99290bf /devel
parent24571585711c6d1894015d12213aad7bde909e35 (diff)
downloadfreebsd-ports-gnome-7a346459b802b9272efcb27617d9d2180c1d938a.tar.gz
freebsd-ports-gnome-7a346459b802b9272efcb27617d9d2180c1d938a.tar.zst
freebsd-ports-gnome-7a346459b802b9272efcb27617d9d2180c1d938a.zip
Fix packaging by not creating an empty directory and removing a temporary file.
Approved by: portmgr (linimon)
Diffstat (limited to 'devel')
-rw-r--r--devel/hs-hpl/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/devel/hs-hpl/Makefile b/devel/hs-hpl/Makefile
index 3e1f4803aca5..b9ba4f6097cd 100644
--- a/devel/hs-hpl/Makefile
+++ b/devel/hs-hpl/Makefile
@@ -29,6 +29,7 @@ CABALCMD= ${LOCALBASE}/bin/runghc Setup.lhs
PLIST_SUB= PORTVERSION="${PORTVERSION}" \
HSPORTNAME="${HSPORTNAME}" \
+ GHC_VERSION="${GHC_VERSION}" \
SUBDIR=lib/ghc-${GHC_VERSION}/cabal
CONFIGURE_ARGS= --ghc --prefix=${PREFIX} --libdir=${CABALDIR} \
@@ -48,4 +49,7 @@ do-install:
cd ${WRKSRC} && ${CABALCMD} install \
&& ${INSTALL_SCRIPT} ${WRKSRC}/register.sh ${CABALDIR}/${HSPORTNAME}-register.sh
+post-install:
+ @${RMDIR} ${CABALDIR}/include # empty
+
.include <bsd.port.post.mk>