aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-03-16 01:17:33 +0800
committermiwi <miwi@FreeBSD.org>2009-03-16 01:17:33 +0800
commit7f2dddf97c6edc75100604fcf33fc5c55978709a (patch)
tree3f3eb38c904252538688454e69b560532759c549 /devel
parent5a6cdcc36092eed055ce86a3d1caff4c3a551e33 (diff)
downloadfreebsd-ports-gnome-7f2dddf97c6edc75100604fcf33fc5c55978709a.tar.gz
freebsd-ports-gnome-7f2dddf97c6edc75100604fcf33fc5c55978709a.tar.zst
freebsd-ports-gnome-7f2dddf97c6edc75100604fcf33fc5c55978709a.zip
Unloads the given class by clearing out its symbol table and removing
it from %INC. SYNOPSIS use Class::Unload; use Class::Inspector; use Some::Class; Class::Unload->unload( 'Some::Class' ); Class::Inspector->loaded( 'Some::Class' ); # Returns false require Some::Class; # Reloads the class WWW: http://search.cpan.org/dist/Class-Unload/ PR: ports/132406 Submitted by: Cezary Morga <cm at therek.net>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Class-Unload/Makefile24
-rw-r--r--devel/p5-Class-Unload/distinfo3
-rw-r--r--devel/p5-Class-Unload/pkg-descr16
-rw-r--r--devel/p5-Class-Unload/pkg-plist4
5 files changed, 48 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 8d33d6055626..4e7d33fcc2f0 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1092,6 +1092,7 @@
SUBDIR += p5-Class-Throwable
SUBDIR += p5-Class-Tom
SUBDIR += p5-Class-Trigger
+ SUBDIR += p5-Class-Unload
SUBDIR += p5-Class-Virtual
SUBDIR += p5-Class-WhiteHole
SUBDIR += p5-Class-Workflow
diff --git a/devel/p5-Class-Unload/Makefile b/devel/p5-Class-Unload/Makefile
new file mode 100644
index 000000000000..daeac5d38d24
--- /dev/null
+++ b/devel/p5-Class-Unload/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-Class-Unload
+# Date created: March 8th 2009
+# Whom: Cezary Morga <cm@therek.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Class-Unload
+PORTVERSION= 0.05
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= cm@therek.net
+COMMENT= Perl5 module for unloading classes
+
+BUILD_DEPENDS= ${SITE_PERL}/Class/Inspector.pm:${PORTSDIR}/devel/p5-Class-Inspector
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= YES
+
+MAN3= Class::Unload.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Class-Unload/distinfo b/devel/p5-Class-Unload/distinfo
new file mode 100644
index 000000000000..817362a97aca
--- /dev/null
+++ b/devel/p5-Class-Unload/distinfo
@@ -0,0 +1,3 @@
+MD5 (Class-Unload-0.05.tar.gz) = 497de4c5c959b328356569a7e423fecc
+SHA256 (Class-Unload-0.05.tar.gz) = 01807226cd9a6b5b1c6a02cf8408ab09e0e76e7d70f06f6d3fe3af6e41906005
+SIZE (Class-Unload-0.05.tar.gz) = 15136
diff --git a/devel/p5-Class-Unload/pkg-descr b/devel/p5-Class-Unload/pkg-descr
new file mode 100644
index 000000000000..0ab405212add
--- /dev/null
+++ b/devel/p5-Class-Unload/pkg-descr
@@ -0,0 +1,16 @@
+Unloads the given class by clearing out its symbol table and removing
+it from %INC.
+
+SYNOPSIS
+
+ use Class::Unload;
+ use Class::Inspector;
+
+ use Some::Class;
+
+ Class::Unload->unload( 'Some::Class' );
+ Class::Inspector->loaded( 'Some::Class' ); # Returns false
+
+ require Some::Class; # Reloads the class
+
+WWW: http://search.cpan.org/dist/Class-Unload/
diff --git a/devel/p5-Class-Unload/pkg-plist b/devel/p5-Class-Unload/pkg-plist
new file mode 100644
index 000000000000..a39a7afcbf8e
--- /dev/null
+++ b/devel/p5-Class-Unload/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Class/Unload/.packlist
+%%SITE_PERL%%/Class/Unload.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Class/Unload
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Class