aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2013-09-10 15:12:35 +0800
committeraz <az@FreeBSD.org>2013-09-10 15:12:35 +0800
commit8097b663e50ab32273b5f98b9a338bc90d672cc4 (patch)
tree93d2de2f9a4bf6801932ddc030f955193b833745 /devel
parent891b9180e52d3411847318aa83e36de37c7508c6 (diff)
downloadfreebsd-ports-gnome-8097b663e50ab32273b5f98b9a338bc90d672cc4.tar.gz
freebsd-ports-gnome-8097b663e50ab32273b5f98b9a338bc90d672cc4.tar.zst
freebsd-ports-gnome-8097b663e50ab32273b5f98b9a338bc90d672cc4.zip
- convert to the new perl5 framework
- trim Makefile header Approved by: portmgr (bapt@, blanket)
Diffstat (limited to 'devel')
-rw-r--r--devel/autoconf/Makefile8
-rw-r--r--devel/mingw32-openssl/Makefile9
-rw-r--r--devel/p5-Class-Std/Makefile9
-rw-r--r--devel/p5-Data-Swap/Makefile9
-rw-r--r--devel/p5-POEx-Role-Streaming/Makefile8
-rw-r--r--devel/p5-Qudo/Makefile8
-rw-r--r--devel/p5-Template-Provider-Encode/Makefile9
-rw-r--r--devel/p5-uni-perl/Makefile9
8 files changed, 21 insertions, 48 deletions
diff --git a/devel/autoconf/Makefile b/devel/autoconf/Makefile
index d81fbf822f65..fc6cac135706 100644
--- a/devel/autoconf/Makefile
+++ b/devel/autoconf/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: autoconf
-# Date created: 7th December 2006
-# Whom: ade@FreeBSD.org
-#
+# Created by: ade@FreeBSD.org
# $FreeBSD$
-#
PORTNAME= autoconf
PORTVERSION= 2.69
@@ -24,7 +20,7 @@ BUILD_VERSION= 2.69
PLIST_SUB= BUILD_VERSION=${BUILD_VERSION}
USE_XZ= yes
USE_GMAKE= yes
-USE_PERL5= yes
+USES= perl5
INFO= autoconf
GNU_CONFIGURE= yes
diff --git a/devel/mingw32-openssl/Makefile b/devel/mingw32-openssl/Makefile
index 290780e73946..051cdd201202 100644
--- a/devel/mingw32-openssl/Makefile
+++ b/devel/mingw32-openssl/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: mingw32-openssl
-# Date created: 5 December 2011
-# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
-#
+# Created by: Akinori MUSHA aka knu <knu@idaemons.org>
# $FreeBSD$
-#
PORTNAME= openssl
PORTVERSION= 1.0.0k
@@ -23,7 +19,8 @@ BUILD_DEPENDS= makedepend:${PORTSDIR}/devel/makedepend \
${LOCALBASE}/mingw32/include/stdlib.h:${PORTSDIR}/devel/${PKGNAMEPREFIX}bin-msvcrt \
${LOCALBASE}/mingw32/lib/libz.a:${PORTSDIR}/devel/mingw32-zlib
-USE_PERL5_BUILD= yes
+USES= perl5
+USE_PERL5= build
MAKE_JOBS_UNSAFE= yes
CONFIGURE_PREFIX= ${PREFIX}/mingw32
OPENSSLDIR= ${CONFIGURE_PREFIX}/openssl
diff --git a/devel/p5-Class-Std/Makefile b/devel/p5-Class-Std/Makefile
index dd43c79f7a39..5d5aec2fbdb4 100644
--- a/devel/p5-Class-Std/Makefile
+++ b/devel/p5-Class-Std/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Class-Std
-# Date created: 30 May 2006
-# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
-#
+# Created by: Andrew Pantyukhin <infofarmer@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Class-Std
DISTVERSION= 0.011
@@ -17,7 +13,8 @@ COMMENT= Support for creating standard "inside-out" classes
BUILD_DEPENDS= p5-version>=0:${PORTSDIR}/devel/p5-version
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= YES
+USES= perl5
+USE_PERL5= configure
MAN3= Class::Std.3
diff --git a/devel/p5-Data-Swap/Makefile b/devel/p5-Data-Swap/Makefile
index 92183dd7e1f2..77c8fbf8d462 100644
--- a/devel/p5-Data-Swap/Makefile
+++ b/devel/p5-Data-Swap/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Data::Swap
-# Date created: 10 December 2005
-# Whom: Parv <parv@pair.org>
-#
+# Created by: Parv <parv@pair.org>
# $FreeBSD$
-#
PORTNAME= Data-Swap
PORTVERSION= 0.08
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= parv@pair.com
COMMENT= XS module to swap the contents and types of referenced variables
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Data::Swap.3
diff --git a/devel/p5-POEx-Role-Streaming/Makefile b/devel/p5-POEx-Role-Streaming/Makefile
index e6852adb2474..9b0e55b63222 100644
--- a/devel/p5-POEx-Role-Streaming/Makefile
+++ b/devel/p5-POEx-Role-Streaming/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: POEx::Role::Streaming
-# Date created: 10 Oct 2010
-# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= POEx-Role-Streaming
PORTVERSION= 1.102610
@@ -24,7 +19,8 @@ RUN_DEPENDS= \
p5-aliased>0:${PORTSDIR}/devel/p5-aliased
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= POEx::Role::Streaming.3
diff --git a/devel/p5-Qudo/Makefile b/devel/p5-Qudo/Makefile
index ba24a4734f6c..ba6d9ccf75bc 100644
--- a/devel/p5-Qudo/Makefile
+++ b/devel/p5-Qudo/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: Qudo
-# Date created: 27 Jun 2012
-# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= Qudo
PORTVERSION= 0.0213
@@ -23,7 +18,8 @@ RUN_DEPENDS= \
p5-YAML>0:${PORTSDIR}/textproc/p5-YAML
BUILD_DEPENDS= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Qudo.3 \
Qudo::Manager.3 \
diff --git a/devel/p5-Template-Provider-Encode/Makefile b/devel/p5-Template-Provider-Encode/Makefile
index 4df56e7aad55..f449742b34d1 100644
--- a/devel/p5-Template-Provider-Encode/Makefile
+++ b/devel/p5-Template-Provider-Encode/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Template-Provider-Encode
-# Date created: 2009-01-08
-# Whom: Murilo Opsfelder <mopsfelder@gmail.com>
-#
+# Created by: Murilo Opsfelder <mopsfelder@gmail.com>
# $FreeBSD$
-#
PORTNAME= Template-Provider-Encode
PORTVERSION= 0.02
@@ -16,7 +12,8 @@ COMMENT= Encode templates for Template Toolkit
RUN_DEPENDS= p5-Template-Toolkit>=0:${PORTSDIR}/www/p5-Template-Toolkit
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Template::Provider::Encode.3 \
Template::Provider::Encode::Guess.3
diff --git a/devel/p5-uni-perl/Makefile b/devel/p5-uni-perl/Makefile
index bc1bce965879..a6a1a288ed4d 100644
--- a/devel/p5-uni-perl/Makefile
+++ b/devel/p5-uni-perl/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-uni-perl
-# Date created: 2009-10-20
-# Whom: Mons Anderson <mons@cpan.org>
-#
+# Created by: Mons Anderson <mons@cpan.org>
# $FreeBSD$
-#
PORTNAME= uni-perl
PORTVERSION= 0.91
@@ -20,6 +16,7 @@ RUN_DEPENDS= p5-Encode>=2.37:${PORTSDIR}/converters/p5-Encode \
BUILD_DEPENDS:= ${RUN_DEPENDS}
TEST_DEPENDS= p5-Test-NoWarnings>=0:${PORTSDIR}/devel/p5-Test-NoWarnings
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
.include <bsd.port.mk>