aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2011-10-19 20:59:47 +0800
committersunpoet <sunpoet@FreeBSD.org>2011-10-19 20:59:47 +0800
commit832ec7f4f8d6c42e616a80154beec6c0f8425458 (patch)
tree531d814adb28c4034e0c55feeb961466c56626e8 /devel
parentafbc9567e26c394b4b2044dbdb605228251593d1 (diff)
downloadfreebsd-ports-gnome-832ec7f4f8d6c42e616a80154beec6c0f8425458.tar.gz
freebsd-ports-gnome-832ec7f4f8d6c42e616a80154beec6c0f8425458.tar.zst
freebsd-ports-gnome-832ec7f4f8d6c42e616a80154beec6c0f8425458.zip
- Add p5-DateTime-Format-Oracle 0.06
DateTime::Format::Oracle may be used to convert Oracle date and timestamp values into DateTime objects. It also can take a DateTime object and produce a date string matching the NLS_DATE_FORMAT. Oracle has flexible date formatting via its NLS_DATE_FORMAT session variable. Date values will be returned from Oracle according to the current value of that variable. Date values going into Oracle must also match the current setting of NLS_DATE_FORMAT. Timestamp values will match either the NLS_TIMESTAMP_FORMAT or NLS_TIMESTAMP_TZ_FORMAT session variables. This module keeps track of these Oracle session variable values by examining environment variables of the same name. Each time one of Oracle's formatting session variables is updated, the %ENV hash must also be updated. WWW: http://search.cpan.org/dist/DateTime-Format-Oracle/
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-DateTime-Format-Oracle/Makefile28
-rw-r--r--devel/p5-DateTime-Format-Oracle/distinfo2
-rw-r--r--devel/p5-DateTime-Format-Oracle/pkg-descr17
-rw-r--r--devel/p5-DateTime-Format-Oracle/pkg-plist7
5 files changed, 55 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index d2c33e974184..63fd270083a2 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1562,6 +1562,7 @@
SUBDIR += p5-DateTime-Format-Mail
SUBDIR += p5-DateTime-Format-MySQL
SUBDIR += p5-DateTime-Format-Natural
+ SUBDIR += p5-DateTime-Format-Oracle
SUBDIR += p5-DateTime-Format-Pg
SUBDIR += p5-DateTime-Format-RFC3339
SUBDIR += p5-DateTime-Format-Roman
diff --git a/devel/p5-DateTime-Format-Oracle/Makefile b/devel/p5-DateTime-Format-Oracle/Makefile
new file mode 100644
index 000000000000..18468d19a86a
--- /dev/null
+++ b/devel/p5-DateTime-Format-Oracle/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-DateTime-Format-Oracle
+# Date created: 2011-10-19
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DateTime-Format-Oracle
+PORTVERSION= 0.06
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Parse and format Oracle dates and timestamps
+
+BUILD_DEPENDS= p5-Convert-NLS_DATE_FORMAT>=0.03:${PORTSDIR}/converters/p5-Convert-NLS_DATE_FORMAT \
+ p5-DateTime>=0:${PORTSDIR}/devel/p5-DateTime \
+ p5-DateTime-Format-Builder>=0:${PORTSDIR}/devel/p5-DateTime-Format-Builder
+RUN_DEPENDS= p5-Convert-NLS_DATE_FORMAT>=0.03:${PORTSDIR}/converters/p5-Convert-NLS_DATE_FORMAT \
+ p5-DateTime>=0:${PORTSDIR}/devel/p5-DateTime \
+ p5-DateTime-Format-Builder>=0:${PORTSDIR}/devel/p5-DateTime-Format-Builder
+
+PERL_CONFIGURE= yes
+
+MAN3= DateTime::Format::Oracle.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-DateTime-Format-Oracle/distinfo b/devel/p5-DateTime-Format-Oracle/distinfo
new file mode 100644
index 000000000000..b7f7e0c78023
--- /dev/null
+++ b/devel/p5-DateTime-Format-Oracle/distinfo
@@ -0,0 +1,2 @@
+SHA256 (DateTime-Format-Oracle-0.06.tar.gz) = 9f18d1eb3dff38e046ba063d6b54cc7d68464640ce69d7d1578a2ccd285ca8d4
+SIZE (DateTime-Format-Oracle-0.06.tar.gz) = 5962
diff --git a/devel/p5-DateTime-Format-Oracle/pkg-descr b/devel/p5-DateTime-Format-Oracle/pkg-descr
new file mode 100644
index 000000000000..76f5f3c7225d
--- /dev/null
+++ b/devel/p5-DateTime-Format-Oracle/pkg-descr
@@ -0,0 +1,17 @@
+DateTime::Format::Oracle may be used to convert Oracle date and timestamp values
+into DateTime objects. It also can take a DateTime object and produce a date
+string matching the NLS_DATE_FORMAT.
+
+Oracle has flexible date formatting via its NLS_DATE_FORMAT session variable.
+Date values will be returned from Oracle according to the current value of that
+variable. Date values going into Oracle must also match the current setting of
+NLS_DATE_FORMAT.
+
+Timestamp values will match either the NLS_TIMESTAMP_FORMAT or
+NLS_TIMESTAMP_TZ_FORMAT session variables.
+
+This module keeps track of these Oracle session variable values by examining
+environment variables of the same name. Each time one of Oracle's formatting
+session variables is updated, the %ENV hash must also be updated.
+
+WWW: http://search.cpan.org/dist/DateTime-Format-Oracle/
diff --git a/devel/p5-DateTime-Format-Oracle/pkg-plist b/devel/p5-DateTime-Format-Oracle/pkg-plist
new file mode 100644
index 000000000000..6fd39e7df42e
--- /dev/null
+++ b/devel/p5-DateTime-Format-Oracle/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/DateTime/Format/Oracle.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime/Format/Oracle/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime/Format/Oracle
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime/Format
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime
+@dirrmtry %%SITE_PERL%%/DateTime/Format
+@dirrmtry %%SITE_PERL%%/DateTime