aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-02-17 01:50:11 +0800
committermiwi <miwi@FreeBSD.org>2008-02-17 01:50:11 +0800
commit8383b180e5be475d46bbceedace44851cc1464f0 (patch)
treef58110e7332b69b757e26231f9db0d63cb57ee8c /devel
parent75405173b7cc90ec7e407e8223163e73c51eb221 (diff)
downloadfreebsd-ports-gnome-8383b180e5be475d46bbceedace44851cc1464f0.tar.gz
freebsd-ports-gnome-8383b180e5be475d46bbceedace44851cc1464f0.tar.zst
freebsd-ports-gnome-8383b180e5be475d46bbceedace44851cc1464f0.zip
GNU cflow analyzes a collection of C source files and prints a graph
charting control flow within the program. Current implementation is able to produce both direct and inverted flowgraphs for C sources. Optionally a cross-reference listing can be generated. Two output formats are implemented: POSIX and GNU (extended). Input files can optionally be preprocessed before analyzing. WWW: http://savannah.gnu.org/projects/cflow PR: ports/120373 Submitted by: Dmitry Marakasov <amdmi3 at amdmi3.ru>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/gnucflow/Makefile32
-rw-r--r--devel/gnucflow/distinfo3
-rw-r--r--devel/gnucflow/pkg-descr11
4 files changed, 47 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index b7d4529273be..15b5872c0463 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -413,6 +413,7 @@
SUBDIR += gnome-vfs1
SUBDIR += gnome-vfsmm
SUBDIR += gnome2-hacker-tools
+ SUBDIR += gnucflow
SUBDIR += gnulibiberty
SUBDIR += gnustep
SUBDIR += gnustep-make
diff --git a/devel/gnucflow/Makefile b/devel/gnucflow/Makefile
new file mode 100644
index 000000000000..78386dd3bd3d
--- /dev/null
+++ b/devel/gnucflow/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: gnucflow
+# Date created: 07 Feb 2008
+# Whom: Dmitry Marakasov <amdmi3@amdmi3.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnucflow
+PORTVERSION= 1.2
+CATEGORIES= devel
+MASTER_SITES= ftp://download.gnu.org.ua/pub/release/cflow/
+DISTNAME= cflow-${PORTVERSION}
+
+MAINTAINER= amdmi3@amdmi3.ru
+COMMENT= Tool to chart control flow within the C program
+
+CONFLICTS= cflow-[0-9]*
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+INFO= cflow
+
+PLIST_FILES= bin/cflow \
+ share/locale/da/LC_MESSAGES/cflow.mo \
+ share/locale/ga/LC_MESSAGES/cflow.mo \
+ share/locale/pl/LC_MESSAGES/cflow.mo \
+ share/locale/uk/LC_MESSAGES/cflow.mo \
+ share/locale/vi/LC_MESSAGES/cflow.mo
+
+.include <bsd.port.mk>
diff --git a/devel/gnucflow/distinfo b/devel/gnucflow/distinfo
new file mode 100644
index 000000000000..b0bc8e0cbff4
--- /dev/null
+++ b/devel/gnucflow/distinfo
@@ -0,0 +1,3 @@
+MD5 (cflow-1.2.tar.bz2) = 860fc15fe9e9aaf42930af5191c518a7
+SHA256 (cflow-1.2.tar.bz2) = db30aa2cb1a2c9f9845b424d284c5b93928a1100545e64761d22a6177a58852c
+SIZE (cflow-1.2.tar.bz2) = 517457
diff --git a/devel/gnucflow/pkg-descr b/devel/gnucflow/pkg-descr
new file mode 100644
index 000000000000..86de2d931387
--- /dev/null
+++ b/devel/gnucflow/pkg-descr
@@ -0,0 +1,11 @@
+GNU cflow analyzes a collection of C source files and prints a graph
+charting control flow within the program.
+
+Current implementation is able to produce both direct and inverted
+flowgraphs for C sources. Optionally a cross-reference listing can
+be generated. Two output formats are implemented: POSIX and GNU
+(extended).
+
+Input files can optionally be preprocessed before analyzing.
+
+WWW: http://savannah.gnu.org/projects/cflow