aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2000-08-22 17:22:24 +0800
committerknu <knu@FreeBSD.org>2000-08-22 17:22:24 +0800
commit8ed515cb286b94004f4b3201e107215871fa6103 (patch)
tree1b048872896d3da7c7a09033c89dbf0be2e63449 /devel
parent7de0bcb2deda8a05986ea4df3354a3fc6d38f8e4 (diff)
downloadfreebsd-ports-gnome-8ed515cb286b94004f4b3201e107215871fa6103.tar.gz
freebsd-ports-gnome-8ed515cb286b94004f4b3201e107215871fa6103.tar.zst
freebsd-ports-gnome-8ed515cb286b94004f4b3201e107215871fa6103.zip
Add ruby-filelock, a Ruby module which provides file locking mechanism.
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/ruby-filelock/Makefile47
-rw-r--r--devel/ruby-filelock/distinfo1
-rw-r--r--devel/ruby-filelock/pkg-comment1
-rw-r--r--devel/ruby-filelock/pkg-descr12
-rw-r--r--devel/ruby-filelock/pkg-plist10
6 files changed, 72 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 64b9b1559a47..b8f4d1b5b76e 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -266,6 +266,7 @@
SUBDIR += rpc2
SUBDIR += ruby-amstd
SUBDIR += ruby-date2
+ SUBDIR += ruby-filelock
SUBDIR += ruby-intl
SUBDIR += ruby-locale
SUBDIR += ruby-optparse
diff --git a/devel/ruby-filelock/Makefile b/devel/ruby-filelock/Makefile
new file mode 100644
index 000000000000..ffd5c7b5e3f0
--- /dev/null
+++ b/devel/ruby-filelock/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: Ruby-filelock
+# Date created: 22 Aug 2000
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= filelock
+PORTVERSION= 0.2
+CATEGORIES= devel ruby
+MASTER_SITES= ftp://ftp.netlab.co.jp/pub/lang/ruby/contrib/
+PKGNAMEPREFIX= ruby-
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+BUILD_DEPENDS= ruby:${PORTSDIR}/lang/ruby
+RUN_DEPENDS= ruby:${PORTSDIR}/lang/ruby
+
+INSTALL_TARGET= site-install
+
+PLIST_SUB= RUBY_VER="${RUBY_VER}" RUBY_ARCH="${RUBY_ARCH}"
+
+RUBY?= ${LOCALBASE}/bin/ruby
+RUBY_VER?= 1.4
+RUBY_ARCH?= ${ARCH}-freebsd${OSREL}
+
+DOCS= README
+EXAMPLES= test.rb tst1.rb tst2.rb tst3.rb tst4.rb
+
+do-configure:
+ @cd ${WRKSRC}; \
+ ${SETENV} ${CONFIGURE_ENV} ${RUBY} extconf.rb ${CONFIGURE_ARGS}
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/examples/ruby/filelock
+.for f in ${EXAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/samples/${f} ${PREFIX}/share/examples/ruby/filelock/
+.endfor
+ ${MKDIR} ${PREFIX}/share/doc/ruby/filelock
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/doc/ruby/filelock/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/ruby-filelock/distinfo b/devel/ruby-filelock/distinfo
new file mode 100644
index 000000000000..9359685b96ec
--- /dev/null
+++ b/devel/ruby-filelock/distinfo
@@ -0,0 +1 @@
+MD5 (ruby/filelock-0.2.tar.gz) = dd2a155539e746be42a851addd96e989
diff --git a/devel/ruby-filelock/pkg-comment b/devel/ruby-filelock/pkg-comment
new file mode 100644
index 000000000000..a9ce044efc63
--- /dev/null
+++ b/devel/ruby-filelock/pkg-comment
@@ -0,0 +1 @@
+A Ruby module which provides file locking mechanism
diff --git a/devel/ruby-filelock/pkg-descr b/devel/ruby-filelock/pkg-descr
new file mode 100644
index 000000000000..47d3df5877b5
--- /dev/null
+++ b/devel/ruby-filelock/pkg-descr
@@ -0,0 +1,12 @@
+This is a Ruby module which provides file locking mechanism.
+
+The module FileLock implements two classes: LockFile and LockedFile;
+the class LockFile deals with so-called lockfiles, and the class
+LockedFile offer a high-level interface to deal with both regular
+files and lockfiles at the same time.
+
+To be portable, a small C extension is used to minimize the time
+between existence check of a lockfile and its creation.
+
+Author: Clemens Hintze <c.hintze@gmx.net>
+WWW: http://www.ruby-lang.org/en/raa-list.rhtml?name=filelock \ No newline at end of file
diff --git a/devel/ruby-filelock/pkg-plist b/devel/ruby-filelock/pkg-plist
new file mode 100644
index 000000000000..f49eb045ce60
--- /dev/null
+++ b/devel/ruby-filelock/pkg-plist
@@ -0,0 +1,10 @@
+lib/ruby/site_ruby/%%RUBY_VER%%/%%RUBY_ARCH%%/_filelock.so
+lib/ruby/site_ruby/%%RUBY_VER%%/filelock.rb
+share/examples/ruby/filelock/test.rb
+share/examples/ruby/filelock/tst1.rb
+share/examples/ruby/filelock/tst2.rb
+share/examples/ruby/filelock/tst3.rb
+share/examples/ruby/filelock/tst4.rb
+@dirrm share/examples/ruby/filelock
+share/doc/ruby/filelock/README
+@dirrm share/doc/ruby/filelock