aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2001-05-10 22:52:51 +0800
committerijliao <ijliao@FreeBSD.org>2001-05-10 22:52:51 +0800
commit8ed9b672254c046363c42e6720122a0f16a64070 (patch)
tree8dfd13360f940b8d877336110a174c90a35455e6 /devel
parent6106500b3a62bbf2139489299e299a77b73564bf (diff)
downloadfreebsd-ports-gnome-8ed9b672254c046363c42e6720122a0f16a64070.tar.gz
freebsd-ports-gnome-8ed9b672254c046363c42e6720122a0f16a64070.tar.zst
freebsd-ports-gnome-8ed9b672254c046363c42e6720122a0f16a64070.zip
upgrade to 0.9.5
Diffstat (limited to 'devel')
-rw-r--r--devel/uds/Makefile2
-rw-r--r--devel/uds/distinfo2
-rw-r--r--devel/uds/files/patch-uds::packetsocket.cc19
-rw-r--r--devel/uds/files/patch-uds::sockbase.cc (renamed from devel/uds/files/patch-uds::socket.cc)4
-rw-r--r--devel/uds/files/patch-uds::streamsocket.cc10
-rw-r--r--devel/uds/pkg-plist8
6 files changed, 40 insertions, 5 deletions
diff --git a/devel/uds/Makefile b/devel/uds/Makefile
index 94d8e7a47cbb..e25715f91e6f 100644
--- a/devel/uds/Makefile
+++ b/devel/uds/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= uds
-PORTVERSION= 0.9.4
+PORTVERSION= 0.9.5
CATEGORIES= devel
MASTER_SITES= http://frost.flewid.de/dist/
diff --git a/devel/uds/distinfo b/devel/uds/distinfo
index a880b00e60c9..7804b38a4543 100644
--- a/devel/uds/distinfo
+++ b/devel/uds/distinfo
@@ -1 +1 @@
-MD5 (uds-0.9.4.tar.gz) = 61ff8da45829cfee99bb5e154dcc024a
+MD5 (uds-0.9.5.tar.gz) = acafc3167c4abbd1f2aac57865d4a0a6
diff --git a/devel/uds/files/patch-uds::packetsocket.cc b/devel/uds/files/patch-uds::packetsocket.cc
new file mode 100644
index 000000000000..8a26a8db1e72
--- /dev/null
+++ b/devel/uds/files/patch-uds::packetsocket.cc
@@ -0,0 +1,19 @@
+--- uds/packetsocket.cc.orig Wed May 9 15:24:10 2001
++++ uds/packetsocket.cc Thu May 10 19:52:41 2001
+@@ -22,6 +22,7 @@
+
+ // includes
+
++#include <sys/types.h>
+ #include <netinet/in.h>
+ #include <sys/socket.h>
+ #include <uds/packetsocket.hh>
+@@ -163,7 +164,7 @@
+ &si_len ) );
+ d.assign( msg, sz );
+
+- hostent* he = gethostbyaddr( &si.sin_addr, sizeof( si.sin_addr ), AF_INET );
++ hostent* he = gethostbyaddr( (const char *)&si.sin_addr, sizeof( si.sin_addr ), AF_INET );
+ clog<<he<<endl;
+
+ if ( he )
diff --git a/devel/uds/files/patch-uds::socket.cc b/devel/uds/files/patch-uds::sockbase.cc
index a0bae732531f..b0d36cb57fb4 100644
--- a/devel/uds/files/patch-uds::socket.cc
+++ b/devel/uds/files/patch-uds::sockbase.cc
@@ -1,5 +1,5 @@
---- uds/socket.cc.orig Tue Feb 27 13:59:39 2001
-+++ uds/socket.cc Tue Feb 27 14:00:40 2001
+--- uds/sockbase.cc.orig Thu May 10 19:57:08 2001
++++ uds/sockbase.cc Thu May 10 19:57:26 2001
@@ -25,6 +25,7 @@
#include "config.h"
#ifdef HAVE_SOCKET
diff --git a/devel/uds/files/patch-uds::streamsocket.cc b/devel/uds/files/patch-uds::streamsocket.cc
new file mode 100644
index 000000000000..8ed71219d640
--- /dev/null
+++ b/devel/uds/files/patch-uds::streamsocket.cc
@@ -0,0 +1,10 @@
+--- uds/streamsocket.cc.orig Thu May 10 19:59:24 2001
++++ uds/streamsocket.cc Thu May 10 19:59:52 2001
+@@ -25,6 +25,7 @@
+ #include "config.h"
+ #ifdef HAVE_SOCKET
+
++#include <sys/types.h>
+ #include <netinet/in.h>
+ #include <sys/un.h>
+ #include <uds/stdexcpt.hh>
diff --git a/devel/uds/pkg-plist b/devel/uds/pkg-plist
index a7a5cd1c0761..19c32cc619ac 100644
--- a/devel/uds/pkg-plist
+++ b/devel/uds/pkg-plist
@@ -1,6 +1,7 @@
include/uds/action.hh
include/uds/alloc.hh
include/uds/auto_ptr.hh
+include/uds/btrace.hh
include/uds/check_ptr.hh
include/uds/childdiag.hh
include/uds/collector.hh
@@ -9,20 +10,24 @@ include/uds/diagnose.hh
include/uds/errnodiag.hh
include/uds/exception.hh
include/uds/exit.hh
+include/uds/fileinfo.hh
include/uds/flex_func.hh
include/uds/functional.hh
include/uds/init.hh
include/uds/log.hh
include/uds/md5.h
+include/uds/packetsocket.hh
include/uds/procstream.hh
include/uds/random.hh
include/uds/refcounter.hh
include/uds/sentinel.hh
-include/uds/socket.hh
+include/uds/sockbase.hh
include/uds/stdexcpt.hh
include/uds/stl_ext.hh
include/uds/stl_util.hh
include/uds/strstream.hh
+include/uds/streamsocket.hh
+include/uds/swanpipe.hh
include/uds/sys_util.hh
include/uds/thread.hh
include/uds/time.hh
@@ -38,6 +43,7 @@ lib/libudsthread.so.0
%%PORTDOCS%%share/doc/uds/contributing.html
%%PORTDOCS%%share/doc/uds/download.html
%%PORTDOCS%%share/doc/uds/features.html
+%%PORTDOCS%%share/doc/uds/history.html
%%PORTDOCS%%share/doc/uds/index.html
%%PORTDOCS%%share/doc/uds/relnotes.html
%%PORTDOCS%%@dirrm share/doc/uds