aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2011-12-14 10:04:05 +0800
committerswills <swills@FreeBSD.org>2011-12-14 10:04:05 +0800
commit92504df1864ebde7dac9a88d6acdd7069b3ae417 (patch)
tree1adff090debf47b71ff4769b0369cb420f740291 /devel
parenteedff8f5fd3890cb06c08779fc763fdcb624f635 (diff)
downloadfreebsd-ports-gnome-92504df1864ebde7dac9a88d6acdd7069b3ae417.tar.gz
freebsd-ports-gnome-92504df1864ebde7dac9a88d6acdd7069b3ae417.tar.zst
freebsd-ports-gnome-92504df1864ebde7dac9a88d6acdd7069b3ae417.zip
This module allows you to deliberately hide modules from a program even though
they are installed. This is mostly useful for testing modules that have a fallback when a certain dependency module is not installed. WWW: http://search.cpan.org/dist/Test-Without-Module/
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Test-Without-Module/Makefile22
-rw-r--r--devel/p5-Test-Without-Module/distinfo2
-rw-r--r--devel/p5-Test-Without-Module/pkg-descr5
-rw-r--r--devel/p5-Test-Without-Module/pkg-plist7
5 files changed, 37 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 9a1549f46905..612366e97043 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2516,6 +2516,7 @@
SUBDIR += p5-Test-WWW-Selenium
SUBDIR += p5-Test-Warn
SUBDIR += p5-Test-Weaken
+ SUBDIR += p5-Test-Without-Module
SUBDIR += p5-Test-XML
SUBDIR += p5-Test-XML-Valid
SUBDIR += p5-Test-YAML-Meta
diff --git a/devel/p5-Test-Without-Module/Makefile b/devel/p5-Test-Without-Module/Makefile
new file mode 100644
index 000000000000..b380d62ec345
--- /dev/null
+++ b/devel/p5-Test-Without-Module/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-Test-Without-Module
+# Date created: 2011-12-11
+# Whom: Steve Wills <swills@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-Without-Module
+PORTVERSION= 0.17
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+#MASTER_SITE_SUBDIR=
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Test fallback behaviour in absence of modules
+
+PERL_CONFIGURE= yes
+
+MAN3= Test::Without::Module.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Test-Without-Module/distinfo b/devel/p5-Test-Without-Module/distinfo
new file mode 100644
index 000000000000..6c57edec7fb0
--- /dev/null
+++ b/devel/p5-Test-Without-Module/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Test-Without-Module-0.17.tar.gz) = a691b0bf6d92dedbacfd547551021389ebc79c51937de2b914e792457da56ff7
+SIZE (Test-Without-Module-0.17.tar.gz) = 6709
diff --git a/devel/p5-Test-Without-Module/pkg-descr b/devel/p5-Test-Without-Module/pkg-descr
new file mode 100644
index 000000000000..fee94f66c72a
--- /dev/null
+++ b/devel/p5-Test-Without-Module/pkg-descr
@@ -0,0 +1,5 @@
+This module allows you to deliberately hide modules from a program even though
+they are installed. This is mostly useful for testing modules that have a
+fallback when a certain dependency module is not installed.
+
+WWW: http://search.cpan.org/dist/Test-Without-Module/
diff --git a/devel/p5-Test-Without-Module/pkg-plist b/devel/p5-Test-Without-Module/pkg-plist
new file mode 100644
index 000000000000..a32ba6df75fe
--- /dev/null
+++ b/devel/p5-Test-Without-Module/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Test/Without/Module.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Without/Module/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Without/Module
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Without
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test
+@dirrmtry %%SITE_PERL%%/Test/Without
+@dirrmtry %%SITE_PERL%%/Test