aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-01-23 19:10:46 +0800
committerbapt <bapt@FreeBSD.org>2014-01-23 19:10:46 +0800
commit9560488bc3a1dd518747b94103861f8906af9994 (patch)
tree1844fc6bdaedffda314450977ea52bf4048dd911 /devel
parent36c14e04489493ffd613c848243c8c2d3e476d94 (diff)
downloadfreebsd-ports-gnome-9560488bc3a1dd518747b94103861f8906af9994.tar.gz
freebsd-ports-gnome-9560488bc3a1dd518747b94103861f8906af9994.tar.zst
freebsd-ports-gnome-9560488bc3a1dd518747b94103861f8906af9994.zip
Fix build without ncurses port installed
Reported by: olgeni
Diffstat (limited to 'devel')
-rw-r--r--devel/cdialog/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/devel/cdialog/Makefile b/devel/cdialog/Makefile
index 832ce35f167c..292a77002ce9 100644
--- a/devel/cdialog/Makefile
+++ b/devel/cdialog/Makefile
@@ -24,13 +24,18 @@ USE_LDCONFIG= yes
CONFIGURE_ARGS= --enable-widec \
--includedir=${PREFIX}/include/${PORTNAME} \
--with-libtool \
- --with-curses-dir=${NCURSESBASE} \
--with-ncursesw \
--with-package=${PORTNAME}
MAKEFILE= makefile
INSTALL_TARGET= install-strip install-man install-lib
+.include <bsd.port.pre.mk>
+
+.if ${NCURSESBASE} != /usr
+CONFIGURE_ARGS= --with-curses-dir=${NCURSESBASE}
+.endif
+
post-patch:
@${FIND} ${WRKSRC}/samples/ -type f -exec ${REINPLACE_CMD} -i "" "s|dialog|cdialog|g" {} \;
@@ -38,4 +43,4 @@ post-install:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
cd ${WRKSRC}/samples && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>