aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorlth <lth@FreeBSD.org>2006-03-18 20:33:32 +0800
committerlth <lth@FreeBSD.org>2006-03-18 20:33:32 +0800
commit95ee01b55c14a4d1968fc85f48cfb648510b4509 (patch)
tree2355a6644cde0ad06903cb2395901e3d6c6d9e13 /devel
parent87e56e3b3880ab13d543e5c74cec2dff9b6044a4 (diff)
downloadfreebsd-ports-gnome-95ee01b55c14a4d1968fc85f48cfb648510b4509.tar.gz
freebsd-ports-gnome-95ee01b55c14a4d1968fc85f48cfb648510b4509.tar.zst
freebsd-ports-gnome-95ee01b55c14a4d1968fc85f48cfb648510b4509.zip
Add p5-Test-Data 1.18, test functions for particular variable types.
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Test-Data/Makefile36
-rw-r--r--devel/p5-Test-Data/distinfo3
-rw-r--r--devel/p5-Test-Data/pkg-descr4
-rw-r--r--devel/p5-Test-Data/pkg-plist10
5 files changed, 54 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 15ba4bb6cece..5ec7a5966c87 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1195,6 +1195,7 @@
SUBDIR += p5-Test-Class
SUBDIR += p5-Test-ClassAPI
SUBDIR += p5-Test-Cmd
+ SUBDIR += p5-Test-Data
SUBDIR += p5-Test-Deep
SUBDIR += p5-Test-Differences
SUBDIR += p5-Test-Exception
diff --git a/devel/p5-Test-Data/Makefile b/devel/p5-Test-Data/Makefile
new file mode 100644
index 000000000000..350a1e8f6b41
--- /dev/null
+++ b/devel/p5-Test-Data/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: devel/p5-Test-Data
+# Date created: 18 March 2006
+# Whom: Lars Thegler <lth@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-Data
+PORTVERSION= 1.18
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Test
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lth@FreeBSD.org
+COMMENT= Test functions for particular variable types
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils \
+ ${SITE_PERL}/Test/Builder/Tester.pm:${PORTSDIR}/devel/p5-Test-Simple
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Test::Data.3 \
+ Test::Data::Array.3 \
+ Test::Data::Function.3 \
+ Test::Data::Hash.3 \
+ Test::Data::Scalar.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires Perl 5.6. Install lang/perl5 or lang/perl5.8, and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Test-Data/distinfo b/devel/p5-Test-Data/distinfo
new file mode 100644
index 000000000000..2cf193c12b22
--- /dev/null
+++ b/devel/p5-Test-Data/distinfo
@@ -0,0 +1,3 @@
+MD5 (Test-Data-1.18.tar.gz) = 10100a5da3fcfc6a99ad85c6b1d96790
+SHA256 (Test-Data-1.18.tar.gz) = 58727ac621a111b3710326be9f3ff899c5f2863cde628cd7f66806c0f5be49e1
+SIZE (Test-Data-1.18.tar.gz) = 10287
diff --git a/devel/p5-Test-Data/pkg-descr b/devel/p5-Test-Data/pkg-descr
new file mode 100644
index 000000000000..0aa0f148cca0
--- /dev/null
+++ b/devel/p5-Test-Data/pkg-descr
@@ -0,0 +1,4 @@
+Test::Data provides utility functions to check properties and values
+of data and variables.
+
+WWW: http://search.cpan.org/dist/Test-Data/
diff --git a/devel/p5-Test-Data/pkg-plist b/devel/p5-Test-Data/pkg-plist
new file mode 100644
index 000000000000..c4c1a5edc859
--- /dev/null
+++ b/devel/p5-Test-Data/pkg-plist
@@ -0,0 +1,10 @@
+%%SITE_PERL%%/Test/Data.pm
+%%SITE_PERL%%/Test/Data/Array.pm
+%%SITE_PERL%%/Test/Data/Function.pm
+%%SITE_PERL%%/Test/Data/Hash.pm
+%%SITE_PERL%%/Test/Data/Scalar.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Data/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Data
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test
+@dirrmtry %%SITE_PERL%%/Test/Data
+@dirrmtry %%SITE_PERL%%/Test