aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2006-08-04 20:34:50 +0800
committererwin <erwin@FreeBSD.org>2006-08-04 20:34:50 +0800
commit983dc15ba8f877d94d8e2b8c777deb8199f4ec99 (patch)
treeb75af0a340e3a5fb325b96ab4419867bc2a7a996 /devel
parent0aec5ee33513f1341433ac3950105867e7edbae9 (diff)
downloadfreebsd-ports-gnome-983dc15ba8f877d94d8e2b8c777deb8199f4ec99.tar.gz
freebsd-ports-gnome-983dc15ba8f877d94d8e2b8c777deb8199f4ec99.tar.zst
freebsd-ports-gnome-983dc15ba8f877d94d8e2b8c777deb8199f4ec99.zip
Add support for DESTDIR part I.
This commit should largele be a NOOP as it only adds support for DESTDIR undefined. This does allow us to start testing ports with DESTDIR set, but this is as of yet not supported. Although this has been extensively tested on pointyhat, this is a very intrusive change and some cases may have been overlooked. Please contact Gabor and me if you find any. PR: 100555 Submitted by: gabor Sponsored by: Google Summer of Code 2006
Diffstat (limited to 'devel')
-rw-r--r--devel/p5-Devel-DProf/Makefile1
-rw-r--r--devel/p5-Glib2/Makefile2
-rw-r--r--devel/p5-SDL/Makefile2
-rw-r--r--devel/plan9port/Makefile2
-rw-r--r--devel/subversion-devel/Makefile2
-rw-r--r--devel/subversion-freebsd/Makefile2
-rw-r--r--devel/subversion/Makefile2
-rw-r--r--devel/subversion16/Makefile2
8 files changed, 7 insertions, 8 deletions
diff --git a/devel/p5-Devel-DProf/Makefile b/devel/p5-Devel-DProf/Makefile
index 3b7485bc7931..42cb201cf9a2 100644
--- a/devel/p5-Devel-DProf/Makefile
+++ b/devel/p5-Devel-DProf/Makefile
@@ -17,7 +17,6 @@ COMMENT= A Perl code profiler
PERL_CONFIGURE= yes
-MAN1PREFIX= ${PREFIX}
MAN1= dprofpp.1
MAN3= Devel::DProf.3
diff --git a/devel/p5-Glib2/Makefile b/devel/p5-Glib2/Makefile
index afeee330b9c5..67597dccaed9 100644
--- a/devel/p5-Glib2/Makefile
+++ b/devel/p5-Glib2/Makefile
@@ -35,6 +35,6 @@ IGNORE= requires perl 5.8.0 or later. Install lang/perl5.8 then try again
post-install:
@cd ${WRKSRC}/blib/man3 && ${FIND} * -name "*.3" | ${SED} \
- 's,^,${MAN3PREFIX:S,^${PREFIX}/,,}/man/man3/,' >> ${TMPPLIST}
+ 's,^,${MAN3PREFIX:S,^${TARGETDIR}/,,}/man/man3/,' >> ${TMPPLIST}
.include <bsd.port.post.mk>
diff --git a/devel/p5-SDL/Makefile b/devel/p5-SDL/Makefile
index d7c377183396..83078e18a258 100644
--- a/devel/p5-SDL/Makefile
+++ b/devel/p5-SDL/Makefile
@@ -54,7 +54,7 @@ USE_PERL5= yes
INSTALLS_SHLIB= yes
INSTALL_TARGET= pure_install
-MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3PREFIX= ${TARGETDIR}/lib/perl5/${PERL_VERSION}
MAN3= SDL.3 \
SDL::App.3 \
SDL::Cdrom.3 \
diff --git a/devel/plan9port/Makefile b/devel/plan9port/Makefile
index 6bc4f0b411aa..488944d2607f 100644
--- a/devel/plan9port/Makefile
+++ b/devel/plan9port/Makefile
@@ -23,7 +23,7 @@ SUB_FILES= pkg-message
REINPLACE_ARGS= -i ""
ONLY_FOR_ARCHS= i386
-PLAN9= ${PREFIX}/plan9
+PLAN9= ${TARGETDIR}/plan9
MANPREFIX= ${PLAN9}
MAN1= 9term.1 acmeevent.1 ascii.1 acme.1 9p.1 basename.1 cal.1 \
diff --git a/devel/subversion-devel/Makefile b/devel/subversion-devel/Makefile
index 2a574ac8b7f7..df96ae7a7eea 100644
--- a/devel/subversion-devel/Makefile
+++ b/devel/subversion-devel/Makefile
@@ -92,7 +92,7 @@ IGNORE= subversion\'s Perl bindings need perl 5.8.0 or greater. Upgrade your per
SWIG_BINDINGS+= yes
USE_PERL5= yes
PLIST_SUB+= WITH_PERL=""
-MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3PREFIX= ${TARGETDIR}/lib/perl5/${PERL_VERSION}
MAN3= SVN::Base.3 \
SVN::Client.3 \
SVN::Core.3 \
diff --git a/devel/subversion-freebsd/Makefile b/devel/subversion-freebsd/Makefile
index 2a574ac8b7f7..df96ae7a7eea 100644
--- a/devel/subversion-freebsd/Makefile
+++ b/devel/subversion-freebsd/Makefile
@@ -92,7 +92,7 @@ IGNORE= subversion\'s Perl bindings need perl 5.8.0 or greater. Upgrade your per
SWIG_BINDINGS+= yes
USE_PERL5= yes
PLIST_SUB+= WITH_PERL=""
-MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3PREFIX= ${TARGETDIR}/lib/perl5/${PERL_VERSION}
MAN3= SVN::Base.3 \
SVN::Client.3 \
SVN::Core.3 \
diff --git a/devel/subversion/Makefile b/devel/subversion/Makefile
index 2a574ac8b7f7..df96ae7a7eea 100644
--- a/devel/subversion/Makefile
+++ b/devel/subversion/Makefile
@@ -92,7 +92,7 @@ IGNORE= subversion\'s Perl bindings need perl 5.8.0 or greater. Upgrade your per
SWIG_BINDINGS+= yes
USE_PERL5= yes
PLIST_SUB+= WITH_PERL=""
-MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3PREFIX= ${TARGETDIR}/lib/perl5/${PERL_VERSION}
MAN3= SVN::Base.3 \
SVN::Client.3 \
SVN::Core.3 \
diff --git a/devel/subversion16/Makefile b/devel/subversion16/Makefile
index 2a574ac8b7f7..df96ae7a7eea 100644
--- a/devel/subversion16/Makefile
+++ b/devel/subversion16/Makefile
@@ -92,7 +92,7 @@ IGNORE= subversion\'s Perl bindings need perl 5.8.0 or greater. Upgrade your per
SWIG_BINDINGS+= yes
USE_PERL5= yes
PLIST_SUB+= WITH_PERL=""
-MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3PREFIX= ${TARGETDIR}/lib/perl5/${PERL_VERSION}
MAN3= SVN::Base.3 \
SVN::Client.3 \
SVN::Core.3 \