aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2004-06-29 09:11:31 +0800
committerijliao <ijliao@FreeBSD.org>2004-06-29 09:11:31 +0800
commit9ef997dd63afaa152303697cd0c76db99f2bb738 (patch)
treecb2a6f0ff79b13546dff9a769354fef65f87c16e /devel
parent628254df4589d9330bc3ab13e298ef8e8fd37782 (diff)
downloadfreebsd-ports-gnome-9ef997dd63afaa152303697cd0c76db99f2bb738.tar.gz
freebsd-ports-gnome-9ef997dd63afaa152303697cd0c76db99f2bb738.tar.zst
freebsd-ports-gnome-9ef997dd63afaa152303697cd0c76db99f2bb738.zip
add genproto 0.3
Generates prototypes from C/C++ code
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/genproto/Makefile28
-rw-r--r--devel/genproto/distinfo2
-rw-r--r--devel/genproto/pkg-descr4
4 files changed, 35 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 1a0d2811bda2..46f5bdd6028c 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -271,6 +271,7 @@
SUBDIR += gdbmods
SUBDIR += gengameng
SUBDIR += gengetopt
+ SUBDIR += genproto
SUBDIR += gettext
SUBDIR += gettext-lint
SUBDIR += getxml
diff --git a/devel/genproto/Makefile b/devel/genproto/Makefile
new file mode 100644
index 000000000000..c1a32d545c5a
--- /dev/null
+++ b/devel/genproto/Makefile
@@ -0,0 +1,28 @@
+# ex:ts=8
+# Ports collection makefile for: genproto
+# Date created: Jun 29, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= genproto
+PORTVERSION= 0.3
+CATEGORIES= devel
+MASTER_SITES= http://freequaos.host.sk/genproto/
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Generates prototypes from C/C++ code
+
+USE_REINPLACE= yes
+
+PLIST_FILES= bin/genproto
+
+post-patch:
+ @${REINPLACE_CMD} -e "s,^CC,#CC," -e "s,^CFLAGS,#CFLAGS," \
+ ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/genproto ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/devel/genproto/distinfo b/devel/genproto/distinfo
new file mode 100644
index 000000000000..48de5287dc36
--- /dev/null
+++ b/devel/genproto/distinfo
@@ -0,0 +1,2 @@
+MD5 (genproto-0.3.tar.gz) = 8fb165ae9f9ffc1f59f611f262f20bf2
+SIZE (genproto-0.3.tar.gz) = 27312
diff --git a/devel/genproto/pkg-descr b/devel/genproto/pkg-descr
new file mode 100644
index 000000000000..d206437324d3
--- /dev/null
+++ b/devel/genproto/pkg-descr
@@ -0,0 +1,4 @@
+genproto generates prototypes from C/C++ code. It does not touch the original
+files, and the output format can be changed via printf-style format strings.
+
+WWW: http://freequaos.host.sk/genproto/