aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2014-09-17 11:00:42 +0800
committervanilla <vanilla@FreeBSD.org>2014-09-17 11:00:42 +0800
commita0adb36bd600c1b1f61f013427f252877e1aa518 (patch)
treed4397aecf5e7afb519c7ce4f90121a29fb35a31b /devel
parent8a8c8a229c9da1159fadbad0721585fe2a56c793 (diff)
downloadfreebsd-ports-gnome-a0adb36bd600c1b1f61f013427f252877e1aa518.tar.gz
freebsd-ports-gnome-a0adb36bd600c1b1f61f013427f252877e1aa518.tar.zst
freebsd-ports-gnome-a0adb36bd600c1b1f61f013427f252877e1aa518.zip
Add pecl-swoole, async framework of php.
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/pecl-swoole/Makefile23
-rw-r--r--devel/pecl-swoole/distinfo2
-rw-r--r--devel/pecl-swoole/pkg-descr14
4 files changed, 40 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 22f3cbf6cddb..a0d7aff82a74 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3387,6 +3387,7 @@
SUBDIR += pecl-spread
SUBDIR += pecl-statgrab
SUBDIR += pecl-svn
+ SUBDIR += pecl-swoole
SUBDIR += pecl-test_helpers
SUBDIR += pecl-uopz
SUBDIR += pecl-uploadprogress
diff --git a/devel/pecl-swoole/Makefile b/devel/pecl-swoole/Makefile
new file mode 100644
index 000000000000..6aab7e7543ec
--- /dev/null
+++ b/devel/pecl-swoole/Makefile
@@ -0,0 +1,23 @@
+# Created by: vanilla@
+# $FreeBSD$
+
+PORTNAME= swoole
+PORTVERSION= 1.7.5
+CATEGORIES= devel net
+MASTER_SITES= http://pecl.php.net/get/
+PKGNAMEPREFIX= pecl-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PECL
+
+MAINTAINER= vanilla@FreeBSD.org
+COMMENT= Asynchronous & concurrent & distributed networking framework
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+CFLAGS+= -I${LOCALBASE}/include
+PHP_MODNAME= ${PORTNAME}
+USE_PHP= pcre
+USE_PHPEXT= yes
+
+.include <bsd.port.mk>
diff --git a/devel/pecl-swoole/distinfo b/devel/pecl-swoole/distinfo
new file mode 100644
index 000000000000..0be458718576
--- /dev/null
+++ b/devel/pecl-swoole/distinfo
@@ -0,0 +1,2 @@
+SHA256 (PECL/swoole-1.7.5.tgz) = 85f1fc212f92a6ec3fa1cc56011273ce1703bb23b59c240e842bf82e1e9e955d
+SIZE (PECL/swoole-1.7.5.tgz) = 388825
diff --git a/devel/pecl-swoole/pkg-descr b/devel/pecl-swoole/pkg-descr
new file mode 100644
index 000000000000..3cdc3fd5b166
--- /dev/null
+++ b/devel/pecl-swoole/pkg-descr
@@ -0,0 +1,14 @@
+Asynchronous & concurrent & distributed networking framework for PHP.
+
+* event-driven
+* full asynchronous non-blocking
+* multi-thread reactor
+* multi-process worker
+* millisecond timer
+* async MySQL
+* async task
+* async read/write file system
+* async dns lookup
+* support IPv4/IPv6/UnixSocket/TCP/UDP
+
+WWW: http://pecl.php.net/package/swoole