aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorjgh <jgh@FreeBSD.org>2013-05-21 15:09:46 +0800
committerjgh <jgh@FreeBSD.org>2013-05-21 15:09:46 +0800
commita57c001d49d8a813b022f179e69e55de1115b9f1 (patch)
treeb94a8f8351da33be14cb1e0a02c7a30422f824ef /devel
parent3f3571382b9eebbc9c3577ed8ba7f7507289026e (diff)
downloadfreebsd-ports-gnome-a57c001d49d8a813b022f179e69e55de1115b9f1.tar.gz
freebsd-ports-gnome-a57c001d49d8a813b022f179e69e55de1115b9f1.tar.zst
freebsd-ports-gnome-a57c001d49d8a813b022f179e69e55de1115b9f1.zip
- adoption of optionsNG
Approved by: maintainer, wen@
Diffstat (limited to 'devel')
-rw-r--r--devel/py-simpy/Makefile9
-rw-r--r--devel/py-tables/Makefile20
2 files changed, 15 insertions, 14 deletions
diff --git a/devel/py-simpy/Makefile b/devel/py-simpy/Makefile
index 87b43d4c90fa..a3a1541c25ee 100644
--- a/devel/py-simpy/Makefile
+++ b/devel/py-simpy/Makefile
@@ -17,17 +17,20 @@ USE_PYTHON= yes
USE_PYDISTUTILS= yes
PYDISTUTILS_PKGNAME= SimPy
-OPTIONS= TKINTER "Install py-tkinter for plot" off
+OPTIONS_DEFINE= TKINTER
+TKINTER_DESC= py-tkinter for plot
+
OPTIONSFILE= ${PORT_DBDIR}/py-${PORTNAME}/options
+.include <bsd.port.options.mk>
.include <bsd.port.pre.mk>
-.if defined(WITH_TKINTER)
+.if ${PORT_OPTIONS:MTKINTER}
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}tkinter>0:${PORTSDIR}/x11-toolkits/py-tkinter
.endif
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
(cd ${WRKSRC}/docs && ${COPYTREE_SHARE} . ${DOCSDIR})
.endif
diff --git a/devel/py-tables/Makefile b/devel/py-tables/Makefile
index 9d732ead52b5..2b326d9ba420 100644
--- a/devel/py-tables/Makefile
+++ b/devel/py-tables/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# Ports collection makefile for: PyTables
-# Date created: Dec 19, 2003
-# Whom: ijliao
-#
+# Created by: ijliao@FreeBSD.org
# $FreeBSD$
-#
PORTNAME= tables
PORTVERSION= 2.4.0
@@ -15,7 +10,7 @@ DISTFILES= tables-${PORTVERSION}.tar.gz pytablesmanual-${PORTVERSION}.pdf
EXTRACT_ONLY= tables-${PORTVERSION}.tar.gz
MAINTAINER= wen@FreeBSD.org
-COMMENT= A hierarchical database for Python
+COMMENT= Hierarchical database for Python
BUILD_DEPENDS= ${PYNUMPY} \
${LOCALBASE}/bin/cython:${PORTSDIR}/lang/cython \
@@ -30,12 +25,15 @@ USE_PYDISTUTILS= yes
PLIST_FILES= bin/nctoh5 bin/ptdump bin/ptrepack
-OPTIONS= PYREX "Use code generated by Pyrex to build" off
+OPTIONS_DEFINE= PYREX
+PYREX_DESC= Use code generated by Pyrex to build
+
OPTIONSFILE= ${PORT_DBDIR}/py-${PORTNAME}/options
+.include <bsd.port.options.mk>
.include <bsd.port.pre.mk>
-.if !defined(WITHOUT_PYREX)
+.if ${PORT_OPTIONS:MPYREX}
BUILD_DEPENDS+= ${PYTHON_SITELIBDIR}/Pyrex/__init__.py:${PORTSDIR}/devel/pyrex
.endif
@@ -48,7 +46,7 @@ post-install:
@${FIND} ${PYTHONPREFIX_SITELIBDIR}/tables -type d | ${SORT} -r | \
${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${DISTDIR}/pytablesmanual-${PORTVERSION}.pdf ${DOCSDIR}
${ECHO} '${DOCSDIR}/pytablesmanual-${PORTVERSION}.pdf' | ${SED} 's,^${PREFIX}/,,' \
@@ -57,7 +55,7 @@ post-install:
>> ${TMPPLIST}
.endif
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/examples/*.py ${EXAMPLESDIR}
@${FIND} ${EXAMPLESDIR} ! -type d | \