aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2011-06-27 22:44:38 +0800
committermiwi <miwi@FreeBSD.org>2011-06-27 22:44:38 +0800
commitaa1e079fea22009a679482d5faa4da6ebe7ebce4 (patch)
tree664068408699b0a50c4a29e3c8d52f2d5a546ed6 /devel
parentc12063b909702e0d7bd25158e70c4d9fe6fd4196 (diff)
downloadfreebsd-ports-gnome-aa1e079fea22009a679482d5faa4da6ebe7ebce4.tar.gz
freebsd-ports-gnome-aa1e079fea22009a679482d5faa4da6ebe7ebce4.tar.zst
freebsd-ports-gnome-aa1e079fea22009a679482d5faa4da6ebe7ebce4.zip
This module provides an interface to libffi which enables you to call C
functions from Pure and vice versa. It extends and complements Pure's built-in C interface in that it also handles C structs and makes Pure functions callable from C without writing a single line of C code. WWW: http://docs.pure-lang.googlecode.com/hg/pure-ffi.html PR: ports/156103 Submitted by: Zhihao Yuan <lichray at gmail.com>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/pure-ffi/Makefile41
-rw-r--r--devel/pure-ffi/distinfo2
-rw-r--r--devel/pure-ffi/pkg-descr6
4 files changed, 50 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 8772c73d300c..f766a5b236a5 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2801,6 +2801,7 @@
SUBDIR += pty
SUBDIR += ptypes
SUBDIR += publib
+ SUBDIR += pure-ffi
SUBDIR += pure-gen
SUBDIR += pushmi
SUBDIR += pwlib
diff --git a/devel/pure-ffi/Makefile b/devel/pure-ffi/Makefile
new file mode 100644
index 000000000000..a89be8a27d9b
--- /dev/null
+++ b/devel/pure-ffi/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: pure-ffi
+# Date created: 2011-03-18
+# Whom: Zhihao Yuan <lichray@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pure-ffi
+PORTVERSION= 0.12
+CATEGORIES= devel
+MASTER_SITES= http://pure-lang.googlecode.com/files/
+
+MAINTAINER= lichray@gmail.com
+COMMENT= Pure langauge interface to libffi
+
+LIB_DEPENDS+= pure.7:${PORTSDIR}/lang/pure \
+ ffi:${PORTSDIR}/devel/libffi
+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USE_GCC= 4.2+
+USE_GMAKE= yes
+
+PLIST_FILES= lib/pure/ffi.pure \
+ lib/pure/ffi.so
+MAKE_ARGS+= prefix=${PREFIX} \
+ CPPFLAGS+=-I${LOCALBASE}/include \
+ LDFLAGS+=-L${LOCALBASE}/lib \
+ CFLAGS="${CFLAGS}"
+
+PORTEXAMPLES= *
+
+.include <bsd.port.pre.mk>
+
+post-install:
+.if !defined(NOPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+ (cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} \* ${EXAMPLESDIR})
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/pure-ffi/distinfo b/devel/pure-ffi/distinfo
new file mode 100644
index 000000000000..fb752eb0678e
--- /dev/null
+++ b/devel/pure-ffi/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pure-ffi-0.12.tar.gz) = 7aa9ce52ddc2154c22317352331afd42741830e3e00a80a7098bb7e155508282
+SIZE (pure-ffi-0.12.tar.gz) = 39555
diff --git a/devel/pure-ffi/pkg-descr b/devel/pure-ffi/pkg-descr
new file mode 100644
index 000000000000..cd2e2628ac1d
--- /dev/null
+++ b/devel/pure-ffi/pkg-descr
@@ -0,0 +1,6 @@
+This module provides an interface to libffi which enables you to call C
+functions from Pure and vice versa. It extends and complements Pure's
+built-in C interface in that it also handles C structs and makes Pure
+functions callable from C without writing a single line of C code.
+
+WWW: http://docs.pure-lang.googlecode.com/hg/pure-ffi.html