aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorperky <perky@FreeBSD.org>2004-10-29 10:28:49 +0800
committerperky <perky@FreeBSD.org>2004-10-29 10:28:49 +0800
commitabbd644bf40494120dad6b20f48d8ad3d48c3664 (patch)
tree144619b57d7f9f6f8ab0d396b132d1ec33eca0ae /devel
parent09efce191157c58f0950a07cfc4543ec56a8f128 (diff)
downloadfreebsd-ports-gnome-abbd644bf40494120dad6b20f48d8ad3d48c3664.tar.gz
freebsd-ports-gnome-abbd644bf40494120dad6b20f48d8ad3d48c3664.tar.zst
freebsd-ports-gnome-abbd644bf40494120dad6b20f48d8ad3d48c3664.zip
Update to 0.9.2
Diffstat (limited to 'devel')
-rw-r--r--devel/py-ctypes/Makefile30
-rw-r--r--devel/py-ctypes/distinfo4
-rw-r--r--devel/py-ctypes/files/patch-source_callproc.c16
-rw-r--r--devel/py-ctypes/pkg-plist1
4 files changed, 7 insertions, 44 deletions
diff --git a/devel/py-ctypes/Makefile b/devel/py-ctypes/Makefile
index 91fbd92cc9c7..9ee138d2ca55 100644
--- a/devel/py-ctypes/Makefile
+++ b/devel/py-ctypes/Makefile
@@ -6,13 +6,11 @@
#
PORTNAME= ctypes
-PORTVERSION= 0.6.3
+PORTVERSION= 0.9.2
CATEGORIES= devel python
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:S,%SUBDIR%/,ctypes/:pyctypes,g} \
- ${MASTER_SITE_LOCAL:S,%SUBDIR%/,perky/:libffi,g}
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:S,%SUBDIR%/,ctypes/,g}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-DISTFILES= ctypes-${PORTVERSION}.tar.gz:pyctypes \
- libffi-${LIBFFIVERSION}.tar.gz:libffi
+DISTFILES= ctypes-${PORTVERSION}.tar.gz
MAINTAINER= perky@FreeBSD.org
COMMENT= Python module allowing to create and manipulate C data types
@@ -21,36 +19,16 @@ USE_PYTHON= yes
USE_PYDISTUTILS=yes
USE_REINPLACE= yes
USE_GMAKE= yes
-GNU_CONFIGURE= yes
-
-# libffi on ports is incompatible with this port. so, we link the recent
-# version of it static.
-LIBFFIVERSION= 030511
-LIBFFIWRKSRC= ${WRKDIR}/libffi-${LIBFFIVERSION}
-CONFIGURE_ARGS= --enable-static --disable-shared
-CONFIGURE_WRKSRC=${LIBFFIWRKSRC}
ONLY_FOR_ARCHS= i386 alpha powerpc
.include <bsd.port.pre.mk>
post-patch:
- ${LN} -sf ${LIBFFIWRKSRC}/config-ml.in ${LIBFFIWRKSRC}/..
- ${REINPLACE_CMD} -e 's|\(include_dirs = \).*|\1["${LIBFFIWRKSRC}/include"]|' \
- -e 's|\(libraries=\["ffi"\]\)|\1,library_dirs=["${LIBFFIWRKSRC}/.libs"]|' \
+ ${REINPLACE_CMD} \
-e 's|\(Extension(.*\)$$|\1 define_macros=[("ffi_type_schar", \
"ffi_type_sint8"), ("ffi_type_sshort","ffi_type_sint16")],|' \
-e 's|define_macros=\[.*CAN_PASS_BY_VALUE.*\],||' \
${WRKSRC}/setup.py
- ${REINPLACE_CMD} -e 's,\(alpha\*-.*-osf.*\)),\1 | alpha*-*-freebsd*),' \
- ${LIBFFIWRKSRC}/configure
-.if ${ARCH} == "ia64"
- ${LN} -sf ${LIBFFIWRKSRC}/${ARCH}/${ARCH}_flags.h ${LIBFFIWRKSRC}/
- ${REINPLACE_CMD} -e 's|defined(IA64)|defined(__ia64__)|' \
- ${LIBFFIWRKSRC}/include/ffi.h
-.endif
-
-pre-build:
- cd ${LIBFFIWRKSRC}; ${MAKE_ENV} ${GMAKE}
.include <bsd.port.post.mk>
diff --git a/devel/py-ctypes/distinfo b/devel/py-ctypes/distinfo
index eabf32510bd4..8d243315b9b2 100644
--- a/devel/py-ctypes/distinfo
+++ b/devel/py-ctypes/distinfo
@@ -1,4 +1,4 @@
-MD5 (ctypes-0.6.3.tar.gz) = db17353042d9b96c9187fb8c4507f79f
-SIZE (ctypes-0.6.3.tar.gz) = 150590
+MD5 (ctypes-0.9.2.tar.gz) = 1acd425fcb69722aca1ab0395d66d780
+SIZE (ctypes-0.9.2.tar.gz) = 502482
MD5 (libffi-030511.tar.gz) = dcce311e68911b3d16729ce8602fd946
SIZE (libffi-030511.tar.gz) = 190872
diff --git a/devel/py-ctypes/files/patch-source_callproc.c b/devel/py-ctypes/files/patch-source_callproc.c
deleted file mode 100644
index 1eaf1f11afd4..000000000000
--- a/devel/py-ctypes/files/patch-source_callproc.c
+++ /dev/null
@@ -1,16 +0,0 @@
---- source/callproc.c.orig Mon Jun 9 13:22:12 2003
-+++ source/callproc.c Mon Jun 9 13:22:58 2003
-@@ -505,6 +505,13 @@
- #undef ffi_type_slong
- #define ffi_type_slong ffi_type_sint32
- #define ffi_type_slonglong ffi_type_sint64
-+#elif (SIZEOF_LONG_LONG == 8 && SIZEOF_LONG == 8)
-+#undef ffi_type_ulong
-+#define ffi_type_ulong ffi_type_uint64
-+#define ffi_type_ulonglong ffi_type_uint64
-+#undef ffi_type_slong
-+#define ffi_type_slong ffi_type_sint64
-+#define ffi_type_slonglong ffi_type_sint64
- #endif
-
- atypes = (ffi_type **)alloca(argcount * sizeof(ffi_type *));
diff --git a/devel/py-ctypes/pkg-plist b/devel/py-ctypes/pkg-plist
index 1b977a91fb14..8af7cb94c721 100644
--- a/devel/py-ctypes/pkg-plist
+++ b/devel/py-ctypes/pkg-plist
@@ -1,4 +1,5 @@
%%PYTHON_SITELIBDIR%%/_ctypes.so
+%%PYTHON_SITELIBDIR%%/_ctypes_test.so
%%PYTHON_SITELIBDIR%%/ctypes/__init__.py
%%PYTHON_SITELIBDIR%%/ctypes/__init__.pyc
%%PYTHON_SITELIBDIR%%/ctypes/__init__.pyo