aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorjoerg <joerg@FreeBSD.org>2009-04-06 15:11:23 +0800
committerjoerg <joerg@FreeBSD.org>2009-04-06 15:11:23 +0800
commitadf67448f7a356a54f1eb22ca90071224e6f650b (patch)
treed2043138e8b0ba708940b8287b5c65893fde8d4d /devel
parent993b0bfaf66b2dec3fffc550a93687bc84de7853 (diff)
downloadfreebsd-ports-gnome-adf67448f7a356a54f1eb22ca90071224e6f650b.tar.gz
freebsd-ports-gnome-adf67448f7a356a54f1eb22ca90071224e6f650b.tar.zst
freebsd-ports-gnome-adf67448f7a356a54f1eb22ca90071224e6f650b.zip
As cc --print-multi-os-dir yields "elf" on FreeBSD 6.x (but "." on 7.x and
above), the library ended up being installed in the wrong place on 6.x. Comment out the respective part of the Makefile.
Diffstat (limited to 'devel')
-rw-r--r--devel/gnulibiberty/Makefile2
-rw-r--r--devel/gnulibiberty/files/patch-Makefile.in19
2 files changed, 20 insertions, 1 deletions
diff --git a/devel/gnulibiberty/Makefile b/devel/gnulibiberty/Makefile
index c82051afe21c..01703ea4ad92 100644
--- a/devel/gnulibiberty/Makefile
+++ b/devel/gnulibiberty/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gnulibiberty
PORTVERSION= 2.19.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEWARE}
MASTER_SITE_SUBDIR= binutils/releases
diff --git a/devel/gnulibiberty/files/patch-Makefile.in b/devel/gnulibiberty/files/patch-Makefile.in
new file mode 100644
index 000000000000..a001481ddffd
--- /dev/null
+++ b/devel/gnulibiberty/files/patch-Makefile.in
@@ -0,0 +1,19 @@
+--- Makefile.in.orig Thu Jul 24 15:51:49 2008
++++ Makefile.in Mon Apr 6 09:05:19 2009
+@@ -348,11 +348,15 @@
+ INSTALL_DEST = @INSTALL_DEST@
+ install: install_to_$(INSTALL_DEST) install-subdir
+
++## FreeBSD port removed this: otherwise, FreeBSD 6.x would end up installing
++## in ${prefix}/lib/elf rather than ${prefix}/lib
++##
+ # This is tricky. Even though CC in the Makefile contains
+ # multilib-specific flags, it's overridden by FLAGS_TO_PASS from the
+ # default multilib, so we have to take LIBCFLAGS into account as well,
+ # since it will be passed the multilib flags.
+-MULTIOSDIR = `$(CC) $(LIBCFLAGS) -print-multi-os-directory`
++##MULTIOSDIR = `$(CC) $(LIBCFLAGS) -print-multi-os-directory`
++MULTIOSDIR = .
+ install_to_libdir: all
+ ${mkinstalldirs} $(DESTDIR)$(libdir)/$(MULTIOSDIR)
+ $(INSTALL_DATA) $(TARGETLIB) $(DESTDIR)$(libdir)/$(MULTIOSDIR)/$(TARGETLIB)n