aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authornivit <nivit@FreeBSD.org>2010-12-17 22:07:17 +0800
committernivit <nivit@FreeBSD.org>2010-12-17 22:07:17 +0800
commitb1814e7aa1163c2fc80bc310cdd9a79e14e17967 (patch)
tree8f8e9814c836be67332f3e3a9457ac6688cfddeb /devel
parenta735c0cb91cf2bdd3f8918fddac90531e609c538 (diff)
downloadfreebsd-ports-gnome-b1814e7aa1163c2fc80bc310cdd9a79e14e17967.tar.gz
freebsd-ports-gnome-b1814e7aa1163c2fc80bc310cdd9a79e14e17967.tar.zst
freebsd-ports-gnome-b1814e7aa1163c2fc80bc310cdd9a79e14e17967.zip
JWasm is a MASM v6 compatible assembler. It's a fork of Open Watcom's WASM
and released under the Sybase Open Watcom Public License, which allows free commercial and non-commercial use. JWasm is written in C, source code is open. JWasm Features: - JWasm natively supports output formats Intel OMF, MS Coff (32- and 64-bit), Elf (32-and 64-bit), Bin and DOS MZ. - precompiled JWasm binaries are available for DOS, Windows and Linux. For OS/2 and FreeBSD, makefiles are supplied. - Instructions up to SSSE3 are supported. - The JWasm source is portable and has successfully been tested with Open Watcom, MS VC, GCC and more. - As far as programming for Windows is concerned, JWasm can be used with both Win32Inc and Masm32. - C header files can be converted to include files for JWasm with h2incX. WWW: http://www.japheth.de/JWasm.html PR: ports/152727 Submitted by: Pedro F. Giffuni <giffunip at tutopia.com>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/jwasm/Makefile33
-rw-r--r--devel/jwasm/distinfo2
-rw-r--r--devel/jwasm/files/patch-GccUnix.mak20
-rw-r--r--devel/jwasm/pkg-descr19
-rw-r--r--devel/jwasm/pkg-plist7
6 files changed, 82 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 17033651c5da..33c012ad6d4c 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -685,6 +685,7 @@
SUBDIR += jtag
SUBDIR += jude-community
SUBDIR += judy
+ SUBDIR += jwasm
SUBDIR += jzmq
SUBDIR += k8048
SUBDIR += kBuild
diff --git a/devel/jwasm/Makefile b/devel/jwasm/Makefile
new file mode 100644
index 000000000000..da92fe3a96b9
--- /dev/null
+++ b/devel/jwasm/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: jwasm
+# Date created: 7 April 2009
+# Whom: Pedro F. Giffuni <giffunip@tutopia.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= jwasm
+PORTVERSION= 204
+CATEGORIES= devel
+MASTER_SITES= http://www.japheth.de/Download/JWasm/
+DISTNAME= JWasm${PORTVERSION}cs
+
+MAINTAINER= giffunip@tutopia.com
+COMMENT= Fork of OpenWatcom's x86 assembler with AMD64 support
+
+ONLY_FOR_ARCHS= amd64 i386
+
+USE_ZIP= yes
+USE_GMAKE= yes
+MAKEFILE= GccUnix.mak
+NO_WRKSUBDIR= yes
+EXTRACT_BEFORE_ARGS= -qa
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/GccUnixR/jwasm ${PREFIX}/bin/
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/*.txt ${DOCSDIR}
+ @${GZIP_CMD} ${DOCSDIR}/*.txt
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/jwasm/distinfo b/devel/jwasm/distinfo
new file mode 100644
index 000000000000..3da259ecc70c
--- /dev/null
+++ b/devel/jwasm/distinfo
@@ -0,0 +1,2 @@
+SHA256 (JWasm204cs.zip) = a45de9c536adb670751ef6d089a6fd94baab0b28dfc076250fe0e5ecd0339017
+SIZE (JWasm204cs.zip) = 642684
diff --git a/devel/jwasm/files/patch-GccUnix.mak b/devel/jwasm/files/patch-GccUnix.mak
new file mode 100644
index 000000000000..0a1c976f0d82
--- /dev/null
+++ b/devel/jwasm/files/patch-GccUnix.mak
@@ -0,0 +1,20 @@
+--- GccUnix.mak.orig 2009-06-07 14:07:37.000000000 -0500
++++ GccUnix.mak 2009-06-07 14:09:18.000000000 -0500
+@@ -14,7 +14,7 @@
+ #cflags stuff
+
+ ifeq ($(DEBUG),0)
+-extra_c_flags = -DNDEBUG -O2
++extra_c_flags = -DNDEBUG ${CFLAGS}
+ OUTD=GccUnixR
+ else
+ extra_c_flags = -DDEBUG_OUT -g
+@@ -23,7 +23,7 @@
+
+ c_flags =-D__UNIX__ $(extra_c_flags)
+
+-CC = gcc
++#CC = cc
+
+ .SUFFIXES:
+ .SUFFIXES: .c .o
diff --git a/devel/jwasm/pkg-descr b/devel/jwasm/pkg-descr
new file mode 100644
index 000000000000..d62a5d47dbf8
--- /dev/null
+++ b/devel/jwasm/pkg-descr
@@ -0,0 +1,19 @@
+JWasm is a MASM v6 compatible assembler. It's a fork of Open Watcom's WASM
+and released under the Sybase Open Watcom Public License, which allows
+free commercial and non-commercial use. JWasm is written in C, source code
+is open.
+
+JWasm Features:
+
+- JWasm natively supports output formats Intel OMF, MS Coff (32- and
+64-bit), Elf (32-and 64-bit), Bin and DOS MZ.
+- precompiled JWasm binaries are available for DOS, Windows and Linux. For
+OS/2 and FreeBSD, makefiles are supplied.
+- Instructions up to SSSE3 are supported.
+- The JWasm source is portable and has successfully been tested with Open
+Watcom, MS VC, GCC and more.
+- As far as programming for Windows is concerned, JWasm can be used with
+both Win32Inc and Masm32.
+- C header files can be converted to include files for JWasm with h2incX.
+
+WWW: http://www.japheth.de/JWasm.html
diff --git a/devel/jwasm/pkg-plist b/devel/jwasm/pkg-plist
new file mode 100644
index 000000000000..7c82c88fc249
--- /dev/null
+++ b/devel/jwasm/pkg-plist
@@ -0,0 +1,7 @@
+@comment $FreeBSD$
+bin/jwasm
+%%PORTDOCS%%%%DOCSDIR%%/History.txt.gz
+%%PORTDOCS%%%%DOCSDIR%%/License.txt.gz
+%%PORTDOCS%%%%DOCSDIR%%/Manual.txt.gz
+%%PORTDOCS%%%%DOCSDIR%%/Readme.txt.gz
+%%PORTDOCS%%@dirrm %%DOCSDIR%%