aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-01-21 09:01:15 +0800
committerbapt <bapt@FreeBSD.org>2014-01-21 09:01:15 +0800
commitb515a251deed389d00dc4db4dae86cdd6d5f7517 (patch)
treede6281a9a2ea885374fae248fb41140ccc520761 /devel
parent366e1dde06c1a5da35d317822375678a244a58ed (diff)
downloadfreebsd-ports-gnome-b515a251deed389d00dc4db4dae86cdd6d5f7517.tar.gz
freebsd-ports-gnome-b515a251deed389d00dc4db4dae86cdd6d5f7517.tar.zst
freebsd-ports-gnome-b515a251deed389d00dc4db4dae86cdd6d5f7517.zip
Support stage
Respect examplesdir
Diffstat (limited to 'devel')
-rw-r--r--devel/libshhopt/Makefile21
-rw-r--r--devel/libshhopt/pkg-plist13
2 files changed, 17 insertions, 17 deletions
diff --git a/devel/libshhopt/Makefile b/devel/libshhopt/Makefile
index de0e11c3a7bc..3dc8c29412c3 100644
--- a/devel/libshhopt/Makefile
+++ b/devel/libshhopt/Makefile
@@ -3,25 +3,26 @@
PORTNAME= libshhopt
PORTVERSION= 1.1.7
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://shh.thathost.com/pub-unix/files/
DISTNAME= shhopt-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
-COMMENT= A library for parsing command line options
+COMMENT= Library for parsing command line options
+OPTIONS_DEFINE= DOCS EXAMPLES
+
+USES= uidfix
MAKEFILE= ${FILESDIR}/Makefile.lib
USE_LDCONFIG= yes
-NO_STAGE= yes
post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/CREDITS ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
- @${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${FILESDIR}/Makefile ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/example.c ${EXAMPLESDIR}
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/CREDITS ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${FILESDIR}/Makefile ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/example.c ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>
diff --git a/devel/libshhopt/pkg-plist b/devel/libshhopt/pkg-plist
index e2af964b9520..0210dea39ec9 100644
--- a/devel/libshhopt/pkg-plist
+++ b/devel/libshhopt/pkg-plist
@@ -1,11 +1,10 @@
-@comment $FreeBSD$
include/shhopt.h
lib/libshhopt.a
lib/libshhopt.so
lib/libshhopt.so.1
-%%PORTDOCS%%share/doc/libshhopt/CREDITS
-%%PORTDOCS%%share/doc/libshhopt/README
-%%PORTDOCS%%share/examples/libshhopt/Makefile
-%%PORTDOCS%%share/examples/libshhopt/example.c
-%%PORTDOCS%%@dirrm share/examples/libshhopt
-%%PORTDOCS%%@dirrm share/doc/libshhopt
+%%PORTDOCS%%%%DOCSDIR%%/CREDITS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example.c
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%