aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorphilip <philip@FreeBSD.org>2006-08-04 19:10:12 +0800
committerphilip <philip@FreeBSD.org>2006-08-04 19:10:12 +0800
commitb79d95c050bde3eee907c059aad0c453db8467ae (patch)
tree622cff4ff40964ed4913883a8a2288c7a196f31a /devel
parent4ad93ba22a0e7c71626e42c07adcaaaebe10acb6 (diff)
downloadfreebsd-ports-gnome-b79d95c050bde3eee907c059aad0c453db8467ae.tar.gz
freebsd-ports-gnome-b79d95c050bde3eee907c059aad0c453db8467ae.tar.zst
freebsd-ports-gnome-b79d95c050bde3eee907c059aad0c453db8467ae.zip
Add p5-DateTime-Calendar-Discordian:
A module that implements the Discordian calendar made popular(?) in the "Illuminatus!" trilogy by Robert Shea and Robert Anton Wilson and by the Church of the SubGenius. Very useful during codefreeze to tell the testing-team why the build is failing or why there are regressions. :-)
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-DateTime-Calendar-Discordian/Makefile27
-rw-r--r--devel/p5-DateTime-Calendar-Discordian/distinfo3
-rw-r--r--devel/p5-DateTime-Calendar-Discordian/pkg-descr5
-rw-r--r--devel/p5-DateTime-Calendar-Discordian/pkg-plist7
5 files changed, 43 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 035e406861e8..277c1185f539 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -925,6 +925,7 @@
SUBDIR += p5-DateConvert
SUBDIR += p5-DateTime
SUBDIR += p5-DateTime-Calendar-Christian
+ SUBDIR += p5-DateTime-Calendar-Discordian
SUBDIR += p5-DateTime-Calendar-FrenchRevolutionary
SUBDIR += p5-DateTime-Calendar-Hebrew
SUBDIR += p5-DateTime-Calendar-Julian
diff --git a/devel/p5-DateTime-Calendar-Discordian/Makefile b/devel/p5-DateTime-Calendar-Discordian/Makefile
new file mode 100644
index 000000000000..dd19f471db22
--- /dev/null
+++ b/devel/p5-DateTime-Calendar-Discordian/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-DateTime-Calendar-Discordian
+# Date created: 04 August 2006
+# Whom: Philip Paeps <philip@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DateTime-Calendar-Discordian
+PORTVERSION= 0.9.2
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= DateTime
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= philip@FreeBSD.org
+COMMENT= Perl extension for the Discordian Calendar
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DateTime.pm:${PORTSDIR}/devel/p5-DateTime \
+ ${SITE_PERL}/${PERL_ARCH}/DateTime/Locale.pm:${PORTSDIR}/devel/p5-DateTime-Locale \
+ ${SITE_PERL}/${PERL_ARCH}/Params/Validate.pm:${PORTSDIR}/devel/p5-Params-Validate
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= DateTime::Calendar::Discordian.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-DateTime-Calendar-Discordian/distinfo b/devel/p5-DateTime-Calendar-Discordian/distinfo
new file mode 100644
index 000000000000..7ae6d7b8a935
--- /dev/null
+++ b/devel/p5-DateTime-Calendar-Discordian/distinfo
@@ -0,0 +1,3 @@
+MD5 (DateTime-Calendar-Discordian-0.9.2.tar.gz) = c00f1b31f7751f044afa8199fa41c134
+SHA256 (DateTime-Calendar-Discordian-0.9.2.tar.gz) = 8cda878e0050206f594f0e0f71cc226c21442bad01cbb744a2143d4eef96cea9
+SIZE (DateTime-Calendar-Discordian-0.9.2.tar.gz) = 20889
diff --git a/devel/p5-DateTime-Calendar-Discordian/pkg-descr b/devel/p5-DateTime-Calendar-Discordian/pkg-descr
new file mode 100644
index 000000000000..80a58d0538ca
--- /dev/null
+++ b/devel/p5-DateTime-Calendar-Discordian/pkg-descr
@@ -0,0 +1,5 @@
+A module that implements the Discordian calendar made popular(?) in the
+"Illuminatus!" trilogy by Robert Shea and Robert Anton Wilson and by the
+Church of the SubGenius.
+
+WWW: http://search.cpan.org/dist/DateTime-Calendar-Discordian/
diff --git a/devel/p5-DateTime-Calendar-Discordian/pkg-plist b/devel/p5-DateTime-Calendar-Discordian/pkg-plist
new file mode 100644
index 000000000000..ecea65678828
--- /dev/null
+++ b/devel/p5-DateTime-Calendar-Discordian/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime/Calendar/Discordian/.packlist
+%%SITE_PERL%%/DateTime/Calendar/Discordian.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime/Calendar/Discordian
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime/Calendar
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime
+@dirrmtry %%SITE_PERL%%/DateTime/Calendar
+@dirrmtry %%SITE_PERL%%/DateTime