aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authortobez <tobez@FreeBSD.org>2013-01-14 19:37:27 +0800
committertobez <tobez@FreeBSD.org>2013-01-14 19:37:27 +0800
commitbd7d5102d28d041809af10ea74a5411d9ed748f9 (patch)
treee77a4a0bc4fc18dc8bcaed2cb10411b0e4e7d965 /devel
parentc7c3e02751b7f1c2d191bea92b05d607ac922028 (diff)
downloadfreebsd-ports-gnome-bd7d5102d28d041809af10ea74a5411d9ed748f9.tar.gz
freebsd-ports-gnome-bd7d5102d28d041809af10ea74a5411d9ed748f9.tar.zst
freebsd-ports-gnome-bd7d5102d28d041809af10ea74a5411d9ed748f9.zip
Add devel/p5-namespace-sweep 0.006, a Perl module to
sweep up imported subs in your classes.
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-namespace-sweep/Makefile23
-rw-r--r--devel/p5-namespace-sweep/distinfo2
-rw-r--r--devel/p5-namespace-sweep/pkg-descr9
-rw-r--r--devel/p5-namespace-sweep/pkg-plist5
5 files changed, 40 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 7748d88b44b3..4ecb29609b32 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2925,6 +2925,7 @@
SUBDIR += p5-mocked
SUBDIR += p5-namespace-autoclean
SUBDIR += p5-namespace-clean
+ SUBDIR += p5-namespace-sweep
SUBDIR += p5-orz
SUBDIR += p5-parent
SUBDIR += p5-perlbrew
diff --git a/devel/p5-namespace-sweep/Makefile b/devel/p5-namespace-sweep/Makefile
new file mode 100644
index 000000000000..7e2456adc82b
--- /dev/null
+++ b/devel/p5-namespace-sweep/Makefile
@@ -0,0 +1,23 @@
+# Created by: Anton Berezin <tobez@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= namespace-sweep
+PORTVERSION= 0.006
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= Sweep up imported subs in your classes
+
+BUILD_DEPENDS= p5-B-Hooks-EndOfScope>=0.09:${PORTSDIR}/devel/p5-B-Hooks-EndOfScope \
+ p5-Package-Stash>=0.33:${PORTSDIR}/devel/p5-Package-Stash \
+ p5-Sub-Identify>=0.04:${PORTSDIR}/devel/p5-Sub-Identify \
+ p5-Sub-Name>=0:${PORTSDIR}/devel/p5-Sub-Name
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= namespace::sweep.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-namespace-sweep/distinfo b/devel/p5-namespace-sweep/distinfo
new file mode 100644
index 000000000000..b522c69978fb
--- /dev/null
+++ b/devel/p5-namespace-sweep/distinfo
@@ -0,0 +1,2 @@
+SHA256 (namespace-sweep-0.006.tar.gz) = de99ce915ab0f93781580e3433d7dc9c2585a2789627173b280c6030ac0b1953
+SIZE (namespace-sweep-0.006.tar.gz) = 12748
diff --git a/devel/p5-namespace-sweep/pkg-descr b/devel/p5-namespace-sweep/pkg-descr
new file mode 100644
index 000000000000..ad63ff9e5278
--- /dev/null
+++ b/devel/p5-namespace-sweep/pkg-descr
@@ -0,0 +1,9 @@
+Because Perl methods are just regular subroutines, it's difficult to
+tell what's a method and what's just an imported function. As a result,
+imported functions can be called as methods on your objects. This pragma
+will delete imported functions from your class's symbol table, thereby
+ensuring that your interface is as you specified it. However, code
+inside your module will still be able to use the imported functions
+without any problems.
+
+WWW: http://search.cpan.org/dist/namespace-sweep/
diff --git a/devel/p5-namespace-sweep/pkg-plist b/devel/p5-namespace-sweep/pkg-plist
new file mode 100644
index 000000000000..be296d5546fc
--- /dev/null
+++ b/devel/p5-namespace-sweep/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/namespace/sweep/.packlist
+%%SITE_PERL%%/namespace/sweep.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/namespace/sweep
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/namespace
+@dirrmtry %%SITE_PERL%%/namespace