aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2011-08-01 04:04:25 +0800
committerkwm <kwm@FreeBSD.org>2011-08-01 04:04:25 +0800
commitc05e32209766da4cbdbbc5c712a745fd63410d16 (patch)
tree10bcb8e0f8f2333635de1737a9b4e3426dcedcad /devel
parent3b7fbffc0629010d38637ece34eb8688f6b7ab2c (diff)
downloadfreebsd-ports-gnome-c05e32209766da4cbdbbc5c712a745fd63410d16.tar.gz
freebsd-ports-gnome-c05e32209766da4cbdbbc5c712a745fd63410d16.tar.zst
freebsd-ports-gnome-c05e32209766da4cbdbbc5c712a745fd63410d16.zip
Update to 4.2.0.
Pet portlint by moving LICENSE block. Add depend on security/libgcrypt since gnutls no longer depends on it. Add a patch to fix symbol visibility support with cc. PR: ports/159032 Submitted by: maintainer
Diffstat (limited to 'devel')
-rw-r--r--devel/gwenhywfar/Makefile18
-rw-r--r--devel/gwenhywfar/distinfo4
-rw-r--r--devel/gwenhywfar/files/patch-configure11
-rw-r--r--devel/gwenhywfar/pkg-plist6
4 files changed, 27 insertions, 12 deletions
diff --git a/devel/gwenhywfar/Makefile b/devel/gwenhywfar/Makefile
index 4ce93ca03f39..8bf7b2b683c4 100644
--- a/devel/gwenhywfar/Makefile
+++ b/devel/gwenhywfar/Makefile
@@ -6,16 +6,18 @@
#
PORTNAME= gwenhywfar
-PORTVERSION= 4.0.9
-PORTREVISION= 1
+PORTVERSION= 4.2.0
CATEGORIES= devel net security
-MASTER_SITES= http://www2.aquamaniac.de/sites/download/
-DISTFILES= download.php\?package=01\&release=60\&file=01\&dummy=${DISTNAME}${EXTRACT_SUFX}
+MASTER_SITES= http://www.aquamaniac.de/sites/download/download.php?package=01&release=62&file=01&dummy=/
MAINTAINER= bsdkaffee@gmail.com
COMMENT= Multi-platform helper library for networking and security applications
-LIB_DEPENDS= gnutls.47:${PORTSDIR}/security/gnutls
+LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= gcrypt.18:${PORTSDIR}/security/libgcrypt \
+ gnutls.47:${PORTSDIR}/security/gnutls
USE_GMAKE= yes
USE_GETTEXT= yes
@@ -23,9 +25,6 @@ USE_OPENSSL= yes
USE_AUTOTOOLS= libtool
USE_GNOME= gnomehack pkgconfig
-LICENSE= LGPL21
-LICENSE_FILE= ${WRKSRC}/COPYING
-
OPTIONS= APIDOC "Full API documentation (requires Doxygen)" off \
MEMDEBUG "Enable memory debugger statistic" off \
FOX16 "Build FOX 1.6 GUI" off \
@@ -47,7 +46,8 @@ GWEN_SHLIB_VER= 60
.include <bsd.port.options.mk>
.if !defined(NOPORTDOCS) && defined(WITH_APIDOC)
-BUILD_DEPENDS+= doxygen:${PORTSDIR}/devel/doxygen
+BUILD_DEPENDS+= doxygen:${PORTSDIR}/devel/doxygen \
+ dot:${PORTSDIR}/graphics/graphviz
CONFIGURE_ARGS+=--enable-full-doc
PORTDOCS= apidoc
.endif
diff --git a/devel/gwenhywfar/distinfo b/devel/gwenhywfar/distinfo
index 845eb5d86715..05c371558b0b 100644
--- a/devel/gwenhywfar/distinfo
+++ b/devel/gwenhywfar/distinfo
@@ -1,2 +1,2 @@
-SHA256 (download.php?package=01&release=60&file=01&dummy=gwenhywfar-4.0.9.tar.gz) = 4cbc83b3c29e2c54e5448a01a7001c79263d8a1c657e951c1f781490649e3b52
-SIZE (download.php?package=01&release=60&file=01&dummy=gwenhywfar-4.0.9.tar.gz) = 2062015
+SHA256 (gwenhywfar-4.2.0.tar.gz) = fbfc7ee4799a594af689d04d32937e799a61358dd42db6e693ddd68bf99d56e4
+SIZE (gwenhywfar-4.2.0.tar.gz) = 2315292
diff --git a/devel/gwenhywfar/files/patch-configure b/devel/gwenhywfar/files/patch-configure
new file mode 100644
index 000000000000..ba189110f1d0
--- /dev/null
+++ b/devel/gwenhywfar/files/patch-configure
@@ -0,0 +1,11 @@
+--- ./configure.orig 2011-07-19 09:08:26.000000000 -0400
++++ ./configure 2011-07-19 09:08:11.000000000 -0400
+@@ -20457,7 +20457,7 @@
+ $as_echo_n "checking if symbol visibility is supported... " >&6; }
+ visibility_cflags=""
+ case `$CC --version|head -n1|cut -f1 -d " "` in
+- *gcc*)
++ cc|*gcc*)
+ gccversion="` ${CC} -dumpversion `"
+ case $gccversion in
+ 4.*)
diff --git a/devel/gwenhywfar/pkg-plist b/devel/gwenhywfar/pkg-plist
index 0ea7ea3c039d..55efc000532c 100644
--- a/devel/gwenhywfar/pkg-plist
+++ b/devel/gwenhywfar/pkg-plist
@@ -1,4 +1,5 @@
bin/gct-tool
+bin/gsa
bin/gwenhywfar-config
bin/mklistdoc
bin/typemaker
@@ -53,6 +54,7 @@ include/gwenhywfar4/gwenhywfar/fastbuffer.h
include/gwenhywfar4/gwenhywfar/fslock.h
include/gwenhywfar4/gwenhywfar/gui.h
include/gwenhywfar4/gwenhywfar/gui_be.h
+include/gwenhywfar4/gwenhywfar/gwen_sar_fileheader.h
include/gwenhywfar4/gwenhywfar/gwendate.h
include/gwenhywfar4/gwenhywfar/gwenhywfar.h
include/gwenhywfar4/gwenhywfar/gwenhywfarapi.h
@@ -98,6 +100,7 @@ include/gwenhywfar4/gwenhywfar/plugindescr.h
include/gwenhywfar4/gwenhywfar/process.h
include/gwenhywfar4/gwenhywfar/refptr.h
include/gwenhywfar4/gwenhywfar/ringbuffer.h
+include/gwenhywfar4/gwenhywfar/sar.h
include/gwenhywfar4/gwenhywfar/sighead.h
include/gwenhywfar4/gwenhywfar/sigtail.h
include/gwenhywfar4/gwenhywfar/smalltresor.h
@@ -163,7 +166,7 @@ lib/gwenhywfar/plugins/%%GWEN_SHLIB_VER%%/dbio/xmldb.xml
lib/libgwenhywfar.a
lib/libgwenhywfar.la
lib/libgwenhywfar.so
-lib/libgwenhywfar.so.%%GWEN_SHLIB_VER%%
+lib/libgwenhywfar.so.62
%%WITH_FOX16%%libdata/pkgconfig/gwengui-fox16.pc
%%WITH_GTK2%%libdata/pkgconfig/gwengui-gtk2.pc
%%WITH_QT4%%libdata/pkgconfig/gwengui-qt4.pc
@@ -188,6 +191,7 @@ share/gwenhywfar/typemaker2/c/list2_base.tm2
share/gwenhywfar/typemaker2/c/struct_base.tm2
share/gwenhywfar/typemaker2/c/tree_base.tm2
share/gwenhywfar/typemaker2/c/uint32_t.tm2
+share/gwenhywfar/typemaker2/c/uint64_t.tm2
share/locale/de/LC_MESSAGES/gwenhywfar.mo
@dirrm share/gwenhywfar/typemaker2/c
@dirrm share/gwenhywfar/typemaker2