aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2006-11-04 15:04:42 +0800
committermarcus <marcus@FreeBSD.org>2006-11-04 15:04:42 +0800
commitc242339f8164fa8b5c8cc906450801aecc76bc0c (patch)
treee9a0c64baf77248abb7e7d1a9e1a5b5abb59df97 /devel
parentef18a19bb5afd18806da1ea4b9fc739d86c401f0 (diff)
downloadfreebsd-ports-gnome-c242339f8164fa8b5c8cc906450801aecc76bc0c.tar.gz
freebsd-ports-gnome-c242339f8164fa8b5c8cc906450801aecc76bc0c.tar.zst
freebsd-ports-gnome-c242339f8164fa8b5c8cc906450801aecc76bc0c.zip
Add libvolume_id, a port of the Linux libvolume_id from the udev project.
Libvolume_id is an API for obtaining many file system related attributes (such as type, label, uuid, etc.) given an open file handle to a block special device. HAL is the primary FreeBSD consumer of this port currently. Bits needed for this port to work on FreeBSD were provided by jylefort.
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/libvolume_id/Makefile36
-rw-r--r--devel/libvolume_id/distinfo3
-rw-r--r--devel/libvolume_id/pkg-descr3
4 files changed, 43 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 79fc3b67836f..ca7eac12e26c 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -599,6 +599,7 @@
SUBDIR += libvanessa_logger
SUBDIR += libvanessa_socket
SUBDIR += libvc
+ SUBDIR += libvolume_id
SUBDIR += libxalloc
SUBDIR += libytnef
SUBDIR += libzrtpcpp
diff --git a/devel/libvolume_id/Makefile b/devel/libvolume_id/Makefile
new file mode 100644
index 000000000000..159aaffc052f
--- /dev/null
+++ b/devel/libvolume_id/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: libvolume_id
+# Date created: 04 November 2006
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= libvolume_id
+PORTVERSION= 0.71.0
+CATEGORIES= devel
+MASTER_SITES= http://www.marcuscom.com/downloads/
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Library to provide file system type information
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_GNOME= pkgconfig
+USE_LDCONFIG= yes
+MAKE_ENV= E=${ECHO_MSG} RANLIB=${RANLIB} AR=${AR} Q=@ \
+ CC=${CC} prefix=${PREFIX}
+
+PLIST_FILES= include/libvolume_id.h \
+ lib/libvolume_id.a \
+ lib/libvolume_id.so \
+ lib/libvolume_id.so.0 \
+ libdata/pkgconfig/libvolume_id.pc
+
+do-install:
+ ${MKDIR} ${PREFIX}/libdata/pkgconfig
+ ${INSTALL_DATA} ${WRKSRC}/libvolume_id.pc ${PREFIX}/libdata/pkgconfig/libvolume_id.pc
+ ${INSTALL_DATA} ${WRKSRC}/libvolume_id.h ${PREFIX}/include/libvolume_id.h
+ ${INSTALL_DATA} ${WRKSRC}/libvolume_id.a ${PREFIX}/lib/libvolume_id.a
+ ${INSTALL_PROGRAM} ${WRKSRC}/libvolume_id.so.0 ${PREFIX}/lib/libvolume_id.so.0
+ ${LN} -sf ${PREFIX}/lib/libvolume_id.so.0 ${PREFIX}/lib/libvolume_id.so
+
+.include <bsd.port.mk>
diff --git a/devel/libvolume_id/distinfo b/devel/libvolume_id/distinfo
new file mode 100644
index 000000000000..328c63836ac0
--- /dev/null
+++ b/devel/libvolume_id/distinfo
@@ -0,0 +1,3 @@
+MD5 (libvolume_id-0.71.0.tar.bz2) = 7a27f133d6c441801bc0626c2393cdcf
+SHA256 (libvolume_id-0.71.0.tar.bz2) = 65446fa12c2556cea6cab3cd406d0bb9a6e672894f89ff84e168c8add9ce1038
+SIZE (libvolume_id-0.71.0.tar.bz2) = 18951
diff --git a/devel/libvolume_id/pkg-descr b/devel/libvolume_id/pkg-descr
new file mode 100644
index 000000000000..7cc7c5dcd956
--- /dev/null
+++ b/devel/libvolume_id/pkg-descr
@@ -0,0 +1,3 @@
+Libvolume_id is a library that provides file system information for a given
+volume device (i.e. file system type, label, etc.). It supports all of the
+major file systems.