aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorobraun <obraun@FreeBSD.org>2003-02-01 06:24:58 +0800
committerobraun <obraun@FreeBSD.org>2003-02-01 06:24:58 +0800
commitc31a9557ec3ce8ec6eb138080a0ad85f0b89cfc8 (patch)
tree81d9bf828ab67b933331dbfc1d638e69fbfcafad /devel
parentf9367cfa4163f1a2321957375940842724f71237 (diff)
downloadfreebsd-ports-gnome-c31a9557ec3ce8ec6eb138080a0ad85f0b89cfc8.tar.gz
freebsd-ports-gnome-c31a9557ec3ce8ec6eb138080a0ad85f0b89cfc8.tar.zst
freebsd-ports-gnome-c31a9557ec3ce8ec6eb138080a0ad85f0b89cfc8.zip
Add hs-alex 1.1, alex is a Lex-like package for generating Haskell scanners.
PR: ports/47644 Submitted by: Volker Stolz <stolz@i2.informatik.rwth-aachen.de>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/hs-alex/Makefile37
-rw-r--r--devel/hs-alex/distinfo1
-rw-r--r--devel/hs-alex/pkg-comment1
-rw-r--r--devel/hs-alex/pkg-descr4
-rw-r--r--devel/hs-alex/pkg-plist16
6 files changed, 60 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 4b94df598097..65c3695688e5 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -229,6 +229,7 @@
SUBDIR += gvd
SUBDIR += happydoc
SUBDIR += hp48cc
+ SUBDIR += hs-alex
SUBDIR += hs-buddha
SUBDIR += hs-c2hs
SUBDIR += hs-drift
diff --git a/devel/hs-alex/Makefile b/devel/hs-alex/Makefile
new file mode 100644
index 000000000000..c2b7a077a1e2
--- /dev/null
+++ b/devel/hs-alex/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: alex
+# Date created: 29 January 2003
+# Whom: Volker Stolz <stolz@i2.informatik.rwth-aachen.de>
+#
+# $FreeBSD$
+
+PORTNAME= alex
+PORTVERSION= 1.1
+CATEGORIES= devel haskell
+MASTER_SITES= http://www.syntaxpolice.org/~ijones/alex/
+DISTNAME= ${PORTNAME}
+DIST_SUBDIR= ${PORTNAME}-${PORTVERSION}
+
+PKGNAMEPREFIX= hs-
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc
+
+USE_GMAKE= yes
+
+BUILD_WRKSRC= ${WRKSRC}/src
+MAKEFILE= makefile
+ALL_TARGET= alex
+
+do-install:
+ ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/alex ${PREFIX}/bin
+ ${MKDIR} ${EXAMPLESDIR}
+.for i in Alex.hs ctx.x lit.lx pp.x tiny.y xscan.x Tokens.x examples.x makefile state.x tkns.hs
+ ${INSTALL_DATA} ${WRKSRC}/examples/$i ${EXAMPLESDIR}
+.endfor
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/alex.ps ${WRKSRC}/doc/alex.pdf ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/hs-alex/distinfo b/devel/hs-alex/distinfo
new file mode 100644
index 000000000000..a870d229363d
--- /dev/null
+++ b/devel/hs-alex/distinfo
@@ -0,0 +1 @@
+MD5 (alex-1.1/alex.tar.gz) = 3b109767f6fb0aaafed9170f99109aa5
diff --git a/devel/hs-alex/pkg-comment b/devel/hs-alex/pkg-comment
new file mode 100644
index 000000000000..25de693237d5
--- /dev/null
+++ b/devel/hs-alex/pkg-comment
@@ -0,0 +1 @@
+Alex is a Lex-like package for generating Haskell scanners
diff --git a/devel/hs-alex/pkg-descr b/devel/hs-alex/pkg-descr
new file mode 100644
index 000000000000..7a8b31f2b1bb
--- /dev/null
+++ b/devel/hs-alex/pkg-descr
@@ -0,0 +1,4 @@
+Alex is a Lex-like package for generating Haskell scanners
+by Chris Dornan.
+
+WWW: http://www.syntaxpolice.org/~ijones/alex/
diff --git a/devel/hs-alex/pkg-plist b/devel/hs-alex/pkg-plist
new file mode 100644
index 000000000000..c62f913b6feb
--- /dev/null
+++ b/devel/hs-alex/pkg-plist
@@ -0,0 +1,16 @@
+bin/alex
+%%PORTDOCS%%share/doc/alex/alex.ps
+%%PORTDOCS%%share/doc/alex/alex.pdf
+%%PORTDOCS%%@dirrm share/doc/alex
+share/examples/alex/Alex.hs
+share/examples/alex/Tokens.x
+share/examples/alex/ctx.x
+share/examples/alex/examples.x
+share/examples/alex/lit.lx
+share/examples/alex/makefile
+share/examples/alex/pp.x
+share/examples/alex/state.x
+share/examples/alex/tiny.y
+share/examples/alex/tkns.hs
+share/examples/alex/xscan.x
+@dirrm share/examples/alex