aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-05-07 21:12:31 +0800
committerbapt <bapt@FreeBSD.org>2013-05-07 21:12:31 +0800
commitc51dc118d16532cbb0975f6a1283f79f0f639846 (patch)
tree5522ebdbbbc41a02fbc8bf3da8fa96b3719b6d61 /devel
parentd6971706dddb262040a6508b9b7e08ba636e3147 (diff)
downloadfreebsd-ports-gnome-c51dc118d16532cbb0975f6a1283f79f0f639846.tar.gz
freebsd-ports-gnome-c51dc118d16532cbb0975f6a1283f79f0f639846.tar.zst
freebsd-ports-gnome-c51dc118d16532cbb0975f6a1283f79f0f639846.zip
Add some shebangfix to allow building most of the ports tree without /usr/bin/perl
Submitted by: John Marino Obtained from: DPorts
Diffstat (limited to 'devel')
-rw-r--r--devel/autogen/Makefile10
-rw-r--r--devel/cc65/Makefile5
-rw-r--r--devel/coccinelle/Makefile2
-rw-r--r--devel/otrs/Makefile3
4 files changed, 14 insertions, 6 deletions
diff --git a/devel/autogen/Makefile b/devel/autogen/Makefile
index b50e2902e04c..6046ff81f2ba 100644
--- a/devel/autogen/Makefile
+++ b/devel/autogen/Makefile
@@ -1,13 +1,9 @@
-# ex:ts=8
-# New ports collection makefile for: autogen
-# Date created: Mar 11, 2001
-# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
-#
+# Created by: Ying-Chieh Liao <ijliao@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= autogen
PORTVERSION= 5.12
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= GNU
MASTER_SITE_SUBDIR= ${PORTNAME}/rel${PORTVERSION}
@@ -19,12 +15,14 @@ COMMENT= The Automated Program Generator
BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
LIB_DEPENDS= guile.21:${PORTSDIR}/lang/guile
+USES= shebangfix
USE_BZIP2= yes
USE_GNOME= gnomehack libxml2
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-libguile=yes --with-libxml2=yes --datadir=${PREFIX}/share
USE_LDCONFIG= yes
+SHEBANG_FILES= autoopts/tpl/*.pl
MAN1= autogen.1 autoopts-config.1 columns.1 getdefs.1 xml2ag.1
MAN3= ao_string_tokenize.3 configFileLoad.3 optionFileLoad.3 \
diff --git a/devel/cc65/Makefile b/devel/cc65/Makefile
index 9358b9f5e098..71ee9162bba2 100644
--- a/devel/cc65/Makefile
+++ b/devel/cc65/Makefile
@@ -3,6 +3,7 @@
PORTNAME= cc65
PORTVERSION= 2.13.3
+PORTREVISION= 1
DISTVERSIONPREFIX= sources-
CATEGORIES= devel
MASTER_SITES= http://bj.spline.de/cc65/ \
@@ -14,11 +15,15 @@ COMMENT= Cross-compiler for 6502-based systems, includes 65816 assembler
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+USES= shebangfix
USE_BZIP2= yes
USE_PERL5_BUILD=yes
USE_GMAKE= yes
MAKEFILE= ${WRKSRC}/make/gcc.mak
MAKE_JOBS_UNSAFE=yes
+SHEBANG_FILES= src/ca65html/ca65html \
+ src/ca65/macpack/cvt-mac.pl \
+ src/ld65/cfg/cvt-cfg.pl
SUB_FILES= pkg-message
diff --git a/devel/coccinelle/Makefile b/devel/coccinelle/Makefile
index b3a3be5b6064..9a8cb94a893b 100644
--- a/devel/coccinelle/Makefile
+++ b/devel/coccinelle/Makefile
@@ -10,11 +10,13 @@ EXTRACT_SUFX= .tgz
MAINTAINER= avg@icyb.net.ua
COMMENT= Coccinelle is a program matching and transformation engine
+USES= shebangfix
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_PERL5_BUILD=yes
USE_PYTHON= 2.5+
USE_OCAML= 3.0+
+SHEBANG_FILES= configure
MAN1= spatch.1
diff --git a/devel/otrs/Makefile b/devel/otrs/Makefile
index 8524818c1624..7d80552f5949 100644
--- a/devel/otrs/Makefile
+++ b/devel/otrs/Makefile
@@ -3,6 +3,7 @@
PORTNAME= otrs
PORTVERSION= 3.1.14
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://ftp.otrs.org/pub/otrs/ \
ftp://ftp.samurai.com/pub/otrs/ \
@@ -48,6 +49,8 @@ SMTP_DESC= Send email via SMTP
REPORTS_MODULES_DESC= Reports support
USE_BZIP2= yes
+USES= shebangfix
+SHEBANG_FILES= bin/*.pl
OTRSDIR= ${PREFIX}/otrs
USERS= ${PORTNAME}