aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2010-12-13 05:37:25 +0800
committerpgollucci <pgollucci@FreeBSD.org>2010-12-13 05:37:25 +0800
commitc7f0afc0d849823d0632b8884e7fd42994b4c7bb (patch)
tree99f63763a3bb609b079a00631cb6ccc6b192f170 /devel
parentbf78de59331747800061d9840df071b061f20787 (diff)
downloadfreebsd-ports-gnome-c7f0afc0d849823d0632b8884e7fd42994b4c7bb.tar.gz
freebsd-ports-gnome-c7f0afc0d849823d0632b8884e7fd42994b4c7bb.tar.zst
freebsd-ports-gnome-c7f0afc0d849823d0632b8884e7fd42994b4c7bb.zip
This module provides the ability to search a path-like environment variable
for a file (that does not necessarily have to be an executable). WWW: http://search.cpan.org/dist/File-SearchPath/
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-File-SearchPath/Makefile23
-rw-r--r--devel/p5-File-SearchPath/distinfo2
-rw-r--r--devel/p5-File-SearchPath/pkg-descr4
-rw-r--r--devel/p5-File-SearchPath/pkg-plist2
5 files changed, 32 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 501cff6086b9..3ae12e90c87d 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1670,6 +1670,7 @@
SUBDIR += p5-File-ReadBackwards
SUBDIR += p5-File-Remove
SUBDIR += p5-File-SafeDO
+ SUBDIR += p5-File-SearchPath
SUBDIR += p5-File-ShareDir
SUBDIR += p5-File-ShareDir-Install
SUBDIR += p5-File-ShareDir-PAR
diff --git a/devel/p5-File-SearchPath/Makefile b/devel/p5-File-SearchPath/Makefile
new file mode 100644
index 000000000000..b0880769afd3
--- /dev/null
+++ b/devel/p5-File-SearchPath/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: p5-File-SearchPath
+# Date created: 2010-12-12
+# Whom: Philip M. Gollucci <pgollucci@p6m7g8.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= File-SearchPath
+PORTVERSION= 0.06
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Search for a file in an environment variable path
+
+RUN_DEPENDS= p5-Env-Path>=0:${PORTSDIR}/devel/p5-Env-Path
+
+PERL_MODBUILD= yes
+
+MAN3= File::SearchPath.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-File-SearchPath/distinfo b/devel/p5-File-SearchPath/distinfo
new file mode 100644
index 000000000000..93d09f01a3cc
--- /dev/null
+++ b/devel/p5-File-SearchPath/distinfo
@@ -0,0 +1,2 @@
+SHA256 (File-SearchPath-0.06.tar.gz) = ffd6485d407c4013162ccf026b8120e6da1d94aaf3a47aa767e1b4b7546eb274
+SIZE (File-SearchPath-0.06.tar.gz) = 7252
diff --git a/devel/p5-File-SearchPath/pkg-descr b/devel/p5-File-SearchPath/pkg-descr
new file mode 100644
index 000000000000..a712694e0b51
--- /dev/null
+++ b/devel/p5-File-SearchPath/pkg-descr
@@ -0,0 +1,4 @@
+This module provides the ability to search a path-like environment variable
+for a file (that does not necessarily have to be an executable).
+
+WWW: http://search.cpan.org/dist/File-SearchPath/
diff --git a/devel/p5-File-SearchPath/pkg-plist b/devel/p5-File-SearchPath/pkg-plist
new file mode 100644
index 000000000000..24cba5e1062f
--- /dev/null
+++ b/devel/p5-File-SearchPath/pkg-plist
@@ -0,0 +1,2 @@
+%%SITE_PERL%%/File/SearchPath.pm
+@dirrm %%SITE_PERL%%/File