aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2014-06-07 17:25:58 +0800
committerdanfe <danfe@FreeBSD.org>2014-06-07 17:25:58 +0800
commitcb6be62e9de873522c2ba1929714f8c3436f2aff (patch)
tree662db127c9e116df3821ce34b372b9089ccfd153 /devel
parent66ea863ccc830e526acfc0f51f95e0b7a28b927f (diff)
downloadfreebsd-ports-gnome-cb6be62e9de873522c2ba1929714f8c3436f2aff.tar.gz
freebsd-ports-gnome-cb6be62e9de873522c2ba1929714f8c3436f2aff.tar.zst
freebsd-ports-gnome-cb6be62e9de873522c2ba1929714f8c3436f2aff.zip
Stagify; cleanup Makefile; define LICENSE (BSL); utilize OPTIONS helpers.
NB: New version 1.4.6p4 is available
Diffstat (limited to 'devel')
-rw-r--r--devel/poco/Makefile31
1 files changed, 12 insertions, 19 deletions
diff --git a/devel/poco/Makefile b/devel/poco/Makefile
index 121f9e3ee9da..5938afa3a0a6 100644
--- a/devel/poco/Makefile
+++ b/devel/poco/Makefile
@@ -1,7 +1,8 @@
-# Created by: wes@FreeBSD.org
+# Created by: Wes Peters <wes@FreeBSD.org>
# $FreeBSD$
PORTNAME= poco
+# New version 1.4.6p4 is available; please use DISTVERSION upon updating
PORTVERSION= 1.4.3
CATEGORIES= devel net
MASTER_SITES= SF/${PORTNAME}/sources/${PORTNAME}-${PORTVERSION}
@@ -10,30 +11,22 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}p1
MAINTAINER= wes@FreeBSD.org
COMMENT= C++ Portable Components library
+LICENSE= BSL
+
CONFLICTS= poco-ssl-[0-9]*
+USES= gmake tar:bzip2
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --config=FreeBSD
+USE_LDCONFIG= yes
+
OPTIONS_DEFINE= TEST SAMPLES
SAMPLES_DESC= Build sample programs
-CONFIGURE_ARGS= --config=FreeBSD
-USES= gmake
-
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ! ${PORT_OPTIONS:MTEST}
-CONFIGURE_ARGS+= --no-tests
-.endif
-
-.if ! ${PORT_OPTIONS:MSAMPLES}
-CONFIGURE_ARGS+= --no-samples
-.endif
-
-GNU_CONFIGURE= yes
-USE_BZIP2= yes
-USE_LDCONFIG= yes
+TEST_CONFIGURE_OFF= --no-tests
+SAMPLES_CONFIGURE_OFF= --no-samples
post-patch:
- @${REINPLACE_CMD} -e "s/ =/ ?=/g" ${WRKSRC}/build/config/FreeBSD
+ @${REINPLACE_CMD} -e 's/ =/ ?=/' ${WRKSRC}/build/config/FreeBSD
.include <bsd.port.mk>