aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormm <mm@FreeBSD.org>2011-07-11 17:24:44 +0800
committermm <mm@FreeBSD.org>2011-07-11 17:24:44 +0800
commitcb8efb8b57f92c463819546c17b7d237ed5587bd (patch)
treee82cb1333770c982cece957d34725c5b419f4d3f /devel
parent38cf04b1dcafc1287b6129b748a378e9de8ed9ba (diff)
downloadfreebsd-ports-gnome-cb8efb8b57f92c463819546c17b7d237ed5587bd.tar.gz
freebsd-ports-gnome-cb8efb8b57f92c463819546c17b7d237ed5587bd.tar.zst
freebsd-ports-gnome-cb8efb8b57f92c463819546c17b7d237ed5587bd.zip
Put common code for PEAR channels to devel/pear/bsd.pear.channel.mk
Diffstat (limited to 'devel')
-rw-r--r--devel/pear-channel-horde/Makefile28
-rw-r--r--devel/pear-channel-phpunit/Makefile28
-rw-r--r--devel/pear/bsd.pear.channel.mk27
3 files changed, 39 insertions, 44 deletions
diff --git a/devel/pear-channel-horde/Makefile b/devel/pear-channel-horde/Makefile
index 7c0f6a5de768..427f8a69533d 100644
--- a/devel/pear-channel-horde/Makefile
+++ b/devel/pear-channel-horde/Makefile
@@ -8,29 +8,13 @@
PORTNAME= pear-channel-horde
PORTVERSION= 20110304
CATEGORIES= devel www pear
-MASTER_SITES= #no master sites
-DISTFILES= #no distfiles
MAINTAINER= mm@FreeBSD.org
-COMMENT= PEAR Channel pear.horde.org
+COMMENT= PEAR channel ${PEAR_CHANNEL_HOST}
-BUILD_DEPENDS= ${LOCALBASE}/bin/pear:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${LOCALBASE}/bin/pear:${PORTSDIR}/devel/pear
+PEAR_CHANNEL_HOST= pear.horde.org
+PEAR_CHANNEL_ALIAS= horde
-NO_BUILD= yes
-
-LPEARDIR?= share/pear
-
-PLIST_FILES= ${LPEARDIR}/.channels/.alias/horde.txt \
- ${LPEARDIR}/.channels/pear.horde.org.reg \
- "@exec ${MKDIR} %D/${LPEARDIR}/.registry/.channel.pear.horde.org"
-PLIST_DIRS= ${LPEARDIR}/.registry/.channel.pear.horde.org
-
-do-install:
- @${MKDIR} ${PREFIX}/${LPEARDIR}/.registry/.channel.pear.horde.org
- @${INSTALL_DATA} ${FILESDIR}/pear.horde.org.reg \
- ${PREFIX}/${LPEARDIR}/.channels/pear.horde.org.reg
- @${ECHO_CMD} -n pear.horde.org > \
- ${PREFIX}/${LPEARDIR}/.channels/.alias/horde.txt
-
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear/bsd.pear.channel.mk"
+.include <bsd.port.post.mk>
diff --git a/devel/pear-channel-phpunit/Makefile b/devel/pear-channel-phpunit/Makefile
index 4a253628f84b..6091be27b556 100644
--- a/devel/pear-channel-phpunit/Makefile
+++ b/devel/pear-channel-phpunit/Makefile
@@ -8,29 +8,13 @@
PORTNAME= pear-channel-phpunit
PORTVERSION= 20110327
CATEGORIES= devel www pear
-MASTER_SITES= #no master sites
-DISTFILES= #no distfiles
MAINTAINER= mm@FreeBSD.org
-COMMENT= PEAR Channel pear.phpunit.de
+COMMENT= PEAR channel ${PEAR_CHANNEL_HOST}
-BUILD_DEPENDS= ${LOCALBASE}/bin/pear:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${LOCALBASE}/bin/pear:${PORTSDIR}/devel/pear
+PEAR_CHANNEL_HOST= pear.phpunit.de
+PEAR_CHANNEL_ALIAS= phpunit
-NO_BUILD= yes
-
-LPEARDIR?= share/pear
-
-PLIST_FILES= ${LPEARDIR}/.channels/.alias/phpunit.txt \
- ${LPEARDIR}/.channels/pear.phpunit.de.reg \
- "@exec ${MKDIR} %D/${LPEARDIR}/.registry/.channel.pear.phpunit.de"
-PLIST_DIRS= ${LPEARDIR}/.registry/.channel.pear.phpunit.de
-
-do-install:
- @${MKDIR} ${PREFIX}/${LPEARDIR}/.registry/.channel.pear.phpunit.de
- @${INSTALL_DATA} ${FILESDIR}/pear.phpunit.de.reg \
- ${PREFIX}/${LPEARDIR}/.channels/pear.phpunit.de.reg
- @${ECHO_CMD} -n pear.phpunit.de > \
- ${PREFIX}/${LPEARDIR}/.channels/.alias/phpunit.txt
-
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear/bsd.pear.channel.mk"
+.include <bsd.port.post.mk>
diff --git a/devel/pear/bsd.pear.channel.mk b/devel/pear/bsd.pear.channel.mk
new file mode 100644
index 000000000000..adaeb272ee9c
--- /dev/null
+++ b/devel/pear/bsd.pear.channel.mk
@@ -0,0 +1,27 @@
+# $FreeBSD$
+#
+# Common code for PEAR channels
+
+MASTER_SITES?= #no master sites
+DISTFILES?= #no distfiles
+
+BUILD_DEPENDS?= ${LOCALBASE}/bin/pear:${PORTSDIR}/devel/pear
+RUN_DEPENDS?= ${LOCALBASE}/bin/pear:${PORTSDIR}/devel/pear
+
+NO_BUILD?= yes
+
+LPEARDIR?= share/pear
+PEAR_CHANNEL_REG?= ${FILESDIR}/${PEAR_CHANNEL_HOST}.reg
+
+PLIST_FILES= ${LPEARDIR}/.channels/.alias/${PEAR_CHANNEL_ALIAS}.txt \
+ ${LPEARDIR}/.channels/${PEAR_CHANNEL_HOST}.reg \
+ "@exec ${MKDIR} %D/${LPEARDIR}/.registry/.channel.${PEAR_CHANNEL_HOST}"
+PLIST_DIRS= ${LPEARDIR}/.registry/.channel.${PEAR_CHANNEL_HOST}
+
+
+do-install:
+ @${MKDIR} ${PREFIX}/${LPEARDIR}/.registry/.channel.${PEAR_CHANNEL_HOST}
+ @${INSTALL_DATA} ${PEAR_CHANNEL_REG} \
+ ${PREFIX}/${LPEARDIR}/.channels/
+ @${ECHO_CMD} -n ${PEAR_CHANNEL_HOST} > \
+ ${PREFIX}/${LPEARDIR}/.channels/.alias/${PEAR_CHANNEL_ALIAS}.txt