aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2007-03-09 11:16:12 +0800
committerclsung <clsung@FreeBSD.org>2007-03-09 11:16:12 +0800
commitcca95f617607588c895dc8e818002a64074d566a (patch)
tree911f9558cfb354284ea341632ea7b8d3ee454521 /devel
parent84993795285a4202ea09e0ad01f7c37f6f92bea1 (diff)
downloadfreebsd-ports-gnome-cca95f617607588c895dc8e818002a64074d566a.tar.gz
freebsd-ports-gnome-cca95f617607588c895dc8e818002a64074d566a.tar.zst
freebsd-ports-gnome-cca95f617607588c895dc8e818002a64074d566a.zip
- This patch allows to use more than one gem file in rubygems port by defining DISTFILES.
PR: ports/109711 Submitted by: Alexander Logvinov <ports_AT_logvinov dot com> Approved by: maintainer (Jonathan Weiss)
Diffstat (limited to 'devel')
-rw-r--r--devel/ruby-gems/Makefile.common10
1 files changed, 9 insertions, 1 deletions
diff --git a/devel/ruby-gems/Makefile.common b/devel/ruby-gems/Makefile.common
index 512f1239f1b8..2bc29f31d232 100644
--- a/devel/ruby-gems/Makefile.common
+++ b/devel/ruby-gems/Makefile.common
@@ -41,5 +41,13 @@ PLIST_SUB+= PORTVERSION="${PORTVERSION}" \
RUBYGEMBIN= ${LOCALBASE}/bin/gem
+.if defined(DISTFILES)
+GEMFILES= ${DISTFILES:C/:[^:]+$//}
+.else
+GEMFILES= ${DISTNAME}${EXTRACT_SUFX}
+.endif
+
do-install:
- ${RUBYGEMBIN} install --no-ri --install-dir ${PREFIX}/lib/ruby/gems/${REV} ${DISTDIR}/${DIST_SUBDIR}/${DISTNAME}${EXTRACT_SUFX}
+.for _D in ${GEMFILES}
+ ${RUBYGEMBIN} install --no-ri --install-dir ${PREFIX}/lib/ruby/gems/${REV} ${DISTDIR}/${DIST_SUBDIR}/${_D}
+.endfor