aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorpat <pat@FreeBSD.org>2002-05-23 08:32:04 +0800
committerpat <pat@FreeBSD.org>2002-05-23 08:32:04 +0800
commitccf69d9370f1b396c50c57421c2d6633769fc944 (patch)
tree37fc7529631cbcd2c3a85c29acc1e32a3a3b58e7 /devel
parentd4a41cc316fff92f393d9f66a4121809b2ecbb51 (diff)
downloadfreebsd-ports-gnome-ccf69d9370f1b396c50c57421c2d6633769fc944.tar.gz
freebsd-ports-gnome-ccf69d9370f1b396c50c57421c2d6633769fc944.tar.zst
freebsd-ports-gnome-ccf69d9370f1b396c50c57421c2d6633769fc944.zip
Fix ports for building with -current without perl
PR: 38359 Submitted by: maintainer
Diffstat (limited to 'devel')
-rw-r--r--devel/decompyle/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/devel/decompyle/Makefile b/devel/decompyle/Makefile
index 8038a0de865b..207bf6f22840 100644
--- a/devel/decompyle/Makefile
+++ b/devel/decompyle/Makefile
@@ -17,8 +17,15 @@ USE_PYTHON= yes
USE_PYDISTUTILS= yes
PLIST_SUB= PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR:S,${LOCALBASE}/,,g}
+.include <bsd.port.pre.mk>
+
post-patch:
+.if ${OSVERSION} < 500036
${PERL} -pi -e 's,/usr/bin/env python2,${PYTHON_CMD},' \
${WRKSRC}/scripts/decompyle
+.else
+ ${SED} -i.orig -e 's,/usr/bin/env python2,${PYTHON_CMD},' \
+ ${WRKSRC}/scripts/decompyle
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>