aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorbrooks <brooks@FreeBSD.org>2013-10-24 22:46:26 +0800
committerbrooks <brooks@FreeBSD.org>2013-10-24 22:46:26 +0800
commitcf1807b0e46927921ce67c08ff9dc98cd3828d32 (patch)
tree5bbf0e7e7b776ec57d4ebc7599ebec4f46c69a5a /devel
parentdf5b6cca77ae31cbe1def220e860ab66b2ad2055 (diff)
downloadfreebsd-ports-gnome-cf1807b0e46927921ce67c08ff9dc98cd3828d32.tar.gz
freebsd-ports-gnome-cf1807b0e46927921ce67c08ff9dc98cd3828d32.tar.zst
freebsd-ports-gnome-cf1807b0e46927921ce67c08ff9dc98cd3828d32.zip
Fix build with libc++ by importing r178240.
Submitted by: tijl (via commit to devel/llvm)
Diffstat (limited to 'devel')
-rw-r--r--devel/llvm32/Makefile2
-rw-r--r--devel/llvm32/files/patch-svn-r17824086
2 files changed, 87 insertions, 1 deletions
diff --git a/devel/llvm32/Makefile b/devel/llvm32/Makefile
index 46c681f76c52..ddff1ae159e4 100644
--- a/devel/llvm32/Makefile
+++ b/devel/llvm32/Makefile
@@ -2,7 +2,7 @@
PORTNAME= llvm
PORTVERSION= 3.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel lang
MASTER_SITES= http://llvm.org/releases/${PORTVERSION}/
DISTNAME= ${PORTNAME}-${PORTVERSION}.src
diff --git a/devel/llvm32/files/patch-svn-r178240 b/devel/llvm32/files/patch-svn-r178240
new file mode 100644
index 000000000000..d79cf9a6ad68
--- /dev/null
+++ b/devel/llvm32/files/patch-svn-r178240
@@ -0,0 +1,86 @@
+$FreeBSD$
+------------------------------------------------------------------------
+r178240 | hhinnant | 2013-03-28 15:47:50 +0000 (Thu, 28 Mar 2013) | 17 lines
+
+Seciton 24.2.2 of the C++ standard, [iterator.iterators], Table 106
+requires that the return type of *r for all iterators r be reference,
+where reference is defined in [iterator.requirements.general]/p11 as
+iterator_traits<X>::reference, and X is the type of r.
+
+But in CFG.h, the dereference operator of PredIterator and SuccIterator
+return pointer, not reference.
+
+Furthermore the nested type reference is value_type&, which is not the
+type returned from operator*().
+
+This patch simply makes the iterator::reference type value_type*, which
+is what the operator*() returns, and then re-lables the return type as
+reference.
+
+From a functionality point of view, the only difference is that the
+nested reference type is now value_type* instead of value_type&.
+------------------------------------------------------------------------
+Index: include/llvm/Support/CFG.h
+===================================================================
+--- include/llvm/Support/CFG.h (revision 178239)
++++ include/llvm/Support/CFG.h (revision 178240)
+@@ -27,8 +27,9 @@
+
+ template <class Ptr, class USE_iterator> // Predecessor Iterator
+ class PredIterator : public std::iterator<std::forward_iterator_tag,
+- Ptr, ptrdiff_t> {
+- typedef std::iterator<std::forward_iterator_tag, Ptr, ptrdiff_t> super;
++ Ptr, ptrdiff_t, Ptr*, Ptr*> {
++ typedef std::iterator<std::forward_iterator_tag, Ptr, ptrdiff_t, Ptr*,
++ Ptr*> super;
+ typedef PredIterator<Ptr, USE_iterator> Self;
+ USE_iterator It;
+
+@@ -40,6 +41,7 @@
+
+ public:
+ typedef typename super::pointer pointer;
++ typedef typename super::reference reference;
+
+ PredIterator() {}
+ explicit inline PredIterator(Ptr *bb) : It(bb->use_begin()) {
+@@ -50,7 +52,7 @@
+ inline bool operator==(const Self& x) const { return It == x.It; }
+ inline bool operator!=(const Self& x) const { return !operator==(x); }
+
+- inline pointer operator*() const {
++ inline reference operator*() const {
+ assert(!It.atEnd() && "pred_iterator out of range!");
+ return cast<TerminatorInst>(*It)->getParent();
+ }
+@@ -100,10 +102,11 @@
+
+ template <class Term_, class BB_> // Successor Iterator
+ class SuccIterator : public std::iterator<std::bidirectional_iterator_tag,
+- BB_, ptrdiff_t> {
++ BB_, ptrdiff_t, BB_*, BB_*> {
+ const Term_ Term;
+ unsigned idx;
+- typedef std::iterator<std::bidirectional_iterator_tag, BB_, ptrdiff_t> super;
++ typedef std::iterator<std::bidirectional_iterator_tag, BB_, ptrdiff_t, BB_*,
++ BB_*> super;
+ typedef SuccIterator<Term_, BB_> Self;
+
+ inline bool index_is_valid(int idx) {
+@@ -112,6 +115,7 @@
+
+ public:
+ typedef typename super::pointer pointer;
++ typedef typename super::reference reference;
+ // TODO: This can be random access iterator, only operator[] missing.
+
+ explicit inline SuccIterator(Term_ T) : Term(T), idx(0) {// begin iterator
+@@ -142,7 +146,7 @@
+ inline bool operator==(const Self& x) const { return idx == x.idx; }
+ inline bool operator!=(const Self& x) const { return !operator==(x); }
+
+- inline pointer operator*() const { return Term->getSuccessor(idx); }
++ inline reference operator*() const { return Term->getSuccessor(idx); }
+ inline pointer operator->() const { return operator*(); }
+
+ inline Self& operator++() { ++idx; return *this; } // Preincrement