aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2006-02-06 23:43:08 +0800
committergarga <garga@FreeBSD.org>2006-02-06 23:43:08 +0800
commitd1731e58b87687abac196196840a89ee92b1e6f3 (patch)
tree46b21356fc477ef870fc5961975eb4a5d4cf3677 /devel
parent6e3d75f86ad83ced638dd7bb81b5b3b99b618047 (diff)
downloadfreebsd-ports-gnome-d1731e58b87687abac196196840a89ee92b1e6f3.tar.gz
freebsd-ports-gnome-d1731e58b87687abac196196840a89ee92b1e6f3.tar.zst
freebsd-ports-gnome-d1731e58b87687abac196196840a89ee92b1e6f3.zip
Quite often, when dealing with dates, we don't just want to know
information about one particular date, but about a range of dates. For example, we may wish to know whether a given date is in a particular range, or what the overlap is between one range and another. This module lets you ask such questions. WWW: http://search.cpan.org/dist/Date-Range PR: ports/92848 Submitted by: Zach Thompson <hideo@lastamericanempire.com>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Date-Range/Makefile25
-rw-r--r--devel/p5-Date-Range/distinfo3
-rw-r--r--devel/p5-Date-Range/pkg-descr7
-rw-r--r--devel/p5-Date-Range/pkg-plist5
5 files changed, 41 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index df092fb3557e..c132585d9d1b 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -825,6 +825,7 @@
SUBDIR += p5-Date-Leapyear
SUBDIR += p5-Date-Manip
SUBDIR += p5-Date-Pcalc
+ SUBDIR += p5-Date-Range
SUBDIR += p5-Date-Roman
SUBDIR += p5-Date-Set
SUBDIR += p5-Date-Simple
diff --git a/devel/p5-Date-Range/Makefile b/devel/p5-Date-Range/Makefile
new file mode 100644
index 000000000000..20aaaff4f0c3
--- /dev/null
+++ b/devel/p5-Date-Range/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: devel/p5-Date-Range
+# Date created: 05 February 2006
+# Whom: Zach Thompson <hideo@lastamericanempire.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Date-Range
+PORTVERSION= 1.40
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Date
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= hideo@lastamericanempire.com
+COMMENT= Date::Range - work with a range of dates
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Date/Simple.pm:${PORTSDIR}/devel/p5-Date-Simple
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Date::Range.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Date-Range/distinfo b/devel/p5-Date-Range/distinfo
new file mode 100644
index 000000000000..2bfc8fcb2809
--- /dev/null
+++ b/devel/p5-Date-Range/distinfo
@@ -0,0 +1,3 @@
+MD5 (Date-Range-1.40.tar.gz) = 129953865843a0ca5a41ba0620a8ce73
+SHA256 (Date-Range-1.40.tar.gz) = e0e84a2577ed2c3829b385705db5690c639b6da4e0910f2941df2cfd8c8d4934
+SIZE (Date-Range-1.40.tar.gz) = 4693
diff --git a/devel/p5-Date-Range/pkg-descr b/devel/p5-Date-Range/pkg-descr
new file mode 100644
index 000000000000..89566eebb458
--- /dev/null
+++ b/devel/p5-Date-Range/pkg-descr
@@ -0,0 +1,7 @@
+Quite often, when dealing with dates, we don't just want to know
+information about one particular date, but about a range of dates. For
+example, we may wish to know whether a given date is in a particular
+range, or what the overlap is between one range and another. This module
+lets you ask such questions.
+
+WWW: http://search.cpan.org/dist/Date-Range
diff --git a/devel/p5-Date-Range/pkg-plist b/devel/p5-Date-Range/pkg-plist
new file mode 100644
index 000000000000..17a67d8a315a
--- /dev/null
+++ b/devel/p5-Date-Range/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Date/Range.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Date/Range/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Date/Range
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Date
+@dirrmtry %%SITE_PERL%%/Date