aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2010-10-10 09:15:10 +0800
committerkuriyama <kuriyama@FreeBSD.org>2010-10-10 09:15:10 +0800
commitd208db356ff59f0532d8b7c1af0e4fb9768771e5 (patch)
treeb66648e973819fa69d4a290efb7affb3a345583f /devel
parent86e1fb0905763751963c337dafe435c4fe2753dd (diff)
downloadfreebsd-ports-gnome-d208db356ff59f0532d8b7c1af0e4fb9768771e5.tar.gz
freebsd-ports-gnome-d208db356ff59f0532d8b7c1af0e4fb9768771e5.tar.zst
freebsd-ports-gnome-d208db356ff59f0532d8b7c1af0e4fb9768771e5.zip
POEx::Role::SessionInstantiation provides a nearly seamless
integration for non-POE objects into a POE environment. It does this by handling the POE stuff behind the scenes including allowing per instances method changes, session registration to the Kernel, and providing some defaults like setting an alias if supplied via the attribute or constructor argument, or defining a _default that warns if your object receives an event that it does not have. This role exposes your class' methods as POE events. WWW: http://search.cpan.org/dist/POEx-Role-SessionInstantiation/
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-POEx-Role-SessionInstantiation/Makefile38
-rw-r--r--devel/p5-POEx-Role-SessionInstantiation/distinfo3
-rw-r--r--devel/p5-POEx-Role-SessionInstantiation/pkg-descr11
-rw-r--r--devel/p5-POEx-Role-SessionInstantiation/pkg-plist14
5 files changed, 67 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index d3e0d9067a04..48ae58146c7d 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1982,6 +1982,7 @@
SUBDIR += p5-POE-Test-Loops
SUBDIR += p5-POE-XS-Loop-Poll
SUBDIR += p5-POE-XS-Queue-Array
+ SUBDIR += p5-POEx-Role-SessionInstantiation
SUBDIR += p5-POEx-Types
SUBDIR += p5-POSIX-strptime
SUBDIR += p5-PPerl
diff --git a/devel/p5-POEx-Role-SessionInstantiation/Makefile b/devel/p5-POEx-Role-SessionInstantiation/Makefile
new file mode 100644
index 000000000000..6bf5bcfc42d9
--- /dev/null
+++ b/devel/p5-POEx-Role-SessionInstantiation/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: POEx::Role::SessionInstantiation
+# Date created: 10 Oct 2010
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= POEx-Role-SessionInstantiation
+PORTVERSION= 1.102610
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/N/NP/NPEREZ
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension of Moose role for turning objects into POE sessions
+
+RUN_DEPENDS= \
+ p5-MooseX-CompileTime-Traits>=0:${PORTSDIR}/devel/p5-MooseX-CompileTime-Traits \
+ p5-MooseX-Declare>0:${PORTSDIR}/devel/p5-MooseX-Declare \
+ p5-MooseX-Types>0:${PORTSDIR}/devel/p5-MooseX-Types \
+ p5-MooseX-Types>0:${PORTSDIR}/devel/p5-MooseX-Types \
+ p5-POE>0:${PORTSDIR}/devel/p5-POE \
+ p5-POEx-Types>=0:${PORTSDIR}/devel/p5-POEx-Types \
+ p5-aliased>0:${PORTSDIR}/devel/p5-aliased
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= POEx::Role::Event.3 \
+ POEx::Role::SessionInstantiation.3 \
+ POEx::Role::SessionInstantiation::Meta::POEState.3 \
+ POEx::Role::SessionInstantiation::Meta::Session::Events.3 \
+ POEx::Role::SessionInstantiation::Meta::Session::Implementation.3 \
+ POEx::Role::SessionInstantiation::Meta::Session::Magic.3 \
+ POEx::Role::SessionInstantiation::Meta::Session::Sugar.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-POEx-Role-SessionInstantiation/distinfo b/devel/p5-POEx-Role-SessionInstantiation/distinfo
new file mode 100644
index 000000000000..f616073f66b2
--- /dev/null
+++ b/devel/p5-POEx-Role-SessionInstantiation/distinfo
@@ -0,0 +1,3 @@
+MD5 (POEx-Role-SessionInstantiation-1.102610.tar.gz) = eec75436e518c6546df2e85eac29778d
+SHA256 (POEx-Role-SessionInstantiation-1.102610.tar.gz) = a6e3c523998869e8dd30b91d91f1248ac44360aa7caec74e204128bf839fd5a9
+SIZE (POEx-Role-SessionInstantiation-1.102610.tar.gz) = 19895
diff --git a/devel/p5-POEx-Role-SessionInstantiation/pkg-descr b/devel/p5-POEx-Role-SessionInstantiation/pkg-descr
new file mode 100644
index 000000000000..04cf4b43a168
--- /dev/null
+++ b/devel/p5-POEx-Role-SessionInstantiation/pkg-descr
@@ -0,0 +1,11 @@
+POEx::Role::SessionInstantiation provides a nearly seamless
+integration for non-POE objects into a POE environment. It does this
+by handling the POE stuff behind the scenes including allowing per
+instances method changes, session registration to the Kernel, and
+providing some defaults like setting an alias if supplied via the
+attribute or constructor argument, or defining a _default that warns
+if your object receives an event that it does not have.
+
+This role exposes your class' methods as POE events.
+
+WWW: http://search.cpan.org/dist/POEx-Role-SessionInstantiation/
diff --git a/devel/p5-POEx-Role-SessionInstantiation/pkg-plist b/devel/p5-POEx-Role-SessionInstantiation/pkg-plist
new file mode 100644
index 000000000000..49730539e5d3
--- /dev/null
+++ b/devel/p5-POEx-Role-SessionInstantiation/pkg-plist
@@ -0,0 +1,14 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/POEx/Role/SessionInstantiation/.packlist
+%%SITE_PERL%%/POEx/Role/Event.pm
+%%SITE_PERL%%/POEx/Role/SessionInstantiation.pm
+%%SITE_PERL%%/POEx/Role/SessionInstantiation/Meta/POEState.pm
+%%SITE_PERL%%/POEx/Role/SessionInstantiation/Meta/Session/Events.pm
+%%SITE_PERL%%/POEx/Role/SessionInstantiation/Meta/Session/Implementation.pm
+%%SITE_PERL%%/POEx/Role/SessionInstantiation/Meta/Session/Magic.pm
+%%SITE_PERL%%/POEx/Role/SessionInstantiation/Meta/Session/Sugar.pm
+@dirrm %%SITE_PERL%%/POEx/Role/SessionInstantiation/Meta/Session
+@dirrm %%SITE_PERL%%/POEx/Role/SessionInstantiation/Meta
+@dirrm %%SITE_PERL%%/POEx/Role/SessionInstantiation
+@dirrmtry %%SITE_PERL%%/POEx/Role
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/POEx/Role/SessionInstantiation
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POEx/Role