aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorobraun <obraun@FreeBSD.org>2008-02-29 04:53:43 +0800
committerobraun <obraun@FreeBSD.org>2008-02-29 04:53:43 +0800
commitd332bfbd1a2e55e6c1998a6396ca79e16e96c448 (patch)
tree8147a9630336a7e0deb99299dbc31b0f756eda8d /devel
parent286fdc2ac3c2d4a690b399fc2724f7d2cde5fe0f (diff)
downloadfreebsd-ports-gnome-d332bfbd1a2e55e6c1998a6396ca79e16e96c448.tar.gz
freebsd-ports-gnome-d332bfbd1a2e55e6c1998a6396ca79e16e96c448.tar.zst
freebsd-ports-gnome-d332bfbd1a2e55e6c1998a6396ca79e16e96c448.zip
UUAG is the Utrecht University Attribute Grammar system.
Generates Haskell files from an attribute grammar specification It is a preprocessor for Haskell which makes it easy to write catamorphisms (that is, functions that do to any datatype what foldr does to lists). You can define tree walks using the intuitive concepts of inherited and synthesized attributes, while keeping the full expressive power of Haskell. maintainer: Arie Middelkoop <ariem@cs.uu.nl> license: GPL-2 WWW: http://www.cs.uu.nl/wiki/HUT/AttributeGrammarSystem package-url: http://nix.cs.uu.nl/dist/hut/ PR: ports/121152 Submitted by: Giuseppe Pilichi aka Jacula Modyun <jacula at gmail.com>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/hs-uuagc/Makefile41
-rw-r--r--devel/hs-uuagc/distinfo3
-rw-r--r--devel/hs-uuagc/pkg-descr12
-rw-r--r--devel/hs-uuagc/pkg-plist3
5 files changed, 60 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 21e50a6a35ff..2d7f3bab3c9a 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -469,6 +469,7 @@
SUBDIR += hs-hpl
SUBDIR += hs-idoc
SUBDIR += hs-tclhaskell-ghc
+ SUBDIR += hs-uuagc
SUBDIR += hs-uulib
SUBDIR += hypersrc
SUBDIR += i386-rtems-binutils
diff --git a/devel/hs-uuagc/Makefile b/devel/hs-uuagc/Makefile
new file mode 100644
index 000000000000..05b33eef9f18
--- /dev/null
+++ b/devel/hs-uuagc/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: hs-uuagc
+# Date created: February 27 2008
+# Whom: Giuseppe Pilichi aka Jacula Modyun <jacula@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= uuagc
+PORTVERSION= 0.9.5
+CATEGORIES= devel haskell
+MASTER_SITES= http://hackage.haskell.org/packages/archive/${PORTNAME}/${PORTVERSION}/
+PKGNAMEPREFIX= hs-
+
+MAINTAINER= jacula@gmail.com
+COMMENT= Attribute Grammar System of Universiteit Utrecht
+
+BUILD_DEPENDS+= ghc:${PORTSDIR}/lang/ghc \
+ hs-uulib>=${PORTVERSION}:${PORTSDIR}/devel/hs-uulib
+LIB_DEPENDS+= gmp.7:${PORTSDIR}/math/libgmp4
+
+GHC_VERSION= 6.8.2
+UUAG_VERSION= ${PORTVERSION}
+
+GHC_CMD= ${LOCALBASE}/bin/ghc
+SETUP_CMD= ./setup
+
+DOCSDIR= ${PREFIX}/share/doc/${DISTNAME}
+
+.SILENT:
+
+do-configure:
+ cd ${WRKSRC} && ${GHC_CMD} --make Setup.hs -o setup -package Cabal \
+ && ${SETUP_CMD} configure --prefix=${PREFIX}
+
+do-build:
+ cd ${WRKSRC} && ${SETUP_CMD} build
+
+do-install:
+ cd ${WRKSRC} && ${SETUP_CMD} install
+
+.include <bsd.port.mk>
diff --git a/devel/hs-uuagc/distinfo b/devel/hs-uuagc/distinfo
new file mode 100644
index 000000000000..20861fd08f01
--- /dev/null
+++ b/devel/hs-uuagc/distinfo
@@ -0,0 +1,3 @@
+MD5 (uuagc-0.9.5.tar.gz) = 1615010c258edfee75039e25444b20de
+SHA256 (uuagc-0.9.5.tar.gz) = c5be435efa609f72c09e175dd5cf7835a060bd7eaf6634ec4cde72ea84b99f25
+SIZE (uuagc-0.9.5.tar.gz) = 167465
diff --git a/devel/hs-uuagc/pkg-descr b/devel/hs-uuagc/pkg-descr
new file mode 100644
index 000000000000..3bd898d0e02c
--- /dev/null
+++ b/devel/hs-uuagc/pkg-descr
@@ -0,0 +1,12 @@
+UUAG is the Utrecht University Attribute Grammar system.
+Generates Haskell files from an attribute grammar specification
+
+It is a preprocessor for Haskell which makes it easy to write catamorphisms
+(that is, functions that do to any datatype what foldr does to lists).
+You can define tree walks using the intuitive concepts of inherited and
+synthesized attributes, while keeping the full expressive power of Haskell.
+
+maintainer: Arie Middelkoop <ariem@cs.uu.nl>
+license: GPL-2
+WWW: http://www.cs.uu.nl/wiki/HUT/AttributeGrammarSystem
+package-url: http://nix.cs.uu.nl/dist/hut/
diff --git a/devel/hs-uuagc/pkg-plist b/devel/hs-uuagc/pkg-plist
new file mode 100644
index 000000000000..f2ca2c9f06ad
--- /dev/null
+++ b/devel/hs-uuagc/pkg-plist
@@ -0,0 +1,3 @@
+bin/uuagc
+%%DOCSDIR%%/LICENSE
+@dirrm %%DOCSDIR%%