aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorhq <hq@FreeBSD.org>2004-11-25 11:58:17 +0800
committerhq <hq@FreeBSD.org>2004-11-25 11:58:17 +0800
commitd5b46401c0eaa9ba8bae403e6078c4b78e1f1fa2 (patch)
treeeb01dd9031e2ae1cebebc289d4f559cdf03aef91 /devel
parent788307461504164af7ae62af340ce164bf3e9268 (diff)
downloadfreebsd-ports-gnome-d5b46401c0eaa9ba8bae403e6078c4b78e1f1fa2.tar.gz
freebsd-ports-gnome-d5b46401c0eaa9ba8bae403e6078c4b78e1f1fa2.tar.zst
freebsd-ports-gnome-d5b46401c0eaa9ba8bae403e6078c4b78e1f1fa2.zip
The Excalibur Configuration package contains extensions to the Avalon Framework
supporting configuration management. This Excalibur component is now deprecated but is still required by some Java packages. WWW: http://excalibur.apache.org/deprecation.html
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/excalibur-configuration/Makefile44
-rw-r--r--devel/excalibur-configuration/distinfo2
-rw-r--r--devel/excalibur-configuration/pkg-descr7
4 files changed, 54 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index ee0b38a94a39..2e04bfe20b88 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -228,6 +228,7 @@
SUBDIR += error
SUBDIR += esdl
SUBDIR += esvn
+ SUBDIR += excalibur-configuration
SUBDIR += f77flow
SUBDIR += fam
SUBDIR += fampp
diff --git a/devel/excalibur-configuration/Makefile b/devel/excalibur-configuration/Makefile
new file mode 100644
index 000000000000..08446fc5a600
--- /dev/null
+++ b/devel/excalibur-configuration/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: excalibur-configuration
+# Date created: 2004-11-19
+# Whom: Herve Quiroz <hq@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= excalibur-configuration
+PORTVERSION= 1.1
+CATEGORIES= devel java
+MASTER_SITES= ${MASTER_SITE_APACHE}
+MASTER_SITE_SUBDIR= avalon/${PORTNAME}/binaries
+
+MAINTAINER= hq@FreeBSD.org
+COMMENT= Configuration management extensions to the Avalon Framework
+
+RUN_DEPENDS= ${JAVALIBDIR}/avalon-framework.jar:${PORTSDIR}/devel/avalon-framework
+
+USE_JAVA= yes
+JAVA_VERSION= 1.2+
+NO_BUILD= yes
+
+PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}.jar
+.if !defined(NOPORTDOCS)
+PORTDOCS= README.txt apidocs
+.endif
+
+.include <bsd.port.pre.mk>
+
+do-install:
+ @${ECHO_MSG} -n ">> Installing JAR as ${JAVAJARDIR}/${PORTNAME}.jar..."
+ @${MKDIR} ${JAVAJARDIR}
+ @${INSTALL_DATA} ${WRKSRC}/${PORTNAME}-${PORTVERSION}.jar ${JAVAJARDIR}/${PORTNAME}.jar
+ @${ECHO_MSG} " [ DONE ]"
+.if !defined(NOPORTDOCS)
+ @${ECHO_MSG} -n ">> Installing documentation in ${DOCSDIR}/..."
+ @cd ${WRKSRC}/docs \
+ && ${FIND} . -type d -exec ${MKDIR} ${DOCSDIR}/apidocs/{} \; \
+ && ${FIND} . -type f -exec ${INSTALL_DATA} {} ${DOCSDIR}/apidocs/{} \;
+ @${INSTALL_DATA} ${WRKSRC}/README.txt ${DOCSDIR}/
+ @${ECHO_MSG} " [ DONE ]"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/excalibur-configuration/distinfo b/devel/excalibur-configuration/distinfo
new file mode 100644
index 000000000000..a5dd17a7d5b6
--- /dev/null
+++ b/devel/excalibur-configuration/distinfo
@@ -0,0 +1,2 @@
+MD5 (excalibur-configuration-1.1.tar.gz) = 1f3656b334f8fe7c67315799595c8319
+SIZE (excalibur-configuration-1.1.tar.gz) = 136076
diff --git a/devel/excalibur-configuration/pkg-descr b/devel/excalibur-configuration/pkg-descr
new file mode 100644
index 000000000000..6e5ef4fb640a
--- /dev/null
+++ b/devel/excalibur-configuration/pkg-descr
@@ -0,0 +1,7 @@
+The Excalibur Configuration package contains extensions to the Avalon Framework
+supporting configuration management.
+
+This Excalibur component is now deprecated but is still required by some Java
+packages.
+
+WWW: http://excalibur.apache.org/deprecation.html