aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2011-02-25 23:10:44 +0800
committerkuriyama <kuriyama@FreeBSD.org>2011-02-25 23:10:44 +0800
commitd7cbc04f1379673aebfef5c140960baea4751c91 (patch)
tree741edada7a096ea67c2d61c623d5d79a50303337 /devel
parent4e14f9c7df2e3da82728c2270b4496ac5ca6b059 (diff)
downloadfreebsd-ports-gnome-d7cbc04f1379673aebfef5c140960baea4751c91.tar.gz
freebsd-ports-gnome-d7cbc04f1379673aebfef5c140960baea4751c91.tar.zst
freebsd-ports-gnome-d7cbc04f1379673aebfef5c140960baea4751c91.zip
This module provides a number of list utility functions, all of which
take an initial code block to control their behaviour. They are variations on similar core perl or List::Util functions of similar names, but which use the block to control their behaviour. For example, the core Perl function sort takes a list of values and returns them, sorted into order by their string value. The sort_by function sorts them according to the string value returned by the extra function, when given each value. WWW: http://search.cpan.org/dist/List-UtilsBy/
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-List-UtilsBy/Makefile21
-rw-r--r--devel/p5-List-UtilsBy/distinfo2
-rw-r--r--devel/p5-List-UtilsBy/pkg-descr10
-rw-r--r--devel/p5-List-UtilsBy/pkg-plist5
5 files changed, 39 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 60561657c68b..f7a943b80022 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1838,6 +1838,7 @@
SUBDIR += p5-List-PowerSet
SUBDIR += p5-List-Rotation-Cycle
SUBDIR += p5-List-Uniq
+ SUBDIR += p5-List-UtilsBy
SUBDIR += p5-Locale-Maketext
SUBDIR += p5-Locale-Maketext-Fuzzy
SUBDIR += p5-Locale-Maketext-Gettext
diff --git a/devel/p5-List-UtilsBy/Makefile b/devel/p5-List-UtilsBy/Makefile
new file mode 100644
index 000000000000..055bcb9bb121
--- /dev/null
+++ b/devel/p5-List-UtilsBy/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: List::UtilsBy
+# Date created: 25 Feb 2011
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= List-UtilsBy
+PORTVERSION= 0.06
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension for higher-order list utility functions
+
+PERL_CONFIGURE= yes
+
+MAN3= List::UtilsBy.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-List-UtilsBy/distinfo b/devel/p5-List-UtilsBy/distinfo
new file mode 100644
index 000000000000..3e5954fa9b9d
--- /dev/null
+++ b/devel/p5-List-UtilsBy/distinfo
@@ -0,0 +1,2 @@
+SHA256 (List-UtilsBy-0.06.tar.gz) = c7a24e898cc8559140706d6756113959026ca88972d06906976869bfef16e3c7
+SIZE (List-UtilsBy-0.06.tar.gz) = 18478
diff --git a/devel/p5-List-UtilsBy/pkg-descr b/devel/p5-List-UtilsBy/pkg-descr
new file mode 100644
index 000000000000..2788949a2907
--- /dev/null
+++ b/devel/p5-List-UtilsBy/pkg-descr
@@ -0,0 +1,10 @@
+This module provides a number of list utility functions, all of which
+take an initial code block to control their behaviour. They are
+variations on similar core perl or List::Util functions of similar
+names, but which use the block to control their behaviour. For
+example, the core Perl function sort takes a list of values and
+returns them, sorted into order by their string value. The sort_by
+function sorts them according to the string value returned by the
+extra function, when given each value.
+
+WWW: http://search.cpan.org/dist/List-UtilsBy/
diff --git a/devel/p5-List-UtilsBy/pkg-plist b/devel/p5-List-UtilsBy/pkg-plist
new file mode 100644
index 000000000000..5eee2be5f130
--- /dev/null
+++ b/devel/p5-List-UtilsBy/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/List/UtilsBy/.packlist
+%%SITE_PERL%%/List/UtilsBy.pm
+@dirrmtry %%SITE_PERL%%/List
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/List/UtilsBy
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/List